Brother printer network support/install and setup

I was just making sure you had tried the AUR package.

I don’t have any other ideas except trying CUPS and checking the Manjaro (link in above post) and Arch wiki:

1 Like

Thank you for your help

Blockquote pamac install lib32-gcc-libs
Nothing to do.
Transaction successfully finished.


I have installed already paman just re-installs the package .

brother_lpdwrapper_dcpj152w is already there cups does not detect the printer to add it?

Why is only HP supported in Manjaro?

I do not own a usb cable for it. I could get one next time I’m in town in 6 months or on the next mail flight in 3 months (I work in remote Australia). But I don’t have these issues on Kubuntu? what is different?

Is all is there and you followed the faq from Brother you should be able to get it to work.
SInce your using the wifi connection it is this part (all done in cups)

For network connection

  1. Connect the printer to the network and turn it on.
  2. Select Modify Printer from the Administration menu.
  3. A list of connected printers appears. Select the target printer from Discovered Network Printers .
  4. Multiple identical printers may be listed depending on the supported network protocols. In that case, list them in descending order.
  5. If the printer is not listed, select Internet Printing protocol (http) , click Continue , and then enter http://xx.xx.xx.xx (where xx.xx.xx.xx is the IP address of the printer) on the displayed page.
  6. Select the options you want, and then click Continue to confirm your selection.
  7. Click Modify Printer .
  8. Try to print again.
  9. If you cannot print, repeat the steps from step 2 , and then select a different printer in step 3 .
    If you cannot print with any of the listed printers, after selecting Internet Printing protocol (http) , enter the IP address manually.

So I guess you also need your printers ip address

How did you come up with such an idea?
The hplib section in de wiki is just an example because HP has an default printer manager for Linux. Most other printers can be setup by cups. It is nothing more and nothing less.


yes the ip address is but cups doesn’t detect the printer.

I only say that because on my neighbours arch laptop they just add my brother printer by the add printer in kde setting same as I could do in Kubuntu without hplib. I am just trying to understand why manjaro only has HP printer support. That from what I can tell has all the same things every other printer has. But Manjaro is the only one that has an issue with my brother printer and they are the only ones that have hplib or hplip or hputilities? Why don’t Manjaro make their manjaro-printer package without hp in it like the others do?

Thank you again I really appreciate you taking the time to help me and answer my questions

And you can ping the address of the printer?

Manajaro =! Kubuntu
So sometimes you need to configure a bit more.

Speaking of that. could you provide the output of your cups config?

Also there is an alternative method and only works if your printer supports the Bonjour protocol

What is the output of
lpinfo --include-schemes dnssd -v

1 Like

I realise Manjaro is not equal to KDE or Arch what I meant was it only seems to be Manjaro that I have to do this on and not either of the others. The only difference is manjaro only seems to ship with HP support nothing else unlike the others do.

what is the best way for me to share that here for you please? Sorry I’m a newbie on here.

PING ( 56(84) bytes of data.
64 bytes from icmp_seq=1 ttl=255 time=3.27 ms
64 bytes from icmp_seq=2 ttl=255 time=2.68 ms
64 bytes from icmp_seq=3 ttl=255 time=3.69 ms
64 bytes from icmp_seq=4 ttl=255 time=3.40 ms
64 bytes from icmp_seq=5 ttl=255 time=2.78 ms
64 bytes from icmp_seq=6 ttl=255 time=3.76 ms
64 bytes from icmp_seq=7 ttl=255 time=2.89 ms
64 bytes from icmp_seq=8 ttl=255 time=3.16 ms
64 bytes from icmp_seq=9 ttl=255 time=2.91 ms
64 bytes from icmp_seq=10 ttl=255 time=3.58 ms
64 bytes from icmp_seq=11 ttl=255 time=2.65 ms
64 bytes from icmp_seq=12 ttl=255 time=3.06 ms
64 bytes from icmp_seq=13 ttl=255 time=2.59 ms
64 bytes from icmp_seq=14 ttl=255 time=2.65 ms
64 bytes from icmp_seq=15 ttl=255 time=4.17 ms
64 bytes from icmp_seq=16 ttl=255 time=2.88 ms
64 bytes from icmp_seq=17 ttl=255 time=2.74 ms
64 bytes from icmp_seq=18 ttl=255 time=2.68 ms
64 bytes from icmp_seq=19 ttl=255 time=2.68 ms
64 bytes from icmp_seq=20 ttl=255 time=2.58 ms
64 bytes from icmp_seq=21 ttl=255 time=2.73 ms
64 bytes from icmp_seq=22 ttl=255 time=2.80 ms
64 bytes from icmp_seq=23 ttl=255 time=2.68 ms
64 bytes from icmp_seq=24 ttl=255 time=3.91 ms
64 bytes from icmp_seq=25 ttl=255 time=2.69 ms
64 bytes from icmp_seq=26 ttl=255 time=3.54 ms
64 bytes from icmp_seq=27 ttl=255 time=7.28 ms
64 bytes from icmp_seq=28 ttl=255 time=2.74 ms
64 bytes from icmp_seq=29 ttl=255 time=2.64 ms
64 bytes from icmp_seq=30 ttl=255 time=2.61 ms
64 bytes from icmp_seq=31 ttl=255 time=5.15 ms
64 bytes from icmp_seq=32 ttl=255 time=2.82 ms
64 bytes from icmp_seq=33 ttl=255 time=2.67 ms

No problem.

You can find how in this item

and then specifically How to Format “Code” in the Forum

So basically.

Open the file in an text editor like kedit for instance.
select and copy the text
paste here
Select the text and click </> in the toolbar.

Also I think you missed a question.
What is the output of
lpinfo --include-schemes dnssd -v

If there is no /etc/cups/cupsd.c(which I think is the case) could you provide the output of etc/cups/cups-browsed.conf

1 Like

The vast majority of printers supports PCL.

There is usually very little to get a networked Brother printer to print - just connect using JetDirect to IP:9100 using the common HP 4L driver - this will work with almost any network printer.

What may be harder is if you try to use a software package to connect to such MFC’s more advanced functionality such as remote scanning.

Only very few know about the built-in webserver in almost any network printer. Try point your browser to the printers local IP address. Unless you want the browser to jump onto the internet and issue a search for the IP - the format is important. Always terminate a request for a local webservice with a / (frontslash) e.g.

The webservice usually provide access to some the printers advanced funtions - e.g. scanning - in which case you download the image using your browser.


Your right, but so should be adding the printer manually by specifying a socket:// ( in this case).

Benefit can be printer specific options.

1 Like

Sorry my fault. I should have paid better attention. The output of

lpinfo --include-schemes dnssd -v
network dnssd://Brother%20DCP-J152W._ipp._tcp.local/?uuid=e3248000-80ce-11db-8000-142d2763584c

until I learn this forum better I uploaded both etc/cups/cupsd.conf and etc/cups/cups-browsed.conf



Thanks again

Great oke lets try something here.

We are going to connect the printer with the Bonjour protocol

First check if avahi in installed. If not install it.

Next we start the daemon

sudo systemctl start avahi-daemon

and enable it

sudo systemctl enable avahi-daemon

Oke that’s step one so to say.

As you can see you have an dnssd output the number behind " uuid=" is important. In this case less because you only have one output but keep that number in mind.

goto cups so
Administration and add printer.
If needed fill in your credentials.

In Discovered Network Printers pick your printer, but make sure you don’t pick the fully driverless one.

(If there is no printer there is something wrong.)

push continue

If all went oke you should see the same dnssd line in Cups at the connection line. If you want you can modify name, description and location.

push continue

Now since you installed the printer drivers select the correct printer software under model (not the driverless or the IPP everywhere one) and add the printer.

This should normaly do the trick

1 Like

Just in case:

If cannot add Printer and it lists as “Forbidden”

sudo usermod -a -G sys your user name

Then add printer as normal

Administration Tab-add the printer

system-config-printer from the official repositories may be of some help.

1 Like

Okay I did



goto cups so
Administration and add printer.
If needed fill in your credentials.

I did that. I entered my credentials. It showed me

Discovered Network Printers: 
Brother DCP-J152W (Brother DCP-J152W)
Brother DCP-J152W (Brother DCP-J152W)
Brother DCP-J152W (fully driverless) (Brother DCP-J152W)

I tried the first one and the second one I did not try the fully driverless like you said.
the page loaded for a long time then showed

This site can’t be reached
The web page at might be temporarily down or it may have moved permanently to a new web address.

We are moving camp tomorrow and we will not be high enough to get any mobile coverage. So I think I’ll just try to quickly install Kubuntu as at least that just works and does not only come with hp support like manjaro does. I do not know when we will be back in range and I’ve wasted my only day off in a month to try fix this mess.

As I said before this printer used to work fine and does on my android phone, my neighbours Arch install, Kubuntu another guy even can use it wirelessly on his Win10 laptop all are setup the same on the same hotspot from my phone. The only difference is Manjaro and they are the only ones that have hp support which is what I’m thinking the issue is (Not that I have anyway of proving that) and I don’t feel like or think I should have to have the headache that this has caused out of nowhere nor the headache of unstitching hplib / hplip / hp tools or whatever it is from the system all because of some daft decision by the Manjaro team.

One last time I am so grateful for all of your gracious time, help and patience.
I’m sorry I am frustrated now (NOT! at you at all) at the situation and having to do a full clean install of Kubuntu.

To any Manjaro Devs please look into removing all the hp bloat as a mandatory part of manjaro-printer (sure have it installed by default but have it as an optional package) and make the printing setup as easy as every other distro. Please?

I’d even pay to have a package nohp-manjaro-printer at this point

Oke but it shows up now so it should work if you can get passed the.

The web page at **** might be temporarily down or it may have moved

This is kinda strange, that should not happen and I wonder how this can happen.
unless cups stops for some strange reason.

All I know is with Bonjour it work 9 out of 10 times.

I dunno if Kubuntu uses that for default.

1 Like

Okay as just a thought experiment I figured I had nothing to lose so I removed manjaro-printer and hplip.
Before I did I typed out everything that both had as dependencies (I hope I format this right lol)

from hplip
python-dbus python-distro ghostscript net-snmp foomatic-db-engine python-gobject 
libxcrypt cups sane python-pillow python-reportlab rpcbind python-pyqt5 libusb wget

from manjaro-printer
cups cups-pdf cups-pk-helper ghostscript gsfonts foomatic-db foomatic-db-gutenprint-ppds 
python-gobject python-pyqt5 python-pysmbc python-reportlab splix colord-sane system- 
config-printer print-manager skanlite

there seems to be very few packages difference between hplip and manjaro-printer. Once those to were removed I did

sudo pacman -S cups cups-pdf cups-pk-helper python-dbus python-distro ghostscript net- 
snmp foomatic-db-engine python-gobject libxcrypt sane python-pillow python-reportlab    
rpcbind python-pyqt5 libusb wget gsfonts foomatic-db foomatic-db-gutenprint-ppds python- 
pysmbc splix colord-sane system-config-printer print-manager skanlite

the brother-dcpj152w was still installed from before

rebooted (again…) as I did after installing lib32-gcc-libs and brother-dcpj152w

went to kde settings > printers > add printer followed the steps and used the fully driverless drivers and everything is working perfectly.

I can’t definitively say it absolutely was hplip (you would be better at guessing that than me) but it’s my guess as that is the only actual package that really changed. From what little I understand manjaro-printer just is used to install all the other packages. Users should not have to go through this kind of hell to get a printer working and it shows that the Manjaro devs have no logical reason to make hplip a mandatory package of manjaro-printer by all means have it installed by default and as an optional dependency but not as a mandatory package. That’s just my opinion anyway.

@SLaItEr You are a legend mate Thank you so very much. best of luck and I hope to see you on the forums at some point in the future

To everyone else thank you for taking the time and helping as well I really appreciate it

1 Like

Perfect and thx

One little side note.
driverless always work, but not all options of the printer driver are available so its my last resort if with driver does not work. Thats why I wanted to check if the driver does the job first.

With network printing and Bonjour this option is always present for basis printing and that is because not all manufacturers supplying drivers for Linux. This way all printers can work. Its also possible for USB connected printers but then you need IPP over USB.

1 Like

there is a strange thing though if I type hp in the application dashboard search both hp device manager and hp-uiscan still show up under applications but they do not work. I guess the Manjaro Devs love hp that much :rofl: :rofl:

in xfce you can right click on it and choose to hide the application or use Menu Editor (Menu Libre) to deal with that. I am guessing you still have a .desktop file in ~/.local/share/applications and possibly elsewhere. Little things like that bother me too.

Thanks. I’m using KDE. I know about menu editor

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.