Brother Printer - MFC-L5700DW setup

Hello, I installed the CUPS driver for the closest printer I could find to mine.
I found drivers for MFC-L5750DW and installed them. When I attempt to print, I hear the machine spool, but no print gets accomplished. I can ping the IP address. I can search for it in BRAdmin Light and find it. I’m able to print a test page from BRAdmin Light, rest the password there etc. So it seems that I can print test pages, and nothing else so far.

can someone help me figure what I might be missing to make a successful print?

Presently my setup is over wifi, though I could switch to USB or LAN if need be.

Thanks in advance everyone!


I would try via USB and see if you print then. That will help narrow down where the issue might be.

Have you tried setting it up in CUPS to use AirPrint or IPP protocols? Then you won’t need specific drivers.

Hi @Sepulther ,
I wonder whether you could post the printer you have and also check the following page, in order to find the drivers:
CUPS/Printer-specific problems - ArchWiki

As @maycne.sonahoz pointed out, at the end of the listed drivers there are instructions for using IPP protocols.

Hope this help, regards

I have it plugged in via USB cable and it still behaves the same way. Maybe there are some nuances worth considering?

So as I’m reading about how to do that, it is referencing a SAMBA software. Is that something I should use as my interface with CUPS?

“CUPS provides backends for printing over parallel, serial, and USB ports, and over the network via the IPP, JetDirect (AppSocket), and Line Printer Daemon (“LPD”) protocols. Additional backends are available in network service packages such as the SMB backend included with the popular SAMBA software.”

If it is possible to set this up so a computer on my network can be a server and allow me to print remotely, that would be awesome. Is that what this is saying I can do with CUPS?

I see these instructions for compiling, installing, and the launching it. I could have swore I installed it from the add/remove program tool. Which manner do you suggest that I use to install CUPS?

Hello, yes, It’s a Brother MFC-L5700DW.
I looked on that page and the closest I found was this one: MFC-L2700DW

I noticed here that USB can be a problem, so I’m unplugging that for now.
"You might experience some trouble while using the USB port on certain models.

Brother provides a shell script to create udev rules to prevent the use of IPP-over-USB. This might solve USB printing problems but means that you need to use the legacy LPR driver."

I’ll read all of this over and see if I can successfully get one print out of this machine :smiley:

I tried using the ps-printer-app from: snapcraft ps-printer-app

I loaded it in my browser at this link: http://localhost:8000/addprinter
This loaded a menu where I eventually found an error that it could not use the drivers. I attempted autodetect, and I also searched the list. There is nothing really even close in there.

Are there any other options that I can attempt? I’m still looking into CUPS and I’m wondering if I’m going to be able to do all of these things. It’s an incredibly complicated process and I’ve already encountered some issues that prevent me from completing the process. Is there an easier way to work with CUPS, or is there some other system that I can attempt to print on my Brother MFC-L5700DW?

Thank you for all the suggestions and help everyone!


There is a driver in AUR for MFC-L5700DN. Would that be useful? Also did you set up using the Printer set-up tool in system settings?

When I download it, I get an error. It says “Error while configuring brother-mfc-l5700-dn”
Maybe if I can resolve this I can get it to print? Does anyone know how I can troubleshoot an install that doesn’t work?

From the error I got these commands from the error:

  • Either add the printer with its socked address "Socket://
    and get feedback “No such file or directory” even though the ip address I entered is what BRAdmin Light tells me is the ip of my printer.

  • Or (recommended) install nss-mdns and update the file /etc/nsswitch.conf so that
    the hosts line contains mdns (e.g. ‘hosts: files mdns_minimal dns mdns’).
    so when I check this one, it’s already installed, and I’m not sure how to do the update they recommend. Maybe someone can help me finish this part and it might be the fix I need?

I’m also hoping that it’ll work though I have the DW and the driver is for a DN printer. If I can complete the install, maybe this one would do it.

Applications >> System >> Manage Printing → localhost:631
which loaded the CUPS admin page. I was reading some instructions in there and did

lpinfo -m
and it resulted in output lpinfo: Success

So I’m not really sure what it did, but I then enter the command
lpadmin -p MFC-L5700DW -E -v socket:// -m everywhere
and it resulted in output
lpadmin: IPP Everywhere driver requires an IPP connection.

So maybe this method could yield results if I can figure how to create an IPP connection. I did some poking around research and did not find anything obvious quickly that would help me to overcome this error.

Thanks eddier!

I haven’t set any printing server that way, so i can’t tell. Though since you mentioned it already having network capability, configuring a Samba server for it is likely unneeded.

You may want to favor packages already available in the repositories, which is the case here.

Adding Your First Printer from the Web

The CUPS web server provides a user-friendly “wizard” interface for adding your printers. Rather than figuring out which device URI and PPD file to use, you can instead click on the appropriate listings and fill in some simple information. Enter the following URL in your web browser to begin:


Click on the Add Printer button to add a printer.
CUPS Software Administrators Manual

See also the Arch wiki: CUPS - ArchWiki

As it is, I have 2 drivers installed:

I was able to find the admin page, and select the drivers for my specific printer. Then I view the jobs that I attempt on this page:


I can see the print job that I run as a test, and it just hangs there. This function doesn’t even wake up the printer, or cause it to spool. Before when I attempted a print, at least the printer would make some noise and pretend like it was going to print. In this case I get no response from the printer. I attempted with USB, and with wifi. The way it reads when I look up “all prints” to include ones that were cancelled etc. it says that the prints were completed unless I actively cancel it. In which case it says that it printed, but includes “Unable to cancel print job.” I am able to print a test-page from the CUPS page, just like I was able the other way, so it seems that he interface is working to some degree. I added my user to the list of authorized users just in case. When I looked at the job status in the Jobs page, it sais “Canceling print job.” though I didn’t manually tell it to say that. It seems that it either says it printed it, and didn’t, or it just cancels it by default for some reason I cannot discern yet.

Is there a method to see more detail about precisely what is happening that causes it to post that the job completed, though it never went, or that it is cancelled, though I didn’t instruct that?

Thanks guys!

One is very old (2017)
brother-mfc-l5750dw seems to be the correct one

To avoid choosing the wrong and/or defunct driver when you set up your printer, I’d remove the first one, just to mitigate possible issues due to mix-up on your part.

So I partially solved my issue. I was able to successfully produce my first legitimate print that wasn’t a test page.

I’m having an issue now that it’s spitting out 3 more pages of additional material with every print job I process.

I think we can consider this one solved.

I found at localhost:631/admin/ the link to add printer.
I added the printer, but it didn’t work, so I went back in to see if I had options, and I found the option under Other Network Printers: Internet Printing Protocol (ipp)

As soon as I setup this printer, I was able to print.
Now I get pages that say Unclassified x2, and an additional page. Now I get to figure how to deselect those options. I thought they would be on each page that printed :smiley:

Thank you for your help and encouragement everyone! You’ve been awesome!