Brother pinting double sided upside down

Hi all!

I’ve recently changed my old Brother laser printer for a new HL-L3270CDW. Works like a charm in linux with driverless option. As a matter of fact, when experimenting in first install, it’s own CUPS driver was not completely OK, it was printing non centered in paper, while driverless works just fine.

But I was trying today to print double sided, and theres an strange issue: no matter if I choose long-sided or short-sided, it always prints short-sided, so it’s not usable for 99% of works.

Dou you know if t’s there any solution for that keeping the driverless option? If not, I’ll have to try to configure it with it’s own CUPS, which has this alignement problem, and also uses to be less stable (in my experience with other brother printers).


Why driverless? There is a driver available from the AUR. Install via pamac GUI or manually via terminal/makepkg:

pamac build brother-hl-l3270cdw

It’s not perfect. As said, it makes the print to be missaligned on page, and sometimes the printer becomes not accessible.
The driverless option works like a charm. Except for the duplex printing… If that could be repaired, would be the best solution.

Trying again the driver from AUR, it doesn’t even print double side (and still is misaligned). So, it’s not usable. At least driverless just fails on duplex.
It’s a very big problem, no prope duplex printing at the moment for the printer, it seems…

SOLVED: There are several AUR packages for Hl-L3270CDW.
The problems were happening with brother-hll3270cdw . It’s PPD it’s defective, it seems.
Use instead brother-hl-l3270cdw, this one works fine. Both in alignement and in duplex printing (and everything else, fortunately).
Driverless is just OK if you don’t use dulex printing, but this won’t work properly.

That’s what I said from the start :upside_down_face:

1 Like

Yes, you’re right… Just didn’t realized there were two different packages with nearly same name, and one (the one with most update version, BTW, so first option) not working…
Thanks, for checking that message from you was the key for finding solution

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.