Brother MFC-7820N Scanner not working

I recently installed Manjaro after using Ubuntu + Debian and have problems getting my scanner working. I tried to install the RPM driver from Brother, but it didn’t work, I tried Brscan5 from the AUR without luck and it looks as though none of the AUR drivers are going to work. Does anyone have an idea what I should try next?

One more thing, I’m writing this from my phone so will add more info when I get back to my PC.

Did you try brother-lpr-drivers-laser or brother-cups-wrapper-laser? The MFC-7820N is mentioned as supported.

I didn’t because the printer works perfectly. The Brscan5 made my scanner visible, but scanning isn’t possible

Well, you might have mentioned that in your first post.

What have you found searching the internet? I’m sure you’re not the first person with the same query :face_with_monocle:

I haven’t searched the internet, I came here 1st because it was logical. I’ve read all the posts I could find about brother scanning in this forum. In Debian I had a similar problem, but I eventually found the answer in a setting in bios, I hoped to find something unexpected here as well.

The brother support site says they don’t support Manjaro for my model, but that doesn’t mean it won’t work.

BIOS settings should have nothing to do with scanning. What setting? :thinking:

Of course not. They only provide DEB or RPM packages–which can be unpacked and packaged for Arch-based distros easily.

I never would have expected it either, but after spending 3 days of un/installing drivers and running tests the nice person in the Debian Forum helping me gave up. In looking through the various messages we got back one in particular caught my eye and I searched the internet for it and found the answer on github, Secure Boot had to be turned off in bios. I did it, it worked and I closed my ticket in the forum.

That’s why I’m in this forum looking for help, not a hard time.

This is true, but if I could easily create the package myself I wouldn’t have asked for help.

RE the BIOS thing. Is it at all possible that the reason things worked after “making BIOS changes” was simply the fact you re-started after making changes prior to re-booting? Something like this bit me in the ‘waste basket’ in the past.

This question has nothing to do with bios, it has to do with help getting my scanner working. If anybody could help me sort out the various info I’ve found concerning it I’d appreciate it, otherwise please PM me and I’d be happy to discuss it.

Please let me clarify this, I made this statement without having access to my PC or my old emails, now that I’m at my PC I see that the bios thing was with my Broadcom wifi problem, not with the scanner. Both were in the same few days and I confused them. Could we please just stick to my problem from now on?


So much info to sort through and maybe I’m too dumb, but I hope to find someone who’s done it before and could give me the short form. As I said, I’m new to Manjaro and I’m slowly learning that each Linux flavor has it’s own quirks.Thank you in advance!

The scanner driver on the Brother website is brscan2 and the scan-key tool is brscan-skey. They’re both already in the AUR, no need to package it yourself. :wink:

Now I understand, I assumed Brscan5 was the 5th version. Thank you Yochanan for the help, I’ll try it and let you know. :blush:

One question before I begin, I ran

pamac build brscan5

before I asked this question and it created a directory and I assume installed a driver, do I need to remove it before I build the brscan2? If yes, how?

Oh wait, pamac remove brscan5 looks to be the answer.

That was it, I installed brscan2 and it worked immediately. Thank you for your support! Until next time :slight_smile:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.