Brother MFC-240C USB and MFC-J460DW Network

Hello, FYI if anyne from the Manjaro team see this I’m new to Manjaro after having been stuck in the dated world of Red Hat and it’s very good to be here as Manjaro KDE 20.2 is wildly cool!!

That said, it would seem that Printers in the Linux world are universally jacked and my issues with them wasn’t simply due to Red Hat being always out of date… Given that I still figured it would hurt to ask if anyone had information which might point me to something I’ve missed.

I have a fresh install of Manjaro KDE 20.2 and it says it is up to date. It’s running on an older beast that has an eight core AMD and an Nvidia graphics card. I might have built it back in 2014 but it’s still got plently of umpf to it! I also have two Brother printers, an MFC-240C connected via USB 2 and a newer network attached MFC-J460DW printer. I’ve pretty much exhausted all the tings I’ve found out the interweb :-)… I have established that that I can see both printer in the system however attempts to configure them using various methods are never able to print the test page so I assume the lack of support for those printers get close but not close enough… The questions I’d like to generally ask are:

  1. Does an IPP printer require having the drivers for that particular printer? I am assuming it does, since the IPP Everywhere didn’t seem to get any closer than anything else.
  2. Has anyone used/tried the MFC-240C package that can be found in AUR? I know AUR isn’t officially supported ((FYI having a community opportunity to share stuff is very cool)).
  3. Does anyone have one of these printers working?
  4. If I were to go out and buy, yet another, printer for use with my Manjaro system, is there a specific printer which consistently demonstrates reliable Linux functionality, or perhaps a least a printer brand/manufacturer?

I believe asking about scanning would be way across the stupid line (where I find myself all to often :slight_smile:

I’m pretty sure printer issues are a Linux issue and nothing to do with Manjaro/Arch which is so wierd after so much water has crossed the Linux bridge…

Thank you all very much.

Check in Pamac and see if drivers for your printers are available - maybe they can be found in AUR. That’s how I got my Brother MFC-L2710DW working.

Well it would seem I figured it out… well more like stumbled on it… Yesterday when I was trying pretty much every idea I had and probably anybody and everybody on the net that google coould find… anyways my wife gave me a test page which printed on the MFC-J460DW network printer… but I must have missed a successful test page print because I thought everything I tried failed… guess not… and some nice programmer somewhere had the forsight to print all the information I needed onto the test page…

Final solution…and recap… There are no drivers of any kind to be found for a Brothr MFC-J460DW network printer so using the CUPS “Generic IPP Everywhere Printer” driver can be used successfully. I hope this helps someone else… good luck…

Thank you… (Now if I could only stop dreaming about being able to scan…)

There is a driver for MFC-J460DW in the AUR repo.

Wow… I’m kinda doing a double take because I thought I found a package in AUR for my Brother MFC-240C printer and NOT the J460DW… but now I only see the one yoou speak of, which I didn’t think I saw, and I do not see the 240C… I wonder if during all my gyrations of figuring out how to do things in Manjaro / Arch I wound up getting my streams crossed… If I did that might explain why the one I thought was for the 240C that I installed from AUR didn’t work for that printer… I’d have bet my own money I wouldn’t do something that goofy but it would like a good bet that I did.

Thank you for pointing out my error as it will hopefully remind me to slow down a bit before I drown.

Would I be correct in assuming the specif driver in AUR only does print?

Thank you.

Drivers for both printers are listed in the AUR – that’s why I suggested looking there.