Brother HL1110 printer - no driver can be installed

Brother HL1110 printer no driver can be installed

If trying to install driver with Manjaro
Manjaro recommend 7 different HL1070-drivers that do not work.

From the Brother support site, I downloaded driver hl1110lpr-3.0.1-1.i386.deb and hl1110cupswrapper-3.0.1-1.i386.deb

I have converted the packages with debtap to …tar.gz files

and tried with

sudo pacman  -U    packname.tar.gz  

to install these but received:

...architecture not valid
...package has no valid architecture

in Debian/Ubuntu it just works.

Is there any similar method in Manjaro or any other solution ?

Take a look at the link below. The .deb method is most straight forward:

HL-1110 - that is a printer which have I worn out several drum kits with. :slight_smile:

Manjaro does not recommend any drivers - you have probably found them on AUR.

Remove any packages you have experimented with and build the above package.

pamac build brother-hl1118

I am using a old brother as well - HL-2240D and it requires special attention too.


I’ve marked this answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (If you disagree with my choice, just send me a personal message and explain why I shouldn’t have done this or :heart: or :+1: if you agree)

P.S. In the future, please don’t forget to come back to your question after your issue has been solved and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

Please read this:

Especially the section How to install software? as installing .deb files opens your system up to something called dependency hell…


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.