Brother DCP7055W scanner part don't work

Im new on Manjaro. I switched from Windows 10
I have a Combo Printer/Scanner Brother DCP 7055W. The problem is that the scanner don’t work.
I want an USB connection
I installed the package “DCP 7055” from AUR, printing is working well
For the Scan part I installed brscan4 and brscan-skey also from AUR but the scanner isn’t working. When i wan’t to scan something it shows an error message “Invalid Argument”. The scanner don’t scan It is reconized though. :

$ scanimage -L
device `brother4:bus1;dev1’ is a Brother DCP-7055W USB scanner

I tried :

$ scanimage -T
Output format is not set, using pnm as a default.
scanimage: rounded value of br-x from 211.9 to 211.881
scanimage: rounded value of br-y from 355.6 to 355.567
scanimage: sane_start: Invalid argument

The printer seems to be seen on the wrong bus and device compare to sane

$ lsusb
Bus 004 Device 012: ID 04f9:02ce Brother Industries, Ltd DCP-7055W

$ scanimage --help

Here is the last part of the output :

List of available devices:

Sane try to find my scanner in the wrong place Bus1 Device 1 instead of true lsusb position which is Bus 004 Device 012

I don’t know how to solve it.

I even tried on another computer on Debian with propriatary drivers. The problem is the same…

I tried to add this rule in a file in /etc/udev/rules.d/ :

brother scanners rules
ATTRS{idVendor}==“04f9”, MODE=“0666”, GROUP=“scanner”, ENV{libsane_matched}=“yes”

But it didn’t fix anything.

EDIT : The scanner/Printer is working fine on Windows 10

Thanks in advance for your help

For my local printer install of my Brother HL-L2390DW printer-scanner, I did as you did, installing the printer driver and brscan4 via the AUR. Then I pulled up localhost:631 in Firefox, clicked the administration tab, and added the printer there as a local printer. Then I rebooted and my printer and scanner worked well.

I hope that might be helpful. Good luck.


Thanks a lot for your help. I did the localhost:631 part but it didn’t change anything, the problem is still the same :confused:
I don’t wan’t to put my printer/scanner in the bin just because of this invalid argument message :confused:
I wrote to Brother support maybe they will answer and fix the problem. Because on Debian with their drivers its not working eather. Its a shame for the manufacturer when they announce that the device is compatible with linux and its not “at least in 2020”. Maybe they didn’t upgrade their package for a while. Or maybe the problem is only on my side. But i checked a lot of people get this same error on internet.

As a workaround you can use the scan to network function.
I have a folder setup on my NAS, but I guess you could try setting one up on your PC.