Broken tiling, cannot restart with kwin replace

Hi,
Not sure it’s the write category here but I basically cannot resize, move windows. The focus is also broken. I tried changing to awesome tiling or run deepin just to test and it works fine. If i understood correctly, kwin should do the job. but it cannot run since last update (and I tried reinstalling it):

kwin_x11: symbol lookup error: /usr/lib/libkwin.so.5: undefined symbol: drmModeFormatModifierBlobIterNext

I tried kwinft, which made things worse so I switched back.

This happened after updating the system (~1850 packages to update).

Here are some infos that might help:

System:
  Host: david Kernel: 6.0.8-1-MANJARO arch: x86_64 bits: 64
    Desktop: KDE Plasma v: 5.26.3 Distro: Manjaro Linux
Graphics:
  Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630] driver: i915 v: kernel
  Device-2: NVIDIA GP107M [GeForce GTX 1050 Ti Mobile] driver: nvidia
    v: 520.56.06
  Device-3: Logitech HD Pro Webcam C920 type: USB
    driver: snd-usb-audio,uvcvideo
  Device-4: Lite-On Integrated Camera type: USB driver: uvcvideo
  Display: x11 server: X.Org v: 21.1.4 driver: X: loaded: modesetting,nvidia
    gpu: i915,nvidia,nvidia-nvswitch resolution: 1: 2560x1440~60Hz
    2: 1920x1080~60Hz
  API: OpenGL v: 4.6.0 NVIDIA 520.56.06 renderer: NVIDIA GeForce GTX 1050
    Ti/PCIe/SSE2

Thanks in advance

Hello,

Your default DE is KDE Plasma but you also have some custom tiling via

and also you have installed

and you run all with the same user?

Yes

Thanks for the quick answer.

Well, to me that sounds a bit like a very bad combination even tho deepin-kwin depends on kwin

Are you sure you are not into some partial update state?
sudo pacman-mirrors -f5 && sudo pacman -Syyu

It totally looks like it too but I get “There is nothing to do”.
In case it matters, other tiling managers (awesome, deepin) were installed temporarily and removed shortly after. I also rebooted since then.
I was thinking of reinstalling the needed packages, even force overwrite but I don’t know which ones I should target.
I already did kwin kde-applications manjaro-kde-settings sddm-breath-theme manjaro-settings-manager-knotifier manjaro-settings-manager-kcm

If you are fully updated then the only issue i can think of it would be with user configs, and in special with your ~/.config/kwinrc

That was a good hint! But still not working I replaced the /etc/xdg/kwinrc by its default by reinstalling the package manjaro-kde-settings which provides it. Now contains this:

[Desktops]
Number=2

[Plugins]
glideEnabled=true
blurEnabled=true
contrastEnabled=false

My ~/.config/kwinrc contains

[org.kde.kdecoration2]
theme=Breeze

I’m considering waiting next upgrade but not sure how long this will take

Probably more than that file … try with a TMP user, fresh, and see if you can log in with plasma-session, then log in with deepin and then back to plasma and see what changes, and if you are able to reproduce the initial issue.