Broken Manjaro - extract home directory

I have a Raspberry with Manjaro Xfce in my car to use as a player.

I’ve started a long-waited update and pushed some cable and the electricity stopped during the update. After the reboot there was no WiFi and Xfce console was unable to run (I’ve checked the locale files). Then I tried to un-update by installing the previous version as it was in Pacman’s log. It got worse… Now I’m in something like a Kernel Panic mode without ‘mount’ command (it says version is not found or something). I guess this is the end of my first Manjaro installation :slight_smile: Now I need to save my stuff before installing a new Manjaro Gnome.
The main purpose of the system was to process audio. Therefore I’ve made a nice-working ALSA .asoundrc file to have full control of each channel that goes through Asus Xonar U7 sound card to the amplifiers. Now I need this file and other stuff from my /home.

I’ve made a .img file from the SD card and when I mount it I see Overlays directory and files such cmdline.txt and bootcode.bin. How can I extract my /home dir from this .img file?

1 Like

There should be 2 partitions in that .img file. a boot partition and a root partition. The boot partition has a fat32 filesystem and the root partition is an ext4 partition. You have only have mounted the boot partition for what ever reason I have no clue what yo have or have not done in making or mounting the image.


I tried to mount it with WSL on Windows 11, but it did not worked.
Then in Manjaro I checked the img file with ‘fdisk -l’ to determine the start position of the second partition and mounted it with ‘mount -o offset’ and got my files back.
Thank you!


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.