Broken login manager after failed boot with kernel panic

I installed nixos on a second drive. Manjaros grub recognized nixos an i could start both of them this way.
I decided to change the boot-order in order to use the grub from nixos.
It woked for booting nixos, but when i tried to start Manjaro, i got the following error:

I reverted the boot-order change and tried to start Manjaro over its own grub:

  • The screen gets black and stays black
  • I can login on another tty, but when i try to start lightdm the screen just gets black again.

I think it might be a good idea to check the file system. Boot into a manjaro install media. start gparted, find the partition with the OS on it, right click on it and select “check”.

you can modify on Grub screen with option (e)dit

for a manjaro boot ,initrd need 2 files

check in /boot/grub file grub.cfg
you need this for boot , 2 files not one

initrd /boot/amd-ucode.img /boot/initramfs-6.0-x86_64.img

indeed, there are tow files in Manjaros grub configuarations (where it worked) but just one in the config for grub on nixos. @stephane thank you for this hint!

Unfortunately it wont fix the lightdm issue, since it is broken with the correct configured grub too.

Have you tried booting into another kernel other than 6.0? Others have had issues with lightdm and 6.0.

I thought i tried it, but maybe with the the other bootloader…
It really works with kernel 5.15.

Seems starnge to me since i booted it before with kernel 6.0. Just after i tried booting it though grub from nixos it didnt work anymore.
Do you know anything elese about this problem?

I recommend you stick with 5.15 unless you need hardware support for a specific piece of hardware. Kernels are for hardware support. New kernels enable new hardware to function. New kernels also introduce new bugs sometimes. Since they are under development each update can bring new problems.