Broken display after installing Kernel

I have a Lenovo Optimus laptop.
Intel i7 6500U
Integrated Intel HD 520 graphics
Discrete nVidia 940M Graphics

Running Manjaro testing with XFCE and using the proprietary nVidia module, which automatically pulls in the nVidia-Intel-hybrid-prime pack.
Everything runs fine on the 5.10 kernel.
Installing the 5.11.10 kernel pulls in the corresponding kernel-5.11-nvidia-460 package. However after rebooting I get I broken display. At the point of starting X the screen blanks, then will give occasional flickers as small portions of the logon screen are briefly displayed.
Rebooting using the original 5.10 kernel, I uninstalled the 5.11 kernel and tried the 5.12.rc5 experimental kernel. This kernel and appropriate nvidia package work correctly again. Not sure if the problem is the 5.11 kernel or the kernel511-nvidia460 package.
Not so much looking for a solution, as I’ll keep using the experimental 5.12 kernel (or 5.10 if other issues arise from the 5.12 one), but just wanted to raise the issue.

can you try with
linux 54 lts
or linux 419 lts ?

A bit more investigating suggests this is not unique to Manjaro.
Installed openSuse tumbleweed, with a 5.11 kernel and proprietary drivers and get the same issue. Installed stable leaf build and no issues. But then manually moved to tumbleweed and the issue happens again. Rebooting into openSuse tumbleweed but using the original leaf kernel (I think it was 5.8) has no issues, only when using the 5.11 kernel.
Finally tried elementaryOS and again had the same problem with a 5.11 kernel.
Not sure if the problem is the kernel or the official nvidia 460 driver pack for 5.11. Haven’t tried using 5.11 with an earlier nvidia driver pack, but as I can use the later 5.12.rc5 kernel with no issues, I’m not going to lose any more time over it.

you can add others kernels

sudo mhwd-kernel -i linux54
sudo mhwd-kernel -i linux419

update your Grub menu


sudo nano /etc/default/grub
sudo update-grub

reboot select advanced menu
choose other kernel version

I’ll try other kernels tomorrow, though I doubt they’ll cause issues. It’s easier to use the Manjaro kernel tool GUI to install other kernels.
No need to concern myself with grub, I use rEFInd, it’s set to unlimited timeout at the boot selection, so easy to choose my kernel when booting.
I do wish all the major Linux distros would acknowledge rEFInd and desist on insisting that everyone should use grub, however that’s a rant for another forum.

Well no surprises.
Installed 4.19 LTS and 5.4 LTS Kernels and had no issues booting with those kernels.
Also downgraded nvidia drivers to from v460 to v390 and re-installed the 5.11 kernel. Still have the broken display issue using the 5.11 Kernel and the downgraded nvidia drivers.