Broke my ssd hard drive. Can read but cannot write I/O into the partitions

So i am writing this in a live iso of manjaro on the same computer the ssd got corrupted.

I was trying to destroy my own data using the tool “wipe” for then securely replace it with a fresh install of Manjaro. However i was very stupid that night, and decided to run wipe in the same hard drive it was running from. After 20% completion, the pc crashed and i cannot boot from the ssd.

With the live iso, i tried to diagnose and repair the partitions but it was no much help.


  • Identify partitions (gparted can see the filetype and size of the partitions)

  • Recover files with gpart, but only in read mode


I cannot in any shape or form do any writing operations to the drive, if i try to reformat, resize or delete a partition in gparted, it returns this error:

Input/Output error during write on /dev/sda

I cannot use dd or similar tools to shred the data of the hard drive either, they seem get stuck on the operation and i have to kill their tasks.

Sadly fsck doesn’t seem to work either, it will return this if i run it with /dev/sda (running e2fsck with the superblock will return same error):

fsck from util-linux 2.37
fsck.ext2: Bad magic number in super-block while trying to open /dev/sda
The superblock could not be read or does not describe a valid ext2/ext3/ext4
filesystem.  If the device is valid and it really contains an ext2/ext3/ext4
filesystem (and not swap or ufs or something else), then the superblock
is corrupt, and you might try running e2fsck with an alternate superblock:
    e2fsck -b 8193 <device>
    e2fsck -b 32768 <device>

/dev/sda contains `DOS/MBR boot sector; partition 1 : ID=0xee, start-CHS (0x0,0,2), end-CHS (0x3ff,255,63), startsector 1, 500118191 sectors, extended partition table (last)' data

If i try /dev/sda2 (main partition):

fsck from util-linux 2.37
/dev/sda2: clean, 11/15032320 files, 1221151/60128751 blocks

as for dmesg i get constantly the following errors:

exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x0
[  199.868962] ata2.00: irq_stat 0x40000001
[  199.868964] ata2.00: failed command: WRITE DMA
[  199.868969] ata2.00: cmd ca/00:28:00:00:00/00:00:00:00:00/e0 tag 4 dma 20480

exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x0
[  199.901025] ata2.00: irq_stat 0x40000001
[  199.901032] ata2.00: failed command: WRITE DMA EXT
[  199.901048] ata2.00: cmd 35/00:28:88:32:cf/00:00:1d:00:00/e0 tag 14 dma 20480

I/O error, dev sda, sector 0 op 0x1:(WRITE) flags 0x800 phys_seg 5 prio class 0
[  199.918664] Buffer I/O error on dev sda, logical block 0, lost async page write
[  199.918687] Buffer I/O error on dev sda, logical block 1, lost async page write
[  199.918692] Buffer I/O error on dev sda, logical block 2, lost async page write
[  199.918714] Buffer I/O error on dev sda, logical block 3, lost async page write
[  199.918718] Buffer I/O error on dev sda, logical block 4, lost async page write
[  199.918736] ata2: EH complete

the only way i know to save the drive is with dd to 0 the drive, that will at least make it usable again.

dd doesn’t seem to be able to write into the drive. I ran dd wit 0 all night and when i woke up it seemed to not have finished, and dd isn’t verbose so i’m not sure what is happening there.

It is a 250 GB hard drive so dd couldn’t have taken that long right?

Maybe try to create a new Partiton table from live manjaro ? Then reboot ?

did not work, however, the badblock tool with verbose seems to be working! crossing fingers it actually wipes the hard drive clean. Will update once it’s done/crashed.

what command did you use?

first you check which drive: lsblk
the command: sudo dd if=/dev/zero of=/dev/sd? bs=1M status=progress
replace ? with yours.

sadly you answered to late. afaik, badblocks returned that ALL the block are bad, every single one of them, i don’t think i got the chance to repair the hard drive.

just try the dd anyway, what have you got to lose.
there will always be some errors, that’s normal.

If you’re still stuck you might be able to wipe it using the manufacturer’s SSD software (Samsung Magician, Crucial Storage Executive, Kingston SSD Manager, etc). They’ve all got some sort of thing they call “secure erase” to wipe SSDs. I think most of those only install on Windows unfortunately but if you’ve tried everything else you may be able to connect your SSD into a Windows PC and run that as a last resort.

You can also use hdparm.I can’t remember all the commands but if you search online for secure-erase-hdds-ssds-sata-nvme-using-hdparm-nvme-cli-on-linux you will find the info.I used hdparm awhile back to wipe and unlock a couple sdd’s.