Broadcom Wi Fi not working with Manjaro 6.1.12-1

I just installed Manjaro on my 2011 MacBook Pro and my wi fi is not working. Its a Broadcom 4331. Previously worked under Fedora 35 and Mint 20. I believe I need the driver or pkg “firmware-b43-installer.”
I finally figure Pacman is what you use vice apt to install. Then I find out about yacourt and yay.
How do I add a repository or can I download the package and use Pacman to install?
Yes I am old and dumb and wasted two days looking on the net for an answer. Yeah I realize this duplicate a question form Aug 21, but that did not help me.

pamac upgrade
pamac search whatever
pamac install whatever

as root of course.

It should work with broadcom-wl-dkms from the repositories. It should also install dkms as well.
Install via pamac GUI or in terminal:

pamac install broadcom-wl-dkms

Reboot for good measure.

when I do the pamac search firmware-b43-installer
I get failure to query the url …and temporary failure in name resolution
but thanks

when i try pamac install broadcom-wl-dkms

I get a whole lot of mirrors saying “temporary failure in name resolution”
and then failure to commit transaction:failed to retrieve some files.
but thanks.

I feel I am either missing something very simple or this is way harder than it should be.

It needs the internet to load packages, and it needs to load a package to install the wifi driver. Stuck!

The easiest way to fix is temporarily use another method to access the internet, like tether your phone with USB cable.

1 Like

Thanks but I do have an internet cable.
I need to apologize to Richard, I did have the cable plugged in my desktop. I replugged it in the laptop, it did install broadcom-wl-dkms, but my wi fi still did not work. In fact broadcom-wl-dkms was loaded all along, it just doesn’t work with my Broadcom card, I need b43 module and not wl one source says, but can’t find a way to load pkg “firmware-b43-installer" in Manjaro, since it seems to be neither Deb or Ubuntu, but some hybrid Arch Linux.
I am about to deep six Manjaro.
I believe I need to be able to access a repository that has pkg “firmware-b43-installer.” And then figure out the command in Manjaro to load it.
Yeah Manjaro works fine if you do exactly what is lets you do apparently.
Someone else on the web said b43 was blacklisted and Manjaro can’t load it for that reason, only wl, which does not work for me. How hard should it be to load a Linux driver on a Linux system? Very hard.

This guy seems to come closest to a fix, but he still seems to assume you know some things he doesn’t bother to explain
Now this won’t allow me to post a link (though the button show you can post links) but it’s on the Dedoimedo site:

How to enable Broadcom Wireless on Manjaro
Updated: September 13, 2019

there is the package called b43-fwcutter which can be used to get the needed firmware for the kernel module.

Most likely you have a firmware issue as that might not been provided

Can you show the output of inxi -Nyaz

Also which kernel are you using?

Incidentally, this other poster seems to be using the wl driver for a 2011 Macbook Pro, does the chipset match yours?

Edit - here’s the unsuccessful result of a similar quest, although different year macbookpro

Check if you have a lib/firmware/b43 directory with over a hundred files. If not, have a look at this solved thread: B43 driver seems to be installed, but no place to check "enable wifi" in new install? - #43 by 6x12 .

The solution was to install the b43-firmware pkg from AUR and reboot.

Open ‘Add/Remove Software’ (GUI of pamac not pacman!) >> klick 3 vertical dots >> Preferences > > Third Party and activate AUR Support.

ok I have installed b43-fwcutter
Do I need to uninstall broadcom-wl-dkms?
Does b43-fwcutter get the firmware from the arch linux repository automatically or how do download the b43-firmware and then run it,
I linked to AUR but b43-firmware is not showing up in the add/remove software list,
My card pci-id is 14e4:4331 (rev 2) so it should work with b43-firmware if I can just download and install it

zsh: correct ‘inix’ to ‘inxi’ [nyae]? y
Device-1: Broadcom NetXtreme BCM57765 Gigabit Ethernet PCIe driver: tg3
v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: N/A bus-ID: 02:00.0
chip-ID: 14e4:16b4 class-ID: 0200
Device-2: Broadcom BCM4331 802.11a/b/g/n driver: N/A modules: bcma pcie:
gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 03:00.0 chip-ID: 14e4:4331
class-ID: 0280

brodcom-wl-dkms might not work if you don’t have the appropriate linux headers for the kernel that you are using as the linux headers are an optional dependency for dkms

pamac install linux61-headers

From Arch Broadcom wiki:

" BCM4331 noticed to have problems with  b43-firmware-classic.
Use b43-firmware for this card instead, or switch to 
broadcom-wl mentioned below for a more stable experience."

No driver currently loaded.

BCM4331 is supposed to work with wl, can you show the steps you took to try wl?

After installing a driver, it needs to be loaded, either automatically at boot, or manually with modprobe (possibly the dkms compile script calls modprobe? it’s okay to load it again)

For example, after installing one of the wl packages and you’ve finished tweaking it,

sudo modprobe wl

modprobe: FATAL: Module wl not found in directory /lib/modules/6.1.12-1-MANJAR

YES, I installed linux61-headers and that seemed to do the trick to get Broadcom-wl working. In hindsight I wonder if that was all I needed. Still confused but card is working.


1 Like

One quick hopefully final question. How do I get Manjaro to remember my wi fi password? I have to enter it every time I login in to wi fi. THanks

Indeed. FYI, I’ve marked @jrichard326’s post as the solution

Please create a new Support topic as that is not related to your original query.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.