Broadcom bcm4311 does not start on boot. Runs with sudo modprobe b43

Broadcom bcm4311 runs fine when sudo modprobe b43. Does not start on bootup. Some results:
[wayne@wayne-presarioc700notebookpc ~]$ cat /etc/modules
[wayne@wayne-presarioc700notebookpc ~]$ cat /etc/modprobe.d/b43.conf
options b43 allhwsupport=1
[wayne@wayne-presarioc700notebookpc ~]$ cat /etc/modules-load.d/modules.conf

List of modules to load at boot

I have tried to run the following command as well.
sudo mkinitcpio -p linux59
Anyone have any ideas??? I am new to Manjaro, though years ago messed with Lubuntu.

Welcome at the forum, @Al_catraz,

in your case I would try the solution proposed in the Arch wiki:

Thanks for the prompt reply. I don’t know if there was anything specific I was to glean from that link. I have all applicable drivers installed (wifi runs fine). The big issue I have is that it does not start at bootup.

The research I did previously, in the AUR documents, mentioned to add b43 to the end of modules.conf to make start on bootup. I don’t see anything ground breaking in the document you mentioned. I am trying to build the b43-firmware through the pamac packagemanger (weak are the term skills with this one…).

In the Arch wiki link you find for example different settings for /etc/modprobe.d/b43.conf. In your case I would try it and report.

Hi @Al_catraz,
Which linux419-broadcom-wl.conf do you have installed In the directory /etc/modprobe.d/ ?
For example, I have the linux419-broadcom-wl.conf and linux54-broadcom-wl.conf in this directory.

Hope it helps,

cat /etc/modprobe.d/b43.conf
options b43 allhwsupport=1

Found this.
Followed this suggestion " check another modprobe source folder at /usr/lib/modprobe.d/"

Saw the following results.
[wayne@wayne-presarioc700notebookpc modprobe.d]$ cat broadcom-wl-dkms.conf
blacklist b43
blacklist b43legacy
blacklist ssb
blacklist bcm43xx
blacklist brcm80211
blacklist brcmfmac
blacklist brcmsmac
blacklist bcma

Hashtagged the first line “blacklist b43” and saved. Reboot and all working.

1 Like

I could not post the link. I tried to change it so I could. Remove the underscores and the xxx.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.