Broadcom 4321 [14e4:4328] rev03

The only 2007 macs with 2.0GHz Core 2 Duos are the macbook 2,1 and the Imac 5,1. Both have ethernet ports to connect to the internet if wifi isn’t working.

We had a recent post here about trying to get manjaro installed on a macbook 2,1. The main shortfalls are the 32bit efi that would need Refind to boot and the maximum 3GB of Ram that are recognised even if 2x2GB are installed.

Because of these limitations Apple devices made before 2009 are probably too old to run manjaro properly, even if the owner has the skill set and the time to succeed with the actual installation. A much more achievable option to keep these devices in use would be a distro like AntiX that can boot 32bit efi and has a recommended minimum of 512MB of Ram.


OK, thanks. I understand now.
Your wording was a little confusing, which is why I questioned it.

I’m just trying to understand your setup a little more. Do you have both Manjaro and El Capitan booting successfully from rEFInd?

(I’ve used rEFInd in a multiboot environment for many years; BSD, Linux, Mac, Windblows.)

Can I ask… How did you install Manjaro?

Did you ‘flash’ the Manjaro Live Installer ISO to a USB drive, and then install it to another USB drive?

Or, did you only ‘flash’ the Manjaro Live Installer ISO to one USB drive, and that’s the drive you’re using to boot from now?

Hopefully the answers to these questions will help clear up any misunderstandings that I see in several posts above.

It’s a 2007 iMAC 7.1
Intel Core Duo running at 2GHz.
The OS is 10.11.6 running 64 bit.

I flashed the USB drive.
I downloaded and extracted the OS on to the USB drive.
I installed the OS on the USB drive.

Sorry, but that hasn’t answered the questions clearly enough.

Are you saying: you only ‘flashed’ the Manjaro Live Installer ISO to ONE USB drive, and THAT is the drive you’re booting from now?

This only requires a Yes/No answer; and it’s important.

I created a bootable USB drive and installed the ISO.
I installed a boot manger that let’s me choose whether I want to boot up off of the ISO that’s been setup on the USB or boot from the internal hard drive on MAC.
I am able to successfully boot up to either OS (USB with Manjaro or MAC OS on hard drive)

Thank you.

Now let me explain what you have done:

  1. You have written the Manjaro Live Installer ISO to a blank USB.
  2. Then you intalled rEFInd to the ESP on that same USB.

That’s all you’ve done, and this is why it’s important to understand:

  • Manjaro is not installed anywhere.
  • You have the Manjaro Live Installer ISO, which is now a USB.

When you boot into the Live Installer, there is usually a welcome screen “Hello” and you’ll also notice an icon on the desktop, that says “Install Manjaro” (or similar). Correct?

If for some reason it’s not there, it will be in the menu somewhere.

The Manjaro Live Installer is a minimal version of Manjaro (read: it’s basically a demo) which is designed to then install the full version to another location – usually a HDD or SSD. This Live Installer doesn’t have everything needed to run Manjaro properly.

Networking via Ethernet will usually be available (it’s in the kernel) but specific WiFi drivers probably won’t be.

Until Manjaro is actually installed, you will likely not have much luck with getting any WiFi working.

Now, to overcome the limitation of the minimal ISO, download the full ISO, and write that to the USB instead. The full ISO contains everything needed to install Manjaro, though it may not have a Live environment.

Does this explanation now help you understand better?

Understood. Thank you for clearing that up.
There is no welcome screen as well as no desktop icon.
I understand now that it’s a Live Installer which has a minimal ISO, and that I will have to get a full version ISO.

No, that is the wrong message to take away from this - the minimal iso is as good an installer as the full iso is.
You’ll have to use it as such - either one.

It’s not ideal without Internet connectivity. The full ISO, however, doesn’t require Internet to install most everything needed. The downside, of course, is that a Live environment isn’t provided, and there must be somewhere to finally install Manjaro to.

The Takeaway, is that Manjaro must be installed to disk to be able to complete all installation and configuration requirements; no matter which Installer ISO/USB is used.

I downloaded the ISO which happens to be the identical ISO that I previously downloaded: manjaro-xfce-23.1.2-240102-linux.iso
I hashed both ISO files and the files are identical as there was no difference with regard to file integrity. I used the new ISO to boot up and this time it gave me the Welcome screen.
I installed Manjaro into a separate dedicated partition on my hard drive.
The wireless is still not available. I’ll have to work on it when I’m more rested.

Well, that’s some progress, at least.

Thanks for keeping us updated. Enjoy your rest.

Connecting to a modem/router via a network cable will allow things to be a little smoother. Standard network interfaces may be easier to make function, in the meantime.
Is this possible; perhaps a friend with a wired Internet?
I’ll leave you with that thought, for now. Cheers.

1 Like

The aluminium one, I’ve missed that one, sorry. Luckily, this changes everything since Ram upgrades to 6GB couldn’t be easier.

  • Connect ethernet cable or use phone tethering to connect to the internet
  • install b43-firmware pkg
  • run the following commands one after the other.
sudo modprobe -r wl
sudo modprobe b43 allhwsupport=1

and your wifi should come on. If that’s the case you have to make this permanent. Open /etc/modules-load.d/modules.conf and add b43 underneath:

# List of modules to load at boot

Open /etc/modprobe.d folder. Create empty document and name it b43.conf, open it and make it look like this:

options b43 allhwsupport=1

Save and reboot.

1 Like

I was having an issue with tethering from IOS.
I ran these commands to get it to work.
sudo systemctl status ModemManager
sudo systemctl stop ModemManager
sudo systemctl disable ModemManager
sudo systemctl start ModemManager
After reboot I was able to tether and get a connection to the internet.
I will go from here and get the internal card working.
Thanks everyone for your help.

You’re most welcome.

Now that you have a fully installed system, I’ll add this, in case it’s useful:

There was recently an apparent regression in some kernel 6.5/6.6 and 6.1 LTS versions that caused WiFi issues for some users.

The latest iterations of kernel 6.6.x and 6.1.x LTS (and also 6.7.x) seem to have resolved those issues.

I wasn’t certain that it was relevant in your case, but now that you have internet access, it might be worth addressing.

Upgrading to the latest kernels may be worth the effort.
Information about installing kernels can be found in the following link.

1 Like

I updated the kernel to 6.7.
My internal wifi card is repeatedly disconnecting.
This was also happening prior to the kernel update.
It worked for a split second initially.

You might need to disable the usb tethering temporarily to see if it was effective.

I wonder what ‘partially’ supported really means here… Can you run:
to make sure there aren’t any blocks on wlan.

One more thing you could try before you try the alternative broadcom-wl-dkms (needs installing kernel headers first); open NetworkManager settings of your wifi connection and under the ‘Wifi’ tab change ‘Band’ from ‘Automatic’ to one of the offered options instead.

No blocks on.

Do you have a file /etc/modprobe.d/blacklist.conf, if so please show us its contents.