Brightness/volume keys crashes desktop, and black screen on startup - AMD Ryzen 4

Hey, I just dual booted Windows with Manjaro Gnome. I have two problems which makes the laptop annoying to use. I’m new to Linux and all its troubleshooting.


  • X does not normally start without command "startx", sometimes it randomly does start correctly.
  • Keys for changing volume and brightness makes desktop unresponsive (could possibly be only brightness keys, or all function-keys without fn). Most of the time now the desktop crashes immediately when using these keys. UPDATE: same problem happened randomly with international characters like "ø" (possibly a coincidence?).


Everything worked fine when testing on USB flash drive. The first time I booted into Manjaro after install the screen was completely black. I was able to bring up the terminal with a shortcut and start the display manager with the command "startx". The brightness and volume keys worked fine until using them randomly crashed the desktop (everything is unresponsive other than moving mouse, can't click or type anything). When rebooting I got two fails that showed up (along with rest of screen being black and not starting):
  UNIT                                            LOAD   ACTIVE SUB    DESCRIPTION                                                   
● systemd-backlight@backlight:acpi_video0.service loaded failed failed Load/Save Screen Backlight Brightness of backlight:acpi_video0
● systemd-backlight@backlight:amdgpu_bl0.service  loaded failed failed Load/Save Screen Backlight Brightness of backlight:amdgpu_bl0

I installed the newest kernel 5.9 and things worked for a while, but then it broke in the same way again. I have also had the keys work at random for many hours, but then suddenly break again. Adjusting the volume and brightness with the sliders in GUI works fine.


System:    Kernel: 5.8.11-1-MANJARO x86_64 bits: 64 compiler: N/A Desktop: GNOME 3.36.6 Distro: Manjaro Linux 

Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Renoir vendor: Lenovo driver: amdgpu v: kernel bus ID: 06:00.0 
           Device-2: Chicony Integrated Camera type: USB driver: uvcvideo bus ID: 2-2:2 
           Display: server: 1.20.9 driver: amdgpu,ati unloaded: modesetting,radeon,vesa resolution: <xdpyinfo missing> 
           OpenGL: renderer: AMD RENOIR (DRM 3.38.0 5.8.11-1-MANJARO LLVM 10.0.1) v: 4.6 Mesa 20.1.8 direct render: Yes 

I have heard others are having similar problems with the amdgpu driver, but I haven’t found a fix.

I have similar issue with the black screen on my new Beelink GTR Pro with Ryzen R5-3550H. After clean installation I had it couple of times booting to the Gnome logon screen, but most of the time it’s just black screen.

I go around it by opening a TTY terminal and then immediately switch back to to the graphical session (CTRL+ALT+F3 > CTRL+ALT+F1). This weekend I will try to dig deeper.

Today I installed 2 updates:

  • libgdm (3.36.3-6 -> 3.36.3-7)
  • gdm (3.36.3-6 -> 3.36.3-7)

and so far (after 10+ reboots) I did not get the black screen. No other changes to the system, same kernel, etc.

That’s great to hear! I also installed those recently, but my system was randomly working beforehand so I was not sure if they fixed anything or not.