Brightness Sliders and fn Keys do not Work (Brightness can be Changed with acpilight)

This is on a Dell XPS 9700 running KDE Plasma. The slider in the tool tray does not adjust brightness, and neither do the fn keys. Not a huge deal (unlike the audio problem that I still can’t figure out, at least bluetooth headphones work), but vaguely irritating all the same. Poking around in /sys/class/backlight, there are two files: “intel_backlight” and “dell_backlight”. The sliders adjust “dell_backlight”, but “intel_backlight” (which can be modified by xbacklight) decides the actual brightness. Is there a way to switch it over to “dell_backlight”, or, failing that, rewire the slider and function keys to “intel_backlight” instead? “acpi_backlight=vendor” doesn’t work for the purpose, and neither does “acpi_backlight=video”, so I’ve just about exhausted my knowledge on the matter.

Hi, jackiecrazy,
In my Lenovo laptop, I have to enable the fnKeys in Bios setup, if I want them to work. Have you already tried looking for the relative option in your Bios?

Hello gan,
Yes, the fn keys do work. I have been able to successfully use them for audio muting when using headphones and keyboard backlight toggling. They actually do change the light value, but it’s the backlight value of Dell itself, rather than Intel, which is what my system is working off.

Maybe, as a workaround, you could set the brightness with a script.
I know, it isn’t the best in comfort, but you can try it and decide.

#!/bin/sh

# This script sets the brightness to 50

qdbus-qt5 local.org_kde_powerdevil /org/kde/Solid/PowerManagement/Actions/BrightnessControl setBrightness 50

exit 0

I tested it on my laptop and it works.
Save this text in a file with *.sh extension, and save it (for example) on your home directory.
Then, you have to make it executable with:

chmod 775 filename.sh

You can make a link on your desktop. When you want to change brightness to the value in your script, just click on it.
This script, unfortunately, will only be able to change to a fixed value, but you could create two or three scripts with values you usually use.
Waiting a solution more comfortable… :biking_man:

If the script doesn’t work, I would try to install acpilight with

$ sudo pacman -S acpilight

acpillight: a backward-compatible xbacklight replacement based on ACPI

User riccardooo97 on Arch forum has solved his problem with this package.

To prevent problems, I would make a system backup :wink:

I forgot to mention, I do have acpilight. I’ll try out the script though, thanks.

I don’t know what Graphics Drivers everyone is using, but after having this problem on my Dell laptop with Intel 4400 integrated graphics, I changed the driver from “free” to “non-free” (proprietary Intel) and whaddaya know? My Brightness keys worked perfectly.

I’d been looking at all sorts of other things that I thought may have been the problem, but it was that simple! Of course if people are unhappy at using proprietary drivers then this won’t work. Also I have only tested it on my own laptop (Dell Latitude E5440 with a Core i5).

If it’s of any help… :crossed_fingers: :slightly_smiling_face:

Is there actually such a thing as proprietary Intel graphics? I’ve only heard of proprietary Nvidia.

That’s a good point. I’m not sure actually. All I know is I did an install choosing “free” first then again choosing “non-free” on the live iso, and the second one worked.

I wish I could provide more information but that laptop was being used for experiments and in the end Manjaro XFCE and various themes weren’t playing so nicely so I wiped the HDD.

It’s now running an Arch KDE setup instead without any issues. It’s my first pure Arch install though and early days… :smile: