Brightness keys dont work any more

Thinkpad t480
The brightness keys (f5,f6) worked fine until today when i (not rebooted) opened the lid and they dont work any more. Added the bindsym XF86MonBrightnessUp exec --no-startup-id xbacklight -inc 5 line to i3 config.

Since then i tryed rebooting, this article but they didnt worked. When i press the keys i got notification, but nothing happens.

inxi -Fxxz
  Kernel: 5.15.41-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    Desktop: i3 v: 4.20.1 dm: LightDM Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: LENOVO product: 20L6S1LV2F v: ThinkPad T480
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: LENOVO model: 20L6S1LV2F v: SDK0J40697 WIN
    serial: <superuser required> UEFI: LENOVO v: N24ET67W (1.42 )
    date: 11/17/2021
  ID-1: BAT0 charge: 8.8 Wh (47.6%) condition: 18.5/23.9 Wh (77.4%)
    volts: 11.3 min: 11.4 model: LGC 01AV489 serial: <filter>
    status: discharging
  ID-2: BAT1 charge: 10.3 Wh (79.8%) condition: 12.9/24.0 Wh (53.8%)
    volts: 12.2 min: 11.5 model: SMP 01AV452 serial: <filter>
    status: not charging
  Info: quad core model: Intel Core i5-8350U bits: 64 type: MT MCP
    arch: Coffee Lake rev: A cache: L1: 256 KiB L2: 1024 KiB L3: 6 MiB
  Speed (MHz): avg: 800 min/max: 400/1901 boost: disabled cores: 1: 800
    2: 800 3: 800 4: 800 5: 800 6: 800 7: 800 8: 800 bogomips: 30409
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Device-1: Intel UHD Graphics 620 vendor: Lenovo driver: i915 v: kernel
    ports: active: eDP-1 empty: DP-1, DP-2, HDMI-A-1, HDMI-A-2 bus-ID: 00:02.0
    chip-ID: 8086:5917
  Device-2: Chicony Integrated Camera (1280x720@30) type: USB
    driver: uvcvideo bus-ID: 1-8:2 chip-ID: 04f2:b604
  Display: x11 server: X.Org v: 21.1.3 compositor: Picom v: git-7e568
    driver: X: loaded: modesetting alternate: fbdev,vesa gpu: i915
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96
  Monitor-1: eDP-1 model: LG Display 0x0521 res: 1920x1080 dpi: 158
    diag: 355mm (14")
  OpenGL: renderer: Mesa Intel UHD Graphics 620 (KBL GT2)
    v: 4.6 Mesa 22.0.4 direct render: Yes
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Lenovo ThinkPad T480
    driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 chip-ID: 8086:9d71
  Sound Server-1: ALSA v: k5.15.41-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.51 running: yes
  Device-1: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel pcie:
    speed: 2.5 GT/s lanes: 1 bus-ID: 03:00.0 chip-ID: 8086:24fd
  IF: wlp3s0 state: up mac: <filter>
  Local Storage: total: 238.47 GiB used: 58.92 GiB (24.7%)
  ID-1: /dev/nvme0n1 vendor: Intel model: SSDPEKKF256G8L size: 238.47 GiB
    speed: 31.6 Gb/s lanes: 4 serial: <filter> temp: 31.9 C
  ID-1: / size: 116.5 GiB used: 58.89 GiB (50.6%) fs: ext4
    dev: /dev/nvme0n1p5
  ID-2: /boot/efi size: 96 MiB used: 25.3 MiB (26.3%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-1: swap-1 type: file size: 8 GiB used: 0 KiB (0.0%) priority: -2
    file: /swapfile
  System Temperatures: cpu: 44.0 C pch: 39.5 C mobo: N/A
  Fan Speeds (RPM): fan-1: 0
  Processes: 233 Uptime: 19m Memory: 7.51 GiB used: 2.13 GiB (28.4%)
  Init: systemd v: 250 Compilers: gcc: 12.1.0 clang: 13.0.1 Packages:
  pacman: 1392 Shell: Bash v: 5.1.16 running-in: kitty inxi: 3.3.16

What happens if you run the mentioned command in the terminal?

xbacklight -inc 5

1 Like

It is working from terminal
But the keys are not working

Have a look here Lenovo ThinkPad T480 - ArchWiki

1 Like

Sorry, but nope.
I installed the intel driver and added the rule but nope. Nothing changed.

Not sure if i have to mention, a reboot of the system is required.

1 Like

I made that too.
And reloaded the udev rules.
But thanks!