Bridge with tap device

Hi I want to create a bridge so I can communicate with my gns3 install.
I have tried but it does not really work and I wonder If someone could help me and see what is wrong?

so I want to create a bridge with 4 interfaces.
tap0, tap1, br0 and enp0s31f6 (the physical ethernet device).
I can not get the tap devices to “up” so that I can use them to connect to gns3.

nmcli connection up tap0  INT ✘  59s 
Error: Connection activation failed: IP configuration could not be reserved (no available address, timeout, etc.)
Hint: use ‘journalctl -xe NM_CONNECTION=29983195-4775-4cf5-b9b0-13151c5e5ab3 + NM_DEVICE=tap0’ to get more details.

Here is how I created them:

nmcli connection add type tun ifname tap0 con-name tap0 mode tap ipv4.method auto
nmcli connection add type tun ifname tap1 con-name tap1 mode tap ipv4.method auto
nmcli connection add type bridge ifname br0 con-name br0 ipv4.method auto
nmcli con add type bridge-slave ifname tap0 master br0
nmcli con add type bridge-slave ifname tap1 master br0
nmcli con add type bridge-slave ifname enp0s31f6 master br0

then to disable the previous configuration and use the bridge instead:

nmcli con del "Wired connection 1"; nmcli con reload "br0" &

here is some diagnostics I did, ask if you need more:

nmcli connection show                                                                                  ✔ 
NAME                    UUID                                  TYPE      DEVICE    
tap0                    29983195-4775-4cf5-b9b0-13151c5e5ab3  tun       tap0      
tap1                    29a28d57-a27e-4531-baaf-81ead0f82d05  tun       tap1      
br0                     2753365d-9b24-4d42-95ba-873e4f23d97a  bridge    br0       
lo                      f59be18a-9796-41a1-a5df-87ecb958e7a8  loopback  lo        
bridge-slave-enp0s31f6  1a2425ad-4121-41d8-bc5b-bddb0f5fc8e0  ethernet  enp0s31f6 
bridge-slave-tap0       19ba8861-c641-420e-9014-93d89edd6ccb  ethernet  --        
bridge-slave-tap1       7d0434c5-bd2d-4e2b-a928-6a4816f1e879  ethernet  --   

something is wrong with the tap connection:

nmcli connection up bridge-slave-tap1                                                                  ✔ 
Error: Connection activation failed: No suitable device found for this connection (device enp0s31f6 not available because profile is not compatible with device (mismatching interface name)).

I wonder why not the tap devices show in the list?

nmcli device show                                                                                    4 ✘ 
GENERAL.DEVICE:                         br0
GENERAL.TYPE:                           bridge
GENERAL.HWADDR:                         B2:51:A9:CE:D2:72
GENERAL.MTU:                            1500
GENERAL.STATE:                          100 (connected)
GENERAL.CONNECTION:                     br0
GENERAL.CON-PATH:                       /org/freedesktop/NetworkManager/ActiveConnection/2
IP4.ROUTE[1]:                           dst =, nh =, mt = 425
IP4.ROUTE[2]:                           dst =, nh =, mt = 425
IP6.ADDRESS[1]:                         fe80::7780:2263:88cd:edfa/64
IP6.GATEWAY:                            --
IP6.ROUTE[1]:                           dst = fe80::/64, nh = ::, mt = 1024

GENERAL.DEVICE:                         lo
GENERAL.TYPE:                           loopback
GENERAL.HWADDR:                         00:00:00:00:00:00
GENERAL.MTU:                            65536
GENERAL.STATE:                          100 (connected (externally))
GENERAL.CONNECTION:                     lo
GENERAL.CON-PATH:                       /org/freedesktop/NetworkManager/ActiveConnection/1
IP4.GATEWAY:                            --
IP6.ADDRESS[1]:                         ::1/128
IP6.GATEWAY:                            --
IP6.ROUTE[1]:                           dst = ::1/128, nh = ::, mt = 256

GENERAL.DEVICE:                         enp0s31f6
GENERAL.TYPE:                           ethernet
GENERAL.HWADDR:                         70:8B:CD:56:03:05
GENERAL.MTU:                            1500
GENERAL.STATE:                          100 (connected)
GENERAL.CONNECTION:                     bridge-slave-enp0s31f6
GENERAL.CON-PATH:                       /org/freedesktop/NetworkManager/ActiveConnection/5
IP4.GATEWAY:                            --
IP6.GATEWAY:                            --


Please check again this Network bridge - ArchWiki

Hi bogdancovaciu,

Perhaps I’m missing something,
I have read that piece of the article a couple of times and now I reread it agin and could still not understand how I could apply that info to my case.

There is a reason why a VM is recommended for GNS.