BricsCAD installation problem

Hello, im running KDE Plasma Version: 5.24.5 and im having a problem with installing BricsCAD software. Bellow is how i wanted to install it (via AUR), and there is an error:

ERROR: Failure while downloading file://BricsCAD-V21.2.04-en_US.x86_64.rpm

If someone can tell me why this error is happening and if there’s alternatives on installing BricsCAD I will be grateful!

sudo pamac install bricscad-en_us                                                              
Warning: bricscad-en_us is only available from AUR
Preparing...
Cloning bricscad-en_us build files...
Running as unit: run-u196.service
fatal: not a git repository (or any parent up to mount point /var/cache/private)
Stopping at filesystem boundary (GIT_DISCOVERY_ACROSS_FILESYSTEM not set).
Finished with result: exit-code
Main processes terminated with: code=exited/status=128
Service runtime: 7ms
CPU time consumed: 6ms
Running as unit: run-u197.service
Finished with result: success
Main processes terminated with: code=exited/status=0
Service runtime: 5ms
CPU time consumed: 5ms
Running as unit: run-u198.service
Finished with result: success
Main processes terminated with: code=exited/status=0
Service runtime: 462ms
CPU time consumed: 31ms
Generating bricscad-en_us information...
Running as unit: run-u199.service
Finished with result: success
Main processes terminated with: code=exited/status=0
Service runtime: 874ms
CPU time consumed: 993ms
Checking bricscad-en_us dependencies...
Resolving dependencies...
Checking inter-conflicts...

To build (1):
  bricscad-en_us  21.2.04-1    AUR


Edit build files : [e] 
Apply transaction ? [e/y/N] y


Building bricscad-en_us...
Running as unit: run-u200.service
Press ^] three times within 1s to disconnect TTY.
==> Making package: bricscad-en_us 21.2.04-1 (27.05.2022 (пт) 18:17:19)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Downloading BricsCAD-V21.2.04-en_US.x86_64.rpm...
curl: (3) URL using bad/illegal format or missing URL
==> ERROR: Failure while downloading file://BricsCAD-V21.2.04-en_US.x86_64.rpm
    Aborting...
Finished with result: exit-code
Main processes terminated with: code=exited/status=1
Service runtime: 743ms
CPU time consumed: 838ms
Error: Failed to build bricscad-en_us

It is telling you why… :arrow_down:

For packages from the AUR, you must use the build command of pamac, not the install command.

Furthermore, pamac should not be used with sudo .

:arrow_down:

pamac build bricscad-en_us

Read the pinned comment. :wink: