Breath theme problem after partial update

Short story, I got a partial update that broke my system (my notebook froze in the process), not an expert but got to make it working again after reinstalling some packages, for now the only thing I wasn’t able to fix is the breath theme.

The problem:
Some texts on the widgets are colored black when setting global theme to “Breath”, making it really hard to read and I don’t think this is correct (may have broken on the partial update). Not sure if its related, but setting global theme to “Breath Dark” make the menus completely unreadable with some parts black with black text, and some white even tough the theme is dark. (check uploaded photos)

I tried reinstalling plasma6-themes-breath and plasma-desktop but none fixed the problem. I was hopping to be able to fix it without a clean install.

System Info
  Kernel: 6.6.30-2-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc avail: acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.6-x86_64
    root=UUID=d725ff16-174b-4ed8-8612-4666e75e386f rw quiet splash
    udev.log_priority=3 mem_sleep_default=deep
  Desktop: KDE Plasma v: 6.0.4 tk: Qt v: N/A info: frameworks v: 6.1.0
    wm: kwin_x11 with: krunner vt: 2 dm: SDDM Distro: Manjaro base: Arch Linux
  Type: Laptop System: HP product: OMEN by HP Laptop 15-ce0xx v: N/A
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: HP model: 838F v: 40.28 serial: <superuser required>
    part-nu: 1KV80UA#ABA uuid: <superuser required> UEFI: American Megatrends
    v: F.24 date: 07/05/2021
  ID-1: BAT0 charge: 62.1 Wh (100.0%) condition: 62.1/62.1 Wh (100.0%)
    volts: 17.3 min: 15.4 model: HP Primary type: Li-ion serial: N/A status: full
  Info: model: Intel Core i7-7700HQ bits: 64 type: MT MCP arch: Kaby Lake
    gen: core 7 level: v3 note: check built: 2018 process: Intel 14nm family: 6
    model-id: 0x9E (158) stepping: 9 microcode: 0xF8
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 6 MiB desc: 1x6 MiB
  Speed (MHz): avg: 811 high: 859 min/max: 800/3800 scaling:
    driver: intel_pstate governor: powersave cores: 1: 800 2: 826 3: 804 4: 800
    5: 800 6: 859 7: 800 8: 800 bogomips: 44817
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: gather_data_sampling mitigation: Microcode
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: reg_file_data_sampling status: Not affected
  Type: retbleed mitigation: IBRS
  Type: spec_rstack_overflow status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: IBRS; IBPB: conditional; STIBP: conditional;
    RSB filling; PBRSB-eIBRS: Not affected; BHI: Not affected
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel HD Graphics 630 vendor: Hewlett-Packard driver: i915
    v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20 ports:
    active: eDP-1 empty: DP-1,HDMI-A-1 bus-ID: 00:02.0 chip-ID: 8086:591b
    class-ID: 0300
  Device-2: NVIDIA GP107M [GeForce GTX 1050 Ti Mobile]
    vendor: Hewlett-Packard driver: nvidia v: 550.78
    alternate: nouveau,nvidia_drm non-free: 545.xx+ status: current (as of
    2024-04; EOL~2026-12-xx) arch: Pascal code: GP10x process: TSMC 16nm
    built: 2016-2021 pcie: gen: 1 speed: 2.5 GT/s lanes: 8 link-max: gen: 3
    speed: 8 GT/s lanes: 16 bus-ID: 01:00.0 chip-ID: 10de:1c8c class-ID: 0300
  Device-3: Realtek HP Wide Vision HD Camera driver: uvcvideo type: USB
    rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-6:3 chip-ID: 0bda:58eb
    class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.13 with: Xwayland v: 23.2.6
    compositor: kwin_x11 driver: X: loaded: modesetting,nvidia
    alternate: fbdev,nouveau,nv,vesa dri: iris gpu: i915 display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93") monitors: <missing: xrandr>
  Monitor-1: eDP-1 model: LG Display 0x0532 built: 2016 res: 1920x1080
    dpi: 142 gamma: 1.2 size: 344x194mm (13.54x7.64") diag: 395mm (15.5")
    ratio: 16:9 modes: 1920x1080
  API: EGL v: 1.5 hw: drv: intel iris drv: nvidia platforms: device: 0
    drv: nvidia device: 2 drv: iris device: 3 drv: swrast gbm: drv: kms_swrast
    surfaceless: drv: nvidia x11: drv: iris inactive: wayland,device-1
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: intel mesa v: 24.0.6-manjaro1.1
    glx-v: 1.4 direct-render: yes renderer: Mesa Intel HD Graphics 630 (KBL GT2)
    device-ID: 8086:591b memory: 15.14 GiB unified: yes
  API: Vulkan v: 1.3.279 layers: 1 device: 0 type: discrete-gpu name: NVIDIA
    GeForce GTX 1050 Ti driver: nvidia v: 550.78 device-ID: 10de:1c8c
    surfaces: xcb,xlib
  Device-1: Intel CM238 HD Audio vendor: Hewlett-Packard driver: snd_hda_intel
    v: kernel alternate: snd_soc_avs bus-ID: 00:1f.3 chip-ID: 8086:a171
    class-ID: 0403
  Device-2: NVIDIA GP107GL High Definition Audio driver: snd_hda_intel
    v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 8 link-max: lanes: 16
    bus-ID: 01:00.1 chip-ID: 10de:0fb9 class-ID: 0403
  Device-3: Samsung USB C Earphones driver: hid-generic,snd-usb-audio,usbhid
    type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-4:2
    chip-ID: 04e8:a05e class-ID: 0300 serial: <filter>
  API: ALSA v: k6.6.30-2-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 1.0.5 status: active with: 1: pipewire-pulse
    status: active 2: pipewire-media-session status: active 3: pipewire-alsa
    type: plugin tools: pactl,pw-cat,pw-cli
  Device-1: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
    vendor: Hewlett-Packard driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: c000 bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: eno1 state: down mac: <filter>
  Device-2: Intel Wireless 7265 driver: iwlwifi v: kernel modules: wl pcie:
    gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 04:00.0 chip-ID: 8086:095a
    class-ID: 0280
  IF: wlo1 state: up mac: <filter>
  IF-ID-1: br-dff152d77a83 state: up speed: 10000 Mbps duplex: unknown
    mac: <filter>
  IF-ID-2: docker0 state: down mac: <filter>
  IF-ID-3: veth3e119f7 state: up speed: 10000 Mbps duplex: full mac: <filter>
  Info: services: NetworkManager, systemd-timesyncd, wpa_supplicant
  Device-1: Intel Bluetooth wireless interface driver: btusb v: 0.8 type: USB
    rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-7:4 chip-ID: 8087:0a2a
    class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 0 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: see --recommends
  Local Storage: total: 1.84 TiB used: 97.62 GiB (5.2%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Seagate
    model: XPG GAMMIX S70 BLADE size: 953.87 GiB block-size: physical: 512 B
    logical: 512 B speed: 63.2 Gb/s lanes: 4 tech: SSD serial: <filter>
    fw-rev: 3.2.F.66 temp: 32.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: HGST (Hitachi) model: HTS721010A9E630
    size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    tech: HDD rpm: 7200 serial: <filter> fw-rev: A3T0 scheme: GPT
  ID-1: / raw-size: 312.5 GiB size: 306.53 GiB (98.09%) used: 70.68 GiB (23.1%)
    fs: ext4 dev: /dev/nvme0n1p6 maj-min: 259:6
  ID-2: /boot/efi raw-size: 350 MiB size: 349.3 MiB (99.80%)
    used: 292 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p5 maj-min: 259:5
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) zswap: yes
    compressor: zstd max-pool: 20%
  ID-1: swap-1 type: partition size: 16.11 GiB used: 768 KiB (0.0%)
    priority: -2 dev: /dev/nvme0n1p9 maj-min: 259:9
  System Temperatures: cpu: 48.0 C pch: 55.5 C mobo: N/A
  Fan Speeds (rpm): cpu: 0 fan-2: 0
  Memory: total: 16 GiB available: 15.5 GiB used: 4.35 GiB (28.0%)
  Processes: 284 Power: uptime: 3h 42m states: freeze,mem,disk suspend: deep
    avail: s2idle wakeups: 0 hibernate: platform avail: shutdown, reboot,
    suspend, test_resume image: 6.19 GiB services: org_kde_powerdevil,
    power-profiles-daemon, upowerd Init: systemd v: 255 default: graphical
    tool: systemctl
  Packages: 1571 pm: pacman pkgs: 1560 libs: 425 tools: pamac pm: flatpak
    pkgs: 11 Compilers: clang: 17.0.6 gcc: 13.2.1 Shell: Zsh v: 5.9 default: Bash
    v: 5.2.26 running-in: konsole inxi: 3.3.34
Breath Dark


Reinstalling won’t help you.

resetting your desktop to defaults might have - prior to running the update

find and read the update announcement thread

Categories → Announcements → stable updates

1 Like

Partial upgrades are unsupported and equal to broken.

Aside from the desktop refresh steps outlines above and elsewhere, make sure to be fully synced and up to date.

1 Like

My desktop configs is practically stock, the only thing I changed was icon to “Tela Circle Dark”

The 2024-05-13 update went ok without problem and I don’t think the 2024-05-18 update was the problem as well, my problem was (I guess) the partial update that broke the system.

So unless my prints is correct (should be the same as a clean install) my guess is that the partial update really messed something.

Sorry, I dind’t get this part:

Aside from the desktop refeesh steps outlines above and elsewhere

My system is up to date, I guess the partial update broke something, I needed to reinstall a lot of packages to make it working (I’m not an expert, so I was just doing things until it worked again…).

My hope was that I “forgot” to reinstall some broken package that is causing the issue, but as per your comment I think the only solution would be a backup (that I don’t have) or a clean install, right?

I just want you to be in a fully synced/updated state.
Anything else is ‘broken’.

It is?
Then what about the partial upgrade?

Its the same as shown in dozens of other threads and the “Known Issues” post.

You should ‘reset’ plasma configurations by removing items in ~/.cache, ~/.config and ~/.local/share/.


I’m not sure when during the update my notebook froze, but I know it broke something because the login screen wasn’t showing, my wifi wasn’t working as well, only wired connection. I don’t remember but I think pamac/pacman wasn’t showing anything to update, but since my notebook froze during the update I thought it was called a “partial update”. So I started reinstalling some packages and get it working again, and pamac/pacman still shows “Nothing to do”.

You should ‘reset’ plasma configurations by removing items in ~/.cache , ~/.config and ~/.local/share/ .

I didn’t know you were referring to this, I did this procedure, didn’t solve the problem.

A clean install is not the only option, but it is likely the fastest way back to a working machine. If you decide to do this, please download the latest full ISO, and read the respective Stable Update announcements beforehand - and address any issues mentioned before you install the OS.

Good luck.

Please try the following

Restart your system - do not log on but switch to e.g. TTY5 - CtrlAltf5

Login using your username and password

Run a full system sync - resolve any prompts on the fly

sudo pacman -Syu

When you have successfully synced your system - use git to clone a profile cleaner script

git clone

Navigate into the folder and execute the script

cd Manjaro-Plasma-Reset

When done reboot the system

 systemctl reboot

Tried the script, but didn’t solve the problem.

Since its just a visual problem I’ll let it for now, maybe on some future update it gets fixed by itself. Thanks everybody for the help anyway.

After today update everything just fixed by itself. Thanks everyone.