Bottles failed to start due modules missing errors

A few minutes ago, I tried to install a wine program with bottles.

After failing to do so, I started bottles via command line, where I could see a missing python module error.

Bottles (bottles, bottles-git) is an AUR package.

Have you rebuilt it since applying system updates?


The solution of this problem was to reinstall the missing module and start bottles again to see another missing python module error. I iterated through a few modules until it worked again.

This is what I had to reinstall.

>$ trizen -S pathvalidate icoextract patool fvs vkbasalt

I actually did prior my solution. Thanks.

Those are also AUR packages.

You need to rebuild them when the libraries they depend on change.

It is part of managing AUR packages.

rebuild-detector purports to help notify you when this occurs.


That’s good advice, I appreciate it. And thanks again.

Edit: Just found arch-rebuild-order, will install both packages.

On the AUR page there are comments where this have already been explained multiple times

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.