Both Firefox Installations (Rel & Dev) On One Computer Can't Add or Edit Credit Cards

I’m having an odd Firefox problem. On my main computer (homebrew; Asus MB, Ryzen APU, Nvidia graphics, running Manjaro Stable with X11 windowing and KDE Plasma desktop with all the latest updates), I have two Firefox installations; “Developer Edition” (121.0b8-64-bit) and “Release Edition” (120.0.1-64-bit). Both installations work fine, except that both have these three bugs:

  1. Cannot add Saved Credit Cards. The “Add…” button launches a dialog box, and I can fill-in the information, but clicking the “Save” button does nothing. The dialog box remains on-screen. After closing the dialog box, the new credit card is not saved.

  2. Cannot edit Saved Credit Cards. The “Edit” button does nothing (no dialog box opens).

  3. Using Firefox “Sync” syncs everything else but not credit cards, even though it’s set to do so.

Note that saved passwords, saved addresses, and auto-fill aren’t effected; just the ability to add or edit credit cards is missing.

Also note that I’m using the same OS setup (Manjaro Stable with KDE Plasma desktop, X11, and all the most recent updates, with Firefox Release and Developer editions) on multiple computers, but only my main machine has this problem. So it’s something specific to this machine.

As for when this problem first cropped-up, sadly I can’t tell you; it could have been any time during the last 2 years, as evidenced by the fact that some of the saved credit cards expired in 2022. I was able to remove those, but not to add new or edit existing. Obviously it was working at one time, but at some point it stopped working.

Things I’ve tried so far, to no avail:

  • I uninstalled then reinstalled Firefox Developer Edition, but the problem persists.

  • I created a new user profile after the uninstall/reinstall, but the problem persists.

  • I also tried “Safe Mode”, but the problem persists (so it’s not due to a balky add-on).

  • Thinking it may be a permissions issue, in a console, in my home directory, I typed “sudo chmod -R 0775 .mozilla” then launched Firefox, but the problem persists. Surprisingly this didn’t break Firefox (usually wholesale chmod-ing a huge file tree breaks things), but it didn’t solve the credit-card issue.

So I’m at a loss. What could be causing this?

I found the solution! It’s not what I expected at all! I was thinking about how-and-where Firefox stores credit cards in Manjaro KDE Plasma Linux. On looking at the “modified” times of files in “~/.mozilla/firefox” in another computer, I could not find a modification time corresponding to the moment of adding a credit card. So, it appears that credit cards were being stored elsewhere, encrypted. What kind of encryption was on my computers? Well, the computers where credit card storage was working correctly had “KDE Wallet subsystem” enabled. The one computer where credit cards could not be stored had “KDE Wallet subsystem” disabled. So I enabled “KDE Wallet subsystem” and checked the “Use KWallet for the Secret Service interface” checkbox, and voila, I can now add and edit credit cards.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.