Bose QC35 sound cuts regularly

Hello everyone!

I own a Bose QC35 (wireless) which I paired with my computer
successfully (see this guide:

There are 2 modes to connect the headphones:

  1. HSP/HFP
  2. A2DP Sink (high fidelity).

The second one gives better sound – the first one seems to simulate a
call from the computer to the headphones: I can hear noise around me
through the microphone and the sound from the computer is not good +
the headphones keeps telling me that there is a phone call.

When I listen to something using A2DP Sink, the sound is cutted
regularly. Every ~2 min, I have no sound and it comes back after 5
sec. This happens only when I am listening (or watching) something
using the WiFi. It is really annoying and I would like to listen to
something from the internet in better quality without any cuts.

The issue seems related to this topic (,_sound_plays_fine_until_headphones_become_idle,_then_stutters) from the ArchLinux Wiki. I do not
really know how to solve the problem.

Do you have any suggestion or solution?

Thank You

Hello and welcome to Manjaro!

If you follow the link that is part of your post, then you come here:

which there are several related problems as this is the default behavior of Pulseaudio.

The most correct way to solve this should be:

### Copy the relevant config file to the right config folder in your homefolder with:

sudo cp /etc/pulse/ ~/.config/pulse/

### Then give this file the right owner, say your user is 'ngayhbe' and the group he is in is 'users'

sudo chown ngayhbe:users ~/.config/pulse/

### Now edit the config file with your favorite editor, I use nano as an example

nano ~/.config/pulse/

### Now find the line which says

'### Automatically suspend sinks/sources that become idle for too long'
'load-module module-suspend-on-idle'

### and put a '#' symbol in front of load-module, like so

'# load-module module-suspend-on-idle'

### Finally restart Pulseaudio with

pulseaudio -k

### or restart your computer, just to be sure. 

Please let us know if it works.

1 Like

Thank you for your answer. It looks like it works.

Remark 1: I already did this before but did not copy /etc/pulse/ to ~/.config/pulse/. I commented the target line directly in /etc/pulse/ then restarded pulseaudio (and it did not work).

Remark 2: Thanks for welcoming me. Actually, I’ve been member for years but did know about the issue that removed the data of the old forum. Everytime I wanted to login via email or change password, I never got the email. Then, today, I decided to create a new account.

1 Like

@mielouk I think I spoke too quickly. It is back. I do not know why it worked very well during ~10 minutes straight. I am watching something now and the issue is back.

So the idling is not the problem. Does this happen in special circumstances, like silent parts of music or of a movie? If it is random we might take a look at your journal and dmesg. Well, lets start from the beginning. Does the playback interruptions also happen with another BT source, like your smartphone?

For general debugging we will need more information. A good starting point is the output of

inxi -Fazy

pactl info

please format it with these three symbols ```at the beginning and the end of each output. Except that you could put your journal and dmesg in two separate pastebins.

journalctl -b

Does this happen in special circumstances, like silent parts of music or of a movie?

It happens regularly without any context. As far as there is something playing using internet connection.

Does the playback interruptions also happen with another BT source, like your smartphone?

It works fine with my smartphone.

$ inxi -Fazy
  Kernel: 5.4.67-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.4-x86_64 
  root=UUID=1b96a60e-4204-4e8f-ac8e-d2a79a17c853 rw quiet 
  Desktop: MATE 1.24.1 info: mate-panel wm: marco 1.24.1 dm: LightDM 1.30.0 
  Distro: Manjaro Linux 
  Type: Laptop System: HP product: HP Pavilion Notebook v: N/A 
  serial: <filter> Chassis: type: 10 serial: <filter> 
  Mobo: HP model: 84F7 v: 07.10 serial: <filter> UEFI: AMI v: F.04 
  date: 04/20/2018 
  ID-1: BAT0 charge: 52.7 Wh condition: 52.7/52.7 Wh (100%) volts: 12.4/11.6 
  model: HP Primary type: Li-ion serial: N/A status: Full 
  Topology: Quad Core model: Intel Core i5-8250U bits: 64 type: MT MCP 
  arch: Kaby Lake family: 6 model-id: 8E (142) stepping: A (10) microcode: D6 
  L2 cache: 6144 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 28808 
  Speed: 947 MHz min/max: 400/3400 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 
  4: 800 5: 800 6: 800 7: 800 8: 800 
  Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel UHD Graphics 620 vendor: Hewlett-Packard driver: i915 
  v: kernel bus ID: 00:02.0 chip ID: 8086:5917 
  Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] driver: N/A 
  alternate: nouveau, nvidia_drm, nvidia bus ID: 01:00.0 chip ID: 10de:1c8d 
  Device-3: Chicony HP Wide Vision HD type: USB driver: uvcvideo bus ID: 1-3:2 
  chip ID: 04f2:b56d 
  Display: x11 server: X.Org 1.20.9 compositor: marco v: 1.24.1 driver: intel 
  display ID: :0 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
  s-diag: 582mm (22.9") 
  Monitor-1: eDP1 res: 1920x1080 hz: 60 dpi: 143 size: 340x190mm (13.4x7.5") 
  diag: 389mm (15.3") 
  OpenGL: renderer: Mesa Intel UHD Graphics 620 (KBL GT2) v: 4.6 Mesa 20.1.8 
  direct render: Yes 
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Hewlett-Packard 
  driver: snd_hda_intel v: kernel alternate: snd_soc_skl bus ID: 00:1f.3 
  chip ID: 8086:9d71 
  Device-2: NVIDIA GP107GL High Definition Audio driver: snd_hda_intel 
  v: kernel bus ID: 01:00.1 chip ID: 10de:0fb9 
  Sound Server: ALSA v: k5.4.67-1-MANJARO 
  Device-1: Realtek RTL8822BE 802.11a/b/g/n/ac WiFi adapter 
  vendor: Hewlett-Packard driver: rtw_pci v: N/A modules: rtwpci port: d000 
  bus ID: 02:00.0 chip ID: 10ec:b822 
  IF: wlo1 state: up mac: <filter> 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Hewlett-Packard driver: r8168 v: 8.048.03-NAPI modules: r8169 
  port: c000 bus ID: 03:00.0 chip ID: 10ec:8168 
  IF: eno1 state: down mac: <filter> 
  IF-ID-1: docker0 state: down mac: <filter> 
  Local Storage: total: 1.03 TiB used: 790.29 GiB (75.2%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/sda vendor: Seagate model: ST1000LM035-1RK172 size: 931.51 GiB 
  block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: 5400 rpm serial: <filter> rev: RSM7 scheme: GPT 
  ID-2: /dev/sdb vendor: Samsung model: MZNLN128HAHQ-000H1 size: 119.24 GiB 
  block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s serial: <filter> 
  rev: 3H3Q scheme: GPT 
  Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci 
  v: 3.0 port: f060 bus ID: 00:17.0 chip ID: 8086.282a rev: 21 
  ID-1: / raw size: 118.24 GiB size: 115.89 GiB (98.01%) 
  used: 69.89 GiB (60.3%) fs: ext4 dev: /dev/sdb2 
  ID-2: /home raw size: 923.40 GiB size: 907.91 GiB (98.32%) 
  used: 720.40 GiB (79.3%) fs: ext4 dev: /dev/sda2 
  Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 8.00 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/sda1 
  System Temperatures: cpu: 39.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  Processes: 225 Uptime: 2h 44m Memory: 7.66 GiB used: 1.77 GiB (23.2%) 
  Init: systemd v: 246 Compilers: gcc: 10.2.0 clang: 10.0.1 Packages: 
  pacman: 2148 lib: 434 Shell: Bash v: 5.0.18 running in: mate-terminal 
  inxi: 3.1.05 
$ pactl info
Chaîne du serveur : /run/user/1000/pulse/native
Version du protocole de bibliothèque : 33
Version du protocole du serveur : 33
Local : oui
Index client : 30
Tile Size: 65472
Nom d'utilisateur : user
Nom d'hôte : user-pc
Nom du serveur : pulseaudio
Version du serveur : 13.0
Spécification d'échantillon par défaut : s16le 2ch 44100Hz
Plan de canaux par défaut : front-left,front-right
Destination par défaut : bluez_sink.04_52_C7_7C_E5_7C.a2dp_sink
Source par défaut : alsa_input.pci-0000_00_1f.3.analog-stereo
Cookie : 0497:97f7

I don’t see any gross problems, not related to PA or BT. (The only smaller thing is that something tries to reconnect via BT. Do you have more BT devices that try to reconnect?) You could try to debug this with opening two terminals side by side. In one terminal you follow this

and in the other this one

Then listen to whatever might be the problem and look at the output whether the BT one shows some reconnect or some error in PA. If so, please post the output here, or if too long in a pastebin again.

EDIT: You may want to remove the ‘Solution’ so more people watch this thread.

This happens (using the first link) when it cuts and tries to sync back:

I: [pulseaudio] module-stream-restore.c: Synced.
I: [bluetooth] module-bluez5-device.c: Changing bluetooth buffer size: Changed from 7168 to 8192
I: [bluetooth] module-bluez5-device.c: Changing bluetooth buffer size: Changed from 8192 to 9216
I: [bluetooth] module-bluez5-device.c: Changing bluetooth buffer size: Changed from 9216 to 11264

I have the same issues with three different BT headsets. I’m afraid I haven’t found any good solutions.
I have spent hours googling and trying out commands and packages, I’ve tried the BT device on my motherboard, and three different dongles. I’ve tried other distros; stuttering remains.
Sometimes it helps to download whatever the sound source is, sometimes changing the buffer delay, but it always returns.

1 Like

It seems like every time I restart pulseaudio, it works fine during ~10min. Then the problem comes back.

I have resorted to speakers. Cabling works. BT sound on Linux, unfortunately, is just bad.

Also, apologies for the bad news.

Sorry to hear that. I also couldn’t find any other feasible solution unfortunately. Many bug reports, but after years people start complaining again…

1 Like

One thing I’ve noticed is that if it’s a video, Playback stutters too; it’s the whole thing, not just the sound. The video drops a few frames, then moves on, but the sound cuts off for sometimes up to several seconds, then comes as a jumble of sounds.
This happens both when playing video from youtube and when playing a local video file, in firefox, chrome, vlc and … the other video player I downloaded to test. I am pretty sure it’s not in the application layer.

Yes. I did not say it because I did not find the right way to tell it.

If there is an internet activity in the background, a download or heavy website loading for instance, the problem occurs. Otherwise, with WI-FI disconnected or static pages loaded in your browser (+ WI-FI), the issue does not happen.


Wifi is disabled on the motherboard, it’s not radio noise.
The very same hardware running a windows 10 install, with the only difference being that I run it from a different ssd, plays bt sound perfectly.

That’s not what I experience.