Borked KDE Plasma theming/colors

Here is a screenshot of Dolphin and Konqueror:

Do you see how the colors are distored?

I noticed this started happening about a week ago after an update. I am on the stable branch running Plasma 5.23.5.

In Plasma’s System Settings I’ve tried different Application Styles and nothing seems to change when I select a theme and click: “Apply”.

Is there any other information I could provide to help troubleshoot?

Here is $ inxi -Fazy:

  Kernel: 5.16.7-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.16-x86_64
    root=UUID=9d0918bc-72f1-49b0-88d7-81ad74dead15 rw quiet splash apparmor=1
    security=apparmor udev.log_priority=3 sysrq_always_enabled=1
  Desktop: KDE Plasma 5.23.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11
    vt: 2 dm: GDM 41.3 Distro: Manjaro Linux base: Arch Linux
  Type: Desktop System: Gigabyte product: X470 AORUS ULTRA GAMING v: N/A
    serial: <superuser required>
  Mobo: Gigabyte model: X470 AORUS ULTRA GAMING-CF v: x.x
    serial: <superuser required> UEFI: American Megatrends v: F2
    date: 03/14/2018
  Info: model: AMD Ryzen 7 2700 bits: 64 type: MT MCP arch: Zen+
    family: 0x17 (23) model-id: 8 stepping: 2 microcode: 0x800820D
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 768 KiB desc: d-8x32 KiB; i-8x64 KiB L2: 4 MiB desc: 8x512 KiB
    L3: 16 MiB desc: 2x8 MiB
  Speed (MHz): avg: 1831 high: 3430 min/max: 1550/3200 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 2557 2: 2576
    3: 1556 4: 1516 5: 3430 6: 2814 7: 1531 8: 1541 9: 1546 10: 1629 11: 1402
    12: 1451 13: 1411 14: 1464 15: 1435 16: 1446 bogomips: 102429
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP:
    disabled, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: AMD Navi 23 [Radeon RX 6600 XT]
    vendor: Sapphire Limited driver: amdgpu v: kernel bus-ID: 0c:00.0
    chip-ID: 1002:73ff class-ID: 0300
  Display: x11 server: X.Org compositor: kwin_x11 driver:
    loaded: amdgpu,ati unloaded: modesetting,radeon alternate: fbdev,vesa
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3840x1600 s-dpi: 96 s-size: 1016x423mm (40.0x16.7")
    s-diag: 1101mm (43.3")
  Monitor-1: HDMI-A-0 res: 3840x1600 hz: 60 dpi: 111
    size: 880x370mm (34.6x14.6") diag: 955mm (37.6")
  Message: Unable to show advanced data. Required tool glxinfo missing.
  Device-1: AMD Navi 21 HDMI Audio [Radeon RX 6800/6800 XT / 6900 XT]
    driver: snd_hda_intel v: kernel bus-ID: 0c:00.1 chip-ID: 1002:ab28
    class-ID: 0403
  Device-2: AMD Family 17h HD Audio vendor: Gigabyte driver: snd_hda_intel
    v: kernel bus-ID: 0e:00.3 chip-ID: 1022:1457 class-ID: 0403
  Sound Server-1: ALSA v: k5.16.7-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.20 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.45 running: yes
  Device-1: Intel I211 Gigabit Network vendor: Gigabyte driver: igb v: kernel
    port: f000 bus-ID: 07:00.0 chip-ID: 8086:1539 class-ID: 0200
  IF: enp7s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Local Storage: total: 3.98 TiB used: 1021.31 GiB (25.0%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 970 EVO 250GB
    size: 232.89 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 type: SSD serial: <filter> rev: 2B2QEXE7 temp: 41.9 C scheme: MBR
  ID-2: /dev/sda maj-min: 8:0 vendor: Western Digital
    model: WDS200T2B0A-00SM50 size: 1.82 TiB block-size: physical: 512 B
    logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 20WD
    scheme: GPT
  ID-3: /dev/sdb maj-min: 8:16 vendor: Western Digital
    model: WD20EFRX-68AX9N0 size: 1.82 TiB block-size: physical: 4096 B
    logical: 512 B speed: 6.0 Gb/s type: N/A serial: <filter> rev: 0A80
    scheme: MBR
  ID-4: /dev/sdc maj-min: 8:32 type: USB vendor: Samsung model: Flash Drive
    size: 119.51 GiB block-size: physical: 512 B logical: 512 B type: SSD
    serial: <filter> rev: 1100 scheme: MBR
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
  ID-1: / raw-size: 83.01 GiB size: 81.15 GiB (97.76%) used: 39.13 GiB (48.2%)
    fs: ext4 dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-2: /boot/efi raw-size: 1000 MiB size: 998 MiB (99.80%)
    used: 280 KiB (0.0%) fs: vfat dev: /dev/nvme0n1p3 maj-min: 259:3
  ID-3: /home raw-size: 1.82 TiB size: 1.79 TiB (98.37%)
    used: 982.17 GiB (53.6%) fs: ext4 dev: /dev/sda1 maj-min: 8:1
  Alert: No swap data was found.
  System Temperatures: cpu: N/A mobo: N/A gpu: amdgpu temp: 40.0 C mem: 38.0 C
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 0
  Processes: 487 Uptime: 22m wakeups: 0 Memory: 62.81 GiB
  used: 12.92 GiB (20.6%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.1.0 clang: 13.0.1 Packages: 2121 pacman: 2116 lib: 513 flatpak: 0
  snap: 5 Shell: Zsh v: 5.8 running-in: gnome-terminal inxi: 3.3.12

Choose a different color scheme. :arrow_down:

System Settings → Appearance → Colors

You may have to log out and back in for all applications to pick that up.

Hi @Aragorn : Under “System Settings” > “Appearance” > “Colors”, I selected : “Restore Defaults” > “Apply”. Next I rebooted and my color scheme is still skewed as you can see in Dolphin and Konqeror (and all my other KDE-based apps):

What happens if you choose a color scheme, like Breath or Breeze, Apply and relog?

Hi @Strit

In System Settings, I went to Appearance:

  • Plasma Style
  • Application Style
  • Colors
  • Icons

And then I mindfully selected “Breeze” for all of the above options and clicked “Apply”.

Next I rebooted my PC.

Here is what Dolphin and Konqueror look like:

It’s still distorted.

As my next step, would you people recommend that I try backing up my Plasma configuration directory in my home folder and starting fresh?

I hesitate to go that route because my KWin configuration is highly customized with lots of plugins and it would be a pain to reconfigure manually from scratch.

I think that would be the cause of your problem.

I thought that KWin was more like the window manager and Plasma color themes are separate. Maybe I’m wrong.

I figured it was worth a try to backup my Plasma configs and nuke them from orbit. So I used this as my guide:

I logged into Gnome and ran these commands:

cd ~/
rm -rf .kde
rm -rf .cache/plasmashell*
rm -rf .cache/org.kde.dirmodel-qml.kcache
rm -rf .cache/kioexec/ .cache/krunner/ .cache/ksycoca5*
rm -rf .cache/krunnerbookmarkrunnerfirefoxdbfile.sqlite
rm -f .config/plasma*
rm -rf .config/kde*
cd .local/
rm -rf kate/ kded5/ klipper/ knewstuff3/ kscreen/ konsole/ kwalletd/ ksysguard/ kmail2/ kcookiejar/ kactivitymanagerd/
cd share/
rm -rf dolphin kate kcookiejar kded5 keyrings klipper kmail2 knewstuff3 konsole kscreen ksysguard kwalletd kxmlgui5 plasma_engine_comic plasma plasma_notes org.kde.gwenview
cd ~/.config/
rm -rf akonadi* KDE kconf_updaterc baloo* dolphinrc drkonqirc gwenviewrc kmail2rc k*rc katemetainfos

Here is what Dolphin looks like now:

I notice that there are other elements to my DE that remain unchanged, such as latte-dock and my top panel. So the guide I used to reset my KDE/Plasma configuration files to factory defaults didn’t work.

I am actually kind of cheesed now because it appears the only which was changed are my KWin settings. So now I need to reconfigure all my keybindings manually. This is going to take me hours even though I have work to do.

So, you are using Gnome and KDE Plasma from the same account.
Gnome uses the qt5ct and qt6ct that will most likely overwrite whatever KDE Plasma does native … and will also prevent from using native KDE Plasma color-schemes.

You should have kept those files you deleted in a backup, as Gnome doesn’t care about those whatsoever. You just messed some of the KDE settings … oh well.

1 Like

You should have created a new user acc and check if things are different there, if so, apply your Kwin modifications one by one to find a breaking one.

:point_up_2: THIS :point_up_2:

Rather than haphazardly running $ rm -rf .cache/plasmashell*, instead I used $ mv -f moving the contents to a backup directory in a separate location. So I should have the original files. The problem is that it’s cumbersome to undo all of this manually.

@bogdancovaciu + @Aragorn : So as a last ditch effort at this point, is there a way to recover the most important configuration file of them all: the one for keybindings with the extension, .kksrc? I went searching for it and found some default presets in /usr/share/ but can’t find any in my home directory or the directory I used to house my KDE / Plasma backup.

Or is there a specific location that you might be aware of perhaps in my KDE / Plasma backup (in the listed folders above) where I could rescue the KWin keybindings?

You should be able to find your shortcuts in ~/.config/khotkeysrc.

1 Like

Some defaults are in /etc/skel/ that are copied at user creation in their home directory, but Gnome has different files since are part of the manjaro-gnome-settings and KDE Plasma has manjaro-kde-settings. Those two packages can’t reside together. Is either one or the other.

If you have those files you removed on another install, then you can use then from there, but once again Gnome and KDE Plasma will not play nice together. There is also the /etc/environment. On KDE Plasma is empty, and for Gnome there are some settings. Without those, Gnome will not display correctly the Qt5 applications.

1 Like


try to look at kvantum manager maybe u use it.

I’ve recovered my KWin keybindings.

@bogdancovaciu : How do I purge my system of Gnome so that I am running KDE/Plasma only?

Other arch-based users suggest: $ sudo pacman -Rnsc gnome gnome-extra.

That worked for me.

@Aragorn + @bogdancovaciu

Original distortions resolved.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.