Booting Pinebook Pro with Manjaro is a real torture

I love Manjaro on my Pinebook Pro. But I have a problem that I can’t fix. The screen almost never turns on when you boot the first few times, it is necessary to turn on and off a considerable number of times to make the screen wake up. Does anyone know how to fix this bug?

Thank you very much for your help

external display?

I had to flash the BSP U-boot to fix mine. The mainline U-boot makes it so my Pinebook Pro will only boot Manjaro successfully 1 out of 7-ish times.


Guess i lucky . zero boot problems ( well not with Manjaro )

Mine isn’t that bad, it’s hung on shutdown once and failed to boot a couple of times.

If you don’t mind where did you get BSP u-boot and how did you flash?

Hello and welcome to the forum

Please describe more of what exactly your doing.

Do you have any sd card inserted when booting?

When was the last time you updated?

Are you talking about laptop screen or wheel external screen? If it’s about external screen then the usb-c to hdmi drivers are experimental and not stable so it has nothing to do with Manjaro OS it is more of kernel issue.

Please share detailed information for further understanding.

Thank you.

It is available in the repo, we maintain bsp and mainline uboot so users can switch to their preferred uboot.
sudo pacman -S uboot-pinebookpro-bsp
Will install the bsp uboot but you will have to flash it manually by following the instructions printed after installation.

1 Like

Thank-you, done that and it’s rebooted fine.

Well, the bug mostly happens when I try to start from emmc, but lately it even happens if I do it from SD. I have no external screen, only the PBP’s own. I have updated Manjaro to the stable version of September 22nd, and that is happening to me since the pre-installed version when I bought it, last June. It does not depend on the version you are working with.

I’m going to install the BSP uboot, as mammbo3 advises me. I will report on the result.

Thank you very much to all.

My apologies if this has already been answered. I did not see it in a quick search.
According to gitlab.manjaro(dot)org/manjaro-arm/packages/core/uboot-pinebookpro-bsp/-/blob/master/PKGBUILD it would appear that you are using the v1.5 in MrFixit2001’s repo for BSP U-Boot. Is there a reason why it has not been [updated to v2.0 here: github(dot)com/mrfixit2001/updates_repo/tree/v2.0/pinebook/filesystem which seems to be what people recommend using on the Pine64 forum for BSP U-Boot?

1 Like

Where you to make a rescue SD from mrfixit’s distro AND updated it
(, you have ver 2 in first 16M, convenient and easy

Changing the default uboot package to BSP seems to have been the definitive solution. I have managed to start the OS several times without any problem. At last!

Thank you all very much, and especially mammbo3. :smile: :smile: :smile:

I think it would be very convenient to report this problem and this solution in this and other forums, so that other users do not have to be looking for the solution to this headache for weeks, as it has happened to me.

It also enables sleep s3 to work, should BSP become the default in the ISO?

Thank you so much for this, genuinely thought I had a dodgy eMMC as couldn’t find alot of people having the same issues, so I’ve been using sdcard mostly. But this truly fixed it and the eMMC seems faster which again is a bonus!

If anyone else was a little cautious about the commands, I ran them against mmcblk2 (eMMC) when booting ManjaroARM from eMMC.

I just updated the uboot package in arm-unstable branch. This should fix some of these issues, when you flash it to your drive.

Cool, does this uboot include what was in BSP that fixed the S3 problem for me yesterday?

And, should I replace the BSP from yesterday with this new uboot?

No. Mainline uboot does not support suspend, other than suspend2idle.

Depends on what you need from your uboot. If you don’t need the S3 suspend, change to mainline. If you do need S3 suspend, stay on BSP uboot.


What do I have to do, apart from replacing the uboot images, to make hibernation work on my Pinebook Pro?

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.