Booting Manjaro from USB stick fails

I am unable to boot Manjaro (XFCE) from the USB stick. I created the bootable USB stick with Balena Etcher. I tried booting in both UEFi and Legacy mode. I get this error:

mount: /run/miso/sfs/livefs: wrong fs type, bad option, bad superblock on /dev/loop0, missing codepage or helper program, or other error
Failed to mount ‘/dev/loop0’
sh: can’t access tty; job control turned off

How should I go about this?

These days I’ve been using Ventoy. Install it from Pamac or Add/Remove Programs. Run the program create a USB boot stick, and literally copy your ISO to the disk. Done.


The ISO is incomplete - download again - verify - write - and don’t yank the stick - use safe eject - be patient until write has completed.

1 Like

Boot into Windows and use Rufus from (windows freeware, I have not used the linux version or ARM version) to make the bootable USB installer from the ISO you download from the official website.

I have used Rufus (for Windows) lots of times to make bootable linux installer USBs, and the bootable usbs have worked flawlessly each time.