Booting into blank screen after switching to unstable

Currently my system boots into a blank screen, and I cant even access the text terminals.

I had the stable branch installed KDE plasma + Bismuth for tiling wm and I use X11 so keepassxc works properly. I wanted to make valgrind work for a project of mine, as it isn’t working on stable. Most discussions recommended switching to unstable branch so I did and updated everything.

This came with plasma 6 that Bismuth doesn’t work with, so I installed Polonium and I was about to finish setting up my shortcuts when the screen turned black. I restarted hoping it helps but I just boot into a blank screen.

I booted a live image and manjaro-chroot -a gets me into the system.

Please help me recover or revert from this, I’m not sure how to proceed from here.

journalctl --boot=-1 --priority=3 --catalog --no-pager gives me this log: pastebin
Its moslty just nfs mount errors,

journalctl -a --boot -5 --no-pager here is the full log starting from branch switch

HW spec
CPU: Ryzen 9 7950X
GPU: RX 7900 XTX
also there is an 4090, buts its passed to a vm and not used normally

From the chroot environment, you might try uninstalling Polonium, considering that installing it was your last action before the issue occurred. Then reboot.

Perhaps if things are not working as hoped in Unstable, you might also consider reverting to Stable, and Wayland. Unstable is called Unstable for a reason.

That’s all I have, apart from:

Hi @slawo and welcome to the Manjaro community.

As a new user, please take some time to familiarise yourself with Forum requirements; in particular, the many ways to use the forum to your benefit. To that end, some or all these links will be invaluable:

And last, but not least, the Stable Update Announcements, which you should check frequently for important update related information. Occasionally an issue might be directly related to a particular update; it’s always best to check those announcements.


1 Like

Yeah, post midnight tunnel vision kicked in by the end :smiley:

So some additional info:

  • I see a lot of mentions of “manjaro unstable is arch stable”, I guess I believed it too much…
  • Polonium git page states “X11 has been briefly tested but is not supported.” So I thought it should function on a basic level.

Anyway, polonium is installed with kpackagetool6 and I couldn’t figure out how to revert that, so I opted for switching back to stable. In between rsync fixed a dirty flag on the boot drive, but there were no other errors. After reverting to stable I tried to downgrade packages back to their stable versions, but that fails with a big wall of text that starts like this:

error: failed to commit transaction (conflicting files)
kguiaddons5: /usr/bin/kde-geo-uri-handler exists in filesystem (owned by kguiaddons)
kguiaddons5: /usr/share/applications/google-maps-geo-handler.desktop exists in filesystem (owned by kguiaddons)
kguiaddons5: /usr/share/applications/openstreetmap-geo-handler.desktop exists in filesystem (owned by kguiaddons)
kguiaddons5: /usr/share/applications/qwant-maps-geo-handler.desktop exists in filesystem (owned by kguiaddons)
kguiaddons5: /usr/share/applications/wheelmap-geo-handler.desktop exists in filesystem (owned by kguiaddons)
kwallet5: /usr/bin/kwallet-query exists in filesystem (owned by kwallet)
kwallet5: /usr/share/man/man1/kwallet-query.1.gz exists in filesystem (owned by kwallet)
kglobalaccel5: /usr/lib/systemd/user/plasma-kglobalaccel.service exists in filesystem (owned by kglobalacceld)
syntax-highlighting5: /usr/share/org.kde.syntax-highlighting/syntax-bundled/4dos.xml exists in filesystem (owned by syntax-highlighting)

At this point I booted up the system and it works. Its really strange because plasma 6 is active with x11, polonium is working, as is valgrind. Makes me thing something completely unrelated went wrong.

For now I’ll test around if its stable enough, thanks for the help.

And that is correct - however - those on Arch or Manjaro unstable already know what to watch out for.

In your case I think kms - especially the kms hook in mkinicpio.conf HOOKS array is missing.

I don’t know much about passthrough - so the Nvidia card is a joker - which may or may not be involved - something about simple drm vs drm and kernel arguments.

1 Like

Most welcome.

Now that you’re back in Stable, probably the best you can do, is nothing (generally), until the usual updates bring you back on par with Stable.


In my defense I worked with arch, but mostly headless or simple i3 systems :smiley:

I dont think its the nvidia card, by specifying the cards pci id like this in /etc/default/grub
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash vfio-pci.ids=10de:2684,10de:22ba ... you guarantee that the pci device as a whole is ignored based on the kernel parameter, and this is necessary to avoid the host os initializing the card if you want to pass it thru to a vm as a whole.

As for mkinitcpio, I’m not too familiar I just added the gpu pass-thru related modules but I’m under the impression that kms should be handled automatically, and I also see here that its part of the default setup and I dont have it, I’ll add it if the system breaks again, for now its stable.

my /etc/mkinitcpio.conf

MODULES="vfio_pci vfio vfio_iommu_type1"
HOOKS="base udev autodetect modconf block keyboard keymap consolefont plymouth resume filesystems fsck"

I just came back from lunch and everything was frozen and unresponsive except my Kitty terminal :thinking: after rebooting I got the blank screen again.

Added the kms hook, cleared the dirty flag on the boot drive with fsck, no other errors, and it works again.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.