/boot/vmlinuz-6.1-x86_64' not found. error: you need to load the kernel first

error: file /boot/vmlinuz-6.1-x86_64’ not found.

error: you need to load the kernel first.

Press any key to continue.

What should I do now.

  Kernel: 6.1.11-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC
    misobasedir=manjaro misolabel=MANJARO_XFCE_2203 quiet
    systemd.show_status=1 splash apparmor=1 security=apparmor driver=free
    nouveau.modeset=1 i915.modeset=1 radeon.modeset=1
  Desktop: Xfce v: 4.18.1 tk: Gtk v: 3.24.36 info: xfce4-panel wm: xfwm
    v: 4.18.0 dm: LightDM v: 1.32.0 Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: Dell product: Latitude 3510 v: N/A serial: <filter>
    Chassis: type: 10 serial: <filter>
  Mobo: Dell model: 0J6VTW v: A03 serial: <filter> UEFI: Dell v: 1.13.0
    date: 02/08/2022
  ID-1: BAT0 charge: 33.9 Wh (100.0%) condition: 33.9/53.0 Wh (63.9%)
    volts: 15.7 min: 15.0 model: BYD DELL TXD030B type: Unknown serial: <filter>
    status: full
  RAM: total: 7.53 GiB used: 2.39 GiB (31.8%)
  Array-1: capacity: 64 GiB slots: 2 EC: None max-module-size: 32 GiB
    note: est.
  Device-1: DIMM A type: DDR4 detail: synchronous size: 8 GiB speed:
    spec: 3200 MT/s actual: 2667 MT/s volts: curr: 1.2 width (bits): data: 64
    total: 64 manufacturer: 019800000000 part-no: K6VDX7-MIE serial: <filter>
  Device-2: DIMM B type: no module installed
  Info: model: Intel Core i7-10510U socket: BGA1528 bits: 64 type: MT MCP
    arch: Comet/Whiskey Lake note: check gen: core 10 level: v3 note: check
    built: 2018 process: Intel 14nm family: 6 model-id: 0x8E (142)
    stepping: 0xC (12) microcode: 0xF4
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 8 MiB desc: 1x8 MiB
  Speed (MHz): avg: 1740 high: 2300 min/max: 400/4900 base/boost: 2673/2300
    scaling: driver: intel_pstate governor: powersave volts: 0.8 V
    ext-clock: 100 MHz cores: 1: 2300 2: 800 3: 2300 4: 2300 5: 800 6: 2300
    7: 2300 8: 821 bogomips: 36812
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
    arch_capabilities arch_perfmon art avx avx2 bmi1 bmi2 bts clflush
    clflushopt cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64
    dtherm dts epb ept ept_ad erms est f16c flexpriority flush_l1d fma fpu
    fsgsbase fxsr ht hwp hwp_act_window hwp_epp hwp_notify ibpb ibrs
    ibrs_enhanced ida intel_pt invpcid invpcid_single lahf_lm lm mca mce
    md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae pat pbe
    pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pts rdrand
    rdseed rdtscp rep_good sdbg sep smap smep ss ssbd sse sse2 sse4_1 sse4_2
    ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust tsc_deadline_timer
    vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt xsaves xtopology
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: retbleed mitigation: Enhanced IBRS
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB
    filling, PBRSB-eIBRS: SW sequence
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel CometLake-U GT2 [UHD Graphics] vendor: Dell driver: i915
    v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20 ports:
    active: eDP-1 empty: DP-1,HDMI-A-1,HDMI-A-2 bus-ID: 00:02.0
    chip-ID: 8086:9b41 class-ID: 0300
  Device-2: Sunplus Innovation Integrated_Webcam_HD type: USB
    driver: uvcvideo bus-ID: 1-6:4 chip-ID: 1bcf:2b98 class-ID: 0e02
  Display: x11 server: X.Org v: 21.1.7 compositor: xfwm v: 4.18.0 driver: X:
    loaded: modesetting alternate: fbdev,vesa dri: iris gpu: i915
    display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: eDP-1 model: BOE Display 0x0819 built: 2018 res: 1920x1080
    hz: 60 dpi: 142 gamma: 1.2 size: 344x194mm (13.54x7.64") diag: 395mm (15.5")
    ratio: 16:9 modes: 1920x1080
  API: OpenGL Message: Unable to show GL data. Required tool glxinfo missing.
  Device-1: Intel Comet Lake PCH-LP cAVS vendor: Dell
    driver: sof-audio-pci-intel-cnl
    alternate: snd_hda_intel,snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
    chip-ID: 8086:02c8 class-ID: 0401
  Sound API: ALSA v: k6.1.11-1-MANJARO running: yes
  Sound Server-1: JACK v: 1.9.21 running: no
  Sound Server-2: PulseAudio v: 16.1 running: yes
  Sound Server-3: PipeWire v: 0.3.65 running: yes
  Device-1: Intel Comet Lake PCH-LP CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:02f0 class-ID: 0280
  IF: wlp0s20f3 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Dell driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    port: 3000 bus-ID: 01:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: eno1 state: down mac: <filter>
  WAN IP: <filter>
  Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-10:6
    chip-ID: 8087:0026 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 3 state: up address: see --recommends
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 267.59 GiB used: 165.2 GiB (61.7%)
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Toshiba model: KBG40ZNS256G NVMe
    KIOXIA 256GB size: 238.47 GiB block-size: physical: 512 B logical: 512 B
    speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 10410105
    temp: 26.9 C scheme: GPT
  SMART: yes health: PASSED on: 2y 2d 17h cycles: 650
    read-units: 54,430,021 [27.8 TB] written-units: 33,488,536 [17.1 TB]
  ID-2: /dev/sda maj-min: 8:0 type: USB vendor: SanDisk model: Ultra
    size: 28.64 GiB block-size: physical: 512 B logical: 512 B type: N/A
    serial: <filter> rev: 1.00 scheme: MBR
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
  ID-3: /dev/sdb maj-min: 8:16 type: USB vendor: Generic model: SD MMC MS PRO
    size: 483.9 MiB block-size: physical: 512 B logical: 512 B type: SSD
    serial: <filter> rev: 1.00 scheme: MBR
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
  Message: No optical or floppy data found.
  ID-1: /mnt raw-size: 238.17 GiB size: 233.38 GiB (97.99%)
    used: 165.2 GiB (70.8%) fs: ext4 block-size: 4096 B dev: /dev/nvme0n1p2
    maj-min: 259:2 label: N/A uuid: 074b2a58-0d75-4160-b39d-e0f7b4a3ef70
  Alert: No swap data was found.
  ID-1: /dev/nvme0n1p1 maj-min: 259:1 size: 300 MiB fs: vfat label: N/A
    uuid: A421-ED9D
  ID-2: /dev/sda1 maj-min: 8:1 size: 3.76 GiB fs: iso9660
  ID-3: /dev/sda2 maj-min: 8:2 size: 4 MiB fs: vfat label: MISO_EFI
    uuid: 2E29-B694
  ID-4: /dev/sdb1 maj-min: 8:17 size: 482.9 MiB fs: vfat label: N/A
    uuid: AAD9-1617
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 12 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-2:2 info: SanDisk Ultra type: Mass Storage driver: usb-storage
    interfaces: 1 rev: 2.1 speed: 480 Mb/s power: 224mA chip-ID: 0781:5581
    class-ID: 0806 serial: <filter>
  Device-2: 1-3:3 info: Dell Universal Receiver type: Keyboard,Mouse,HID
    driver: hid-generic,usbhid interfaces: 3 rev: 2.0 speed: 12 Mb/s power: 100mA
    chip-ID: 413c:301c class-ID: 0300
  Device-3: 1-6:4 info: Sunplus Innovation Integrated_Webcam_HD type: Video
    driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA
    chip-ID: 1bcf:2b98 class-ID: 0e02
  Device-4: 1-7:5 info: Realtek USB2.0-CRW type: Mass Storage
    driver: ums-realtek interfaces: 1 rev: 2.0 speed: 480 Mb/s power: 500mA
    chip-ID: 0bda:0177 class-ID: 0806 serial: <filter>
  Device-5: 1-10:6 info: Intel AX201 Bluetooth type: Bluetooth driver: btusb
    interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA chip-ID: 8087:0026
    class-ID: e001
  Hub-2: 2-0:1 info: Super-speed hub ports: 6 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 45.0 C pch: 43.0 C mobo: 44.0 C
  Fan Speeds (RPM): cpu: 0
  Processes: 249 Uptime: 2h 49m wakeups: 380 Init: systemd v: 252
  default: graphical tool: systemctl Compilers: gcc: 12.2.1 clang: 15.0.7
  Packages: pm: pacman pkgs: 1144 libs: 317 tools: pamac pm: flatpak pkgs: 0
  Shell: Bash (sudo) v: 5.1.16 running-in: xfce4-terminal inxi: 3.3.25

Did you interrupt an update process?

In this case boot into a live ISO, manajro-chroot into your install and restart the update.



1 Like

then chroot into the system with Manjaro USB stick.
manjaro-chroot -a.
Then check /boot/.

That depends, on what you did before the error appeared :wink:


I remember I just update my system

Still get :error: file /boot/vmlinuz-6.1-x86_64’ not found.
error: you need to load the kernel first.

Press any key to continue. After doing that

It’s been awhile since I’ve given my old advice, but it seems this user is kind of confuse or their is a language barrier, so that being said…do you have a good backup of your data? Good, wipe and load. Yea I know it’s a lot of work for some, but it’s a sure proof way to fix your problem.

chroot and rerun update again:
pacman-mirrors --fasttrack 5 && pacman -Syyu
if there are no errors and you are up to date, post output from:
mhwd-kernel -li

I need to know your root partition, first of all. If you boot into your USB manjaro installation drive, run command

sudo parted -l

and post up the output.

Probably you are in GRUB shell. There you can type some commands like help, ls.

I like this rescue tutorial.

grub> ls

(proc) (hda) (hd0,msdos1) (hd1) (hd1,gpt2) (hd1,gpt1)


Which one should I choose

The disks:

  • /dev/sda (30.8GB), and
  • /dev/sdb (507MB)
    both seem to be using a Legacy/MBR patitioning scheme; whereas:
  • /dev/nvme0n1
    is UEFI (Logic suggests this is your new Manjaro installation).

UEFI and Legacy/MBR booting schemes often won’t coexist (they won’t play nicely). This alone may be causing some complication.

Try shutting down, removing the Sandisk Ultra and the other Generic disk. Then boot to BIOS and make sure the NVMe disk is selected to boot (it should be by virtue of removing the other two).

Then, try booting again. If the error persists, at least it will now be easier to diagnose and find a solution.

Note that you might wish to repartition the SanDisk to be UEFI-compliant if you wish to keep using it. The Generic disk (FAT16, with I presume DOS or Windows 3.x) should not be used with this configuration.

Aside:- To be fully UEFI booting, disable CSM completely in your BIOS.

I got another error
error: file `/boot/initramfs-6.1-x86_64’ not found.

Press any key to continue.

after I press a key,it stuck on boot logo

Could you perhaps be a little more verbose?

When did this additional error appear; what did you do before it appeared? Or, did it suddenly appear in addition to the original error, after doing nothing?

After repair kernel

Then you may need to recreate your initramdisks.

You can also use maxi -eg

to collect information about the boot process. This works,

  • when you are in your running system (with CTRL+ALT+F2).
  • And also in a live environment

Have you already tried to change the boot-order in your UEFI ?

If you don’t start being much more talkative, you will lose your installation because no one can give you good help with so little information that you give. :see_no_evil:

  • You must say what you are doing (in detail)
  • Then you have to say what the results are (don’t describe them, just copy them completely)
  • You must follow ALL the steps recommended to you (not just some random ones) (For example from @soundofthunder @brahma or @Wollie )
    Please use google translator if you are not so good with english !!!
1 Like

Otherwise, we can not help you to repair the installation.

I’ve solved two previous problems, but a new error appears
/lib/modules/6.1.23-1-MANJARO/modules.devname not found – ignoring
And stuck at boot logo but the word Manjaro appears before it



Plymouth is a boot screen intended to cover up onscreen text during boot; to make it prettier.
Unfortunately, Plymouth can sometimes cause more problems than it’s worth.

I suggest you uninstall Plymouth, completely.

The correct procedure to uninstall Plymouth can be found in Plymouth (Manjaro Wiki) under the heading of REMOVAL.

You should follow the procedure exactly. It’s not as simple as a normal uninstall. Once finished, reboot and hopefully the issue will be resolved. If not, or if another error occurs, be sure to report back.

I hope this helps. Cheers.