Boot to black screen on Raspberry Pi 4 when attempting to install


I imaged the 20.10 version of Manjaro ARM for raspberry pi 4 using the raspberry imager and when I try to boot it boots to a black screen.

Here’s what happens

It shows the standard linux boot screen with the list of things, and all of the items in it show OK (green).

It even says Manjaro ARM in green text at one point. After this screen the raspberry changes to the black screen and nothing happens after that.

What can I do in the Black Screen

In that screen

  • Hitting caps or num lock works (lock indicator lights in keyboard change)
  • If I hit ctrl+alt+del the raspberry reboots, to the same point.

Here’s what I know:

  • It’s not the SD card. I booted to the latest RPi OS in the same card imaged using raspberry imager.

What I’ve tried:

  • Tried running the 20.06 version instead of 20.10.

  • Tried all the different editions: KDE, XFCE, l3

  • Changed the HDMI port based on another post

  • Verified the SHA-1 of the downloaded images against the ones in the download page, and the downloaded images are valid (hashed using 7z crc).


I just love manjaro in the short time I’ve used it on my PC and I want to use it on my Pi4, in fact, having a dedicated manjaro machine was one of the motivators for me to buy a Pi, so any help/suggestions here is appreciated.
Thanks :smiley:

I’ll try using etcher and tell if that’s changed anything.

What kind of monitor do you have?

And what’s the content of /boot/config.txt?

These information is needed to troubleshoot further.

I have a Acer (KG241QP) gaming monitor, 1080p 144hz HDMI2.0.

The full contents:

# See /boot/overlays/README for all available options


initramfs initramfs-linux.img followkernel





#enable sound



#enable vc4



144hz not a choice. Will it do 120hz

yeah, I need to connect using DP for it to go 144hz (or use a dual hdmi setup), but when using a single hdmi it uses 60hz or 120hz (hdmi2.0 max). I’m connected using single hdmi, so I’m sure it’s not trying to run at 144hz.

I’ll try using a different monitor (60hz)

Is the display 16:9 or 64:27

it’s a standard 16:9 1080p monitor

Using the first hdmi port on the board:


Oh I tried a different, 60hz monitor and it shows the keyboard layout selector. So it works.

I’ll try the additional boot config you’ve provided and tell if that allows me to use my main monitor.
Thanks for all the help! :smile:

If that does not work above it might be an issue with the v3d and mesa. Try installing xf86-video-fbturbo-git and then rem out these lines in config.txt to look like this and reboot:

# dtoverlay=vc4-fkms-v3d
# max_framebuffers=2

Yep, that solved the problem! I undid the previous step, as it didn’t work, and did this and this was enough to fix it. Issue with high refresh rate monitors looks like.

Thanks for the help!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.