Boot to black after install

Hello everyone I just decided to switch to Linux and Decided on Manjaro. I got the ISO on Ventoy, made sure secure boot was off, switched on ACHI, turned off fast boot , and got a fresh 2tb SSD. I loaded up live environment and everything worked fine so I went ahead and launched the installer. During download I kept getting a pop up at the bottom right that was telling me I could mount my USB not sure if that is normal. Now after the restart at the end of the install My PC just boots to a black screen. I tried using my keyboard to get to grub but it either gets disconnected upon boot or grub just won’t open. Any ideas would be greatly appreciated as I’ve looked everywhere and can’t find anything to on the topic other than opening command line or grub Which I don’t think I can do.

Hello and Welcome to Manjaro,

What are you downloading? I don’t think its recommend to update your liveboot. Ignore the updates found, till you successfull booted from your install.

Hold shift, this should force you in Grub menue… if you booting from the right drive and your install is okay.

When you see nothing as a blackscreen, you maybe can try to go in TTY with crtl+alt+f1-f4 keys. But this doesn’t sound normal, at least you should see a login screen or a mouse cursor after a install.

Good Morning,

Which graphics card do you use Nvidia or AMD?

Which installation did you choose?
proprietary drivers or open source driver?

I guess other can help better with more Infos.


I am currently using a 2080 Nvidia card. I chose the open source drivers as the live environment would also just boot to a black screen if I used proprietary. Once at the black screen I have no way of restarting other than hitting the power button


For the first point I was referring to the installation of Manjaro not a download should have been more clear. I did get grub to work my timing with holding the shift key was off but Still no luck with TTY. If the information helps I believe my monitor and keyboard might be disconnecting shortly after the boot to black screen. I can still boot into the live environment completely fine as long as I choose the open source drivers as the proprietary option has the same boot to black problem. My GPU is a Nvidia 2080 and my CPU is an i7-9700k

I would suggest you to do a clean install.

Back up your home folder to a USB stick or elsewhere before installing.

Reinstall, but this time with separate partitions, one for the /root
and one for your /home personal folder.

Since you hadn’t answered the question. proprietary drivers or open source driver?

Take the changes to the /etc/default/grub “nvidia_drm.fbdev=1” and /etc/mkinitcpio.conf (nvidia nvidia_modeset nvidia_uvm nvidia_drm) as others had recommended to me (My Question here in the Forum) then restart.

And other like if you give more info like

inxi -v7azy or so

but rather wait with my answer until others correct my given answer or give you a better answer, since I am only an experienced beginner myself


If you installed Manjaro KDE, then this sounds like a Wayland problem. you can switch between wayland and x11 at your login screen (bottom left).

Anyways, this fix only your blackscreen with a mouse cursor issue with your liveboot + proprietary driver. But i have no idea why you have a blackscreen straight after install.

Possible there is something wrong around your USB Stick or Data corruption from your iso download. IDK maybe worth it to compare checksum.

Maybe your New SSD has a problem, how did you installed it? UEFI or in Legacy Mode? GPT for UEFI and MBR if you use Legacy.

You might see 2 different Boot entries for your bios boot on your USB Stick?
One is for EFI the other is for MBR boot.

You believe? So you not sure, if its going into standby after you waited for some time?
And crtl+alt+del isn’t working for a warm reset, because you Keyboard is disconnected?

Nvidia 2080Ti and i7-6700k here, but never had this strange problems :confused:

Just create again a new USB stick and reinstall your system, disconnected Monitor and Keyboard is something i never heared about.

Why should he backup? He just switched to Linux… and did a clean install.

Are you actually getting a log-in screen?
… One thing to try: press e in GRUB and edit the command line to remove quiet and splash.

I’m wondering if it’s a Plymouth issue.


I did install KDE. I will try the switch to x11 and see if it works. My SSD should be ok as It was detected on windows and shows up in boot. I did not however know GPT and MBR were not interchangeable I believe my motherboard uses UEFI and my SSD was MBR. I will definitely look into this first. For the boot on my USB I only see the EFI boot and after install I can see a boot option for manjaro as well as one that is the UEFI (or EFI I will be honest cannot recall) partition of manjaro. The only reason I say I believe the keyboard is disconnecting is because the back lighting goes out and stays out I’ve never had something like this happen during an OS install. I think my plan of action will be to change drive to GPT first and redownload ISO with checksum just in case then do the wayland switch if I still have problems. Thank you for the help so far btw still kinda new to this


No problem :slight_smile:
I hope we can get Manjaro running on your system.

I was thinking about that too, but since he can’t even access Grub… that’s not working. So he need to boot in a liveboot and chroot from there to remove this from Grub.

But disconnect Monitor and keyboard isn’t something that should occurred on a Plymouth issue.

Since you describes 2 different times from a blackscreen issue.

The first one after install and the second after you switched to proprietary driver on liveboot… its important to know if you experience the exact same blackscreen with Keyboard+Monitor shutdown or if there are something different.

The liveboot shows a check list, that can we also activate on your Installed Manjaro and @BG405 pointed to this list.

1 Like

I would have thought that the installer would not work if trying to install in (U)EFI mode on an MBR format. Although it does work the other way round (manually) installing in Legacy mode on GPT, such as the machine I’m using now, with the small “unformatted” bios_grub partition.

As far as i remember the installer should reject the install (in calamares) after choosing the Partition and respond with a error. But since im not installed Manjaro since 4 year’s, idk how is the situation right now with the newest Iso.

I remember GPT and Legacy boot is not possible under Windows. That was a pretty new info for me, as Philm released the install-grub tool which supported Legacy+GPT.

But i installed Manjaro on both my system in Legacy+MBR. For that reason i just bought just a normal M.2 SSD instead a M.2 NVMe on my Laptop. Because NVMe only supports UEFI… which i don’t like.

1 Like

Hello sorry I have not been keeping up with thread I have been busy. I believe my problem may have to do with plymouth as I found another thread where the user had very similar if not the exact same problems as me and fixed them by disabling plymouth. I also do have access to the grub menu It turns out I was just using the wrong inputs a bit silly of me I admit. Before I go about trying to fix this should I be installing Linux on GPT or MBR? My bios says it uses UEFI and I have no way to change it. I currently have another separate SSD in the system that has windows on it as well should I remove this during the Linux install? or should it be ok since its on a separate drive.

Normaly a Bios should give you the option to activate Legacy Mode.
Which Mode you want to use is up to you, i personal like to use Legacy right now, because its granted that no application will ever has a option to access my Bios and there is no Secure Boot and TPM possible, which i also like.

Besides this additional secure aspects which Legacy has. UEFI and GPT allows you more than 4 Partitions on a single Drive. And UEFI is also require for Resizable BAR which gives your GPU up to 10% more Performance in gaming. Not to mentionend there are GPU’s which won’t show a Post-Screen on Legacy Boot till you booted inside your OS.

Win11 also Official required UEFI/Secure Boot/TPM, even if you blocked it with tweaks right now, its maybe no longer possible to evade in the near future.

You can disable the SATA Ports from your other DISK’s, while you install Manjaro, just to evade mistakes. But i think it’s more needed when (vice versa) you have Linux already installed and you want to install Windows, because the Windows Boot Manager is more penetrating as Grub.

Alright great news I was able to launch and run the Live environment for proprietary and open source drivers. I decided to install with the latter as I’ve heard its easier for Nvidia. I also now have access to grub. With everything seemingly working besides the black screen I think its safe to assume it could very well be a plymouth issue. So my new question is how do I go about disabling/removing it?

what option have you used at install ? propietary or open source ? keep in mind that the open-source-nvidia driver is scrap in the end. it’s highly recommended to use the propietary-nvidia driver.

If you removed plymouth successfull you will see the same green coloured font checklist, same as when you booting from a USB Stick.

If still something is unclear just ask.

How would I be navigating to paths such as /ect/default /grub? Would I be doing it through grub command line or would I chroot in and do it from there

sudo nano /etc/default/grub

will open Nano text editor with the file.

I’d suggest making a backup first, before you alter anything:

sudo cp /etc/default/grub /etc/default/grub.old

… either from TTY or chroot.

1 Like

Boot to the Manjaro Live environment;
Enter a chroot environment;

manjaro-chroot -a

If using a BTRFS filesystem, please seek additional assistance for the required chroot procedure.


1 Like