Boot Time slow / laggy & FAILED notif in the boot text messages

Hi everyone,

been using Manjaro KDE for about 2 weeks or so and am super satisfied. However one problem I encountered recently is that it has this (arguably) long boot time.

I noticed that others in this forum seems to have super-fast boot time. Some reach below 10 seconds while regularly people are between 10-20 seconds.

Mine, however reach up 20+ and I noticed that it reached 30+ sometimes.
Here are my specs:

$ inxi -Fxz
System:
  Host: holovertex Kernel: 4.14.52-1-MANJARO x86_64 bits: 64 
  compiler: gcc v: 8.1.1 Desktop: KDE Plasma 5.13.2 tk: Qt 5.11.1 
  Distro: Manjaro Linux 17.1.11 Hakoila 
Machine:
  Type: Laptop System: LENOVO product: 80E1 v: Lenovo G40-45 
  serial: <filter> 
  Mobo: LENOVO model: Lancer 4B2 v: SDK0F82990 WIN serial: <filter> 
  UEFI: LENOVO v: A2CN25WW(V1.07) date: 08/26/2014 
Battery:
  ID-1: BAT1 charge: 29.1 Wh condition: 29.1/41.4 Wh (70%) 
  model: LENOVO PABAS0241231 status: Full 
CPU:
  Topology: Quad Core model: AMD A6-6310 APU with AMD Radeon R4 Graphics 
  bits: 64 type: MCP arch: Puma rev: 1 L2 cache: 2048 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 14379 
  Speed: 1066 MHz min/max: 1000/1800 MHz Core speeds (MHz): 1: 1707 
  2: 1057 3: 1032 4: 998 
Graphics:
  Card-1: AMD Mullins [Radeon R4/R5 Graphics] driver: radeon v: kernel 
  bus ID: 00:01.0 
  Display: x11 server: X.Org 1.19.6 driver: ati,radeon 
  unloaded: fbdev,modesetting,vesa resolution: 1366x768~60Hz 
  OpenGL: renderer: AMD MULLINS (DRM 2.50.0 4.14.52-1-MANJARO LLVM 6.0.0) 
  v: 4.5 Mesa 18.1.3 direct render: Yes 
Audio:
  Card-1: AMD Kabini HDMI/DP Audio driver: snd_hda_intel v: kernel 
  bus ID: 00:01.1 
  Card-2: AMD FCH Azalia driver: snd_hda_intel v: kernel bus ID: 00:14.2 
  Sound Server: ALSA v: k4.14.52-1-MANJARO 
Network:
  Card-1: Realtek RTL8723BE PCIe Wireless Network Adapter 
  driver: rtl8723be v: kernel port: 3000 bus ID: 01:00.0 
  IF: wlp1s0 state: up mac: <filter> 
  Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  driver: r8168 v: 8.045.08-NAPI port: 2000 bus ID: 02:00.0 
  IF: enp2s0 state: down mac: <filter> 
Drives:
  HDD Total Size: 465.76 GiB used: 240.63 GiB (51.7%) 
  ID-1: /dev/sda vendor: Western Digital model: WD5000LPCX-24C6HT0 
  size: 465.76 GiB 
Partition:
  ID-1: / size: 98.01 GiB used: 19.27 GiB (19.7%) fs: ext4 
  dev: /dev/sda10 
  ID-2: swap-1 size: 4.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda9 
Sensors:
  System Temperatures: cpu: 54.0 C mobo: N/A gpu: radeon temp: 47 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 199 Uptime: 21m Memory: 6.77 GiB used: 2.21 GiB (32.6%) 
  Init: systemd Compilers: gcc: 8.1.1 Shell: bash v: 4.4.23 inxi: 3.0.12

And here are my outputs, based from other forum posts I dig into

startup finished in 4.969s (kernel) + 19.542s (userspace) = 24.512s

$ systemd-analyze blame
          9.622s lvm2-monitor.service
          7.998s dev-sda10.device
          3.744s systemd-journal-flush.service
          3.565s NetworkManager.service
          3.431s ModemManager.service
          1.765s systemd-udevd.service
          1.703s avahi-daemon.service
          1.655s bluetooth.service
          1.645s systemd-logind.service
          1.232s polkit.service
           992ms wpa_supplicant.service
           926ms systemd-rfkill.service
           874ms tlp.service
           825ms systemd-fsck@dev-disk-by\x2duuid-CC55\x2dA829.service
           714ms udisks2.service
           713ms mnt-multimediator.mount
           713ms upower.service
           685ms sys-kernel-debug.mount
           634ms dev-hugepages.mount
           578ms systemd-remount-fs.service
           541ms user@1000.service
           451ms systemd-modules-load.service
           436ms systemd-timesyncd.service
           423ms systemd-tmpfiles-setup-dev.service
           416ms systemd-udev-trigger.service
           400ms boot-efi.mount
           347ms org.cups.cupsd.service
$ systemd-analyze blame --user 
          3.271s pulseaudio.service
           509ms gvfs-gphoto2-volume-monitor.service
           310ms gvfs-mtp-volume-monitor.service
           214ms obex.service
           190ms dbus.socket
           180ms gvfs-udisks2-volume-monitor.service
           108ms gvfs-daemon.service
            92ms xdg-user-dirs-update.service
            62ms gvfs-afc-volume-monitor.service
            31ms at-spi-dbus-bus.service

Here are the plots, if needed

$ systemd-analyze critical-chain
The time after the unit is active or started is printed after the "@" charac>
The time the unit takes to start is printed after the "+" character.

graphical.target @18.667s
└─multi-user.target @18.662s
  └─systemd-user-sessions.service @18.622s +32ms
    └─network.target @18.618s
      └─NetworkManager.service @15.053s +3.565s
        └─dbus.service @15.046s
          └─basic.target @15.044s
            └─sockets.target @15.044s
              └─dbus.socket @15.044s
                └─sysinit.target @14.902s
                  └─systemd-backlight@backlight:radeon_bl0.service @16.731s >
                    └─system-systemd\x2dbacklight.slice @16.727s
                      └─system.slice @2.765s
                        └─-.slice @2.765s
$ journalctl --disk-usage
Archived and active journals take up 384.1M in the file system.

Is it normal? Is it something that’s device specific? I hope I can gather some information deeper since I just noticed whenever I boot my linux, there’s always this red FAILED notification on those text streams like thus:

As for me, I use splash screen, autologin, and just rename some text in GRUB using grub customizer.

and here are my kernel parameters

I renamed it since I have this problem earlier like experienced by another user in another thread (link) where I had to to rename the manjaro efi file as the windows efi file.

I think the culprit here is the red FAILED notif and also these:

      9.622s lvm2-monitor.service
      7.998s dev-sda10.device
      3.744s systemd-journal-flush.service
      3.565s NetworkManager.service
      3.431s ModemManager.service

Any suggestion? Or are there other outputs I should provide here?

Can you please remove all these services and gain 10 seconds boot time. :stuck_out_tongue_winking_eye:

$ systemd-analyze blame
9.622s lvm2-monitor.service
7.998s dev-sda10.device
3.744s systemd-journal-flush.service
3.565s NetworkManager.service
3.431s ModemManager.service
1.765s systemd-udevd.service
1.703s avahi-daemon.service
1.655s bluetooth.service
1.645s systemd-logind.service
1.232s polkit.service

Seriously you can probably disable a few of them at least.

So something like sudo systemctl stop ModemManager.service and then from there if all works well you would permanently remove the service from startup.

Wait - we can just disable these services without consequences?

1 Like

hahaha, yes it is very possible.
I am not on my Manjaro box right now but if I were my list of startup services would be different. Also you need to look at what is taking the time, do you use lvm2 drive schema to make many drives/partitions look like one?

Oowh okay. You know, I am a newbie here. Maybe a bit paranoid, but should it happen that I will need the services again, how do I turn it on? Do I need some sort of GUI for this, which enables me to turn it on and off?

or is it just utter parashitic services running from the beginning?

Now I don’t even know what is lvm2 drive schema or whatnot.

Please see https://superuser.com/questions/513159/how-to-remove-systemd-services

There are GUIs I think? Actually not sure about that, anyway anything you do can be undone. Please spend some time learning systemctl and what it does.
You should not just go turning off things before you really know if you need them or not.
On the other hand I am pretty sure you can eliminate at least a couple of those, have fun.

That’s a bunch of starters already. Thanks for the help! Brb reading the stuff

1 Like

So, the red FAILED notification means nothing?

btw, I just read the information here. It’s so complete on how to remove processes!

1 Like

Hi everyone, I just read a lot of information in this forum and out of forum, and disabled these services:

1. Bluetooth
sudo systemctl stop bluetooth.service
sudo systemctl disable bluetooth.service

2. ModemManager (For 2G/3G/4G Data Modem)
sudo systemctl stop ModemManager.service
sudo systemctl disable ModemManager.service

3. systemd-journal-flush.service (logs flusher)
sudo journalctl --vacuum-time=7d

4. lvmm2-monitor.service (Linux Volume Manager)
sudo systemctl stop lvm2-monitor.service  
sudo systemctl disable lvm2-monitor.service

To my surprise, they are “resurrected” when I rebooted. Here are my systemd-analyze blame

 10.081s systemd-journal-flush.service
          7.903s lvm2-monitor.service
          4.471s dev-sda10.device
          2.902s polkit.service
          2.559s upower.service
          2.442s NetworkManager.service
          1.958s mnt-multimediator.mount
          1.573s ldconfig.service
          1.468s avahi-daemon.service
          1.442s bluetooth.service
          1.431s systemd-logind.service
          1.125s wpa_supplicant.service
           772ms boot-efi.mount
           766ms tlp.service
           764ms udisks2.service
           673ms systemd-sysusers.service
           643ms systemd-udev-trigger.service
           638ms dev-hugepages.mount
           547ms user@1000.service
           519ms sys-kernel-debug.mount
           510ms systemd-journal-catalog-update.service
           485ms systemd-udevd.service
           452ms dev-mqueue.mount
           448ms systemd-remount-fs.service
           439ms systemd-fsck@dev-disk-by\x2duuid-CC55\x2dA829.service
           436ms systemd-timesyncd.service
           348ms packagekit.service

So I tried masking the services instead - and here are the results:

sudo systemd-analyze blame
          6.062s mnt-multimediator.mount
          3.365s dev-sda10.device
          2.700s boot-efi.mount
          2.397s NetworkManager.service
          2.243s ldconfig.service
          2.063s systemd-journal-flush.service
          1.941s polkit.service
          1.469s upower.service
          1.354s systemd-timesyncd.service
          1.178s systemd-logind.service
           931ms avahi-daemon.service
           868ms user@1000.service
           852ms udisks2.service
           831ms systemd-rfkill.service
           795ms systemd-tmpfiles-setup.service
           742ms tlp.service
           693ms systemd-sysusers.service
           677ms systemd-fsck@dev-disk-by\x2duuid-CC55\x2dA829.service
           558ms dev-hugepages.mount
           557ms dev-mqueue.mount
           552ms systemd-journal-catalog-update.service
           418ms systemd-udevd.service
           407ms systemd-udev-trigger.service
           385ms wpa_supplicant.service
           307ms systemd-modules-load.service
           301ms packagekit.service
           301ms kmod-static-nodes.service
           301ms systemd-journald.service 

I squeezed just about 5 seconds. I thought it will be bigger, thought, like getting 10 seconds of it. So am I doing the process correctly? I thought I left out some key components.

As you can see, my multimediator mount (which is auto-mounting one of my drives) suddenly takes more time. Is it normal like this?

  1. Bluetooth
    sudo systemctl mask bluetooth.service

  2. ModemManager (For 2G/3G/4G Data Modem)
    sudo systemctl mask ModemManager.service

  3. systemd-journal-flush.service (logs flusher)
    sudo journalctl --vacuum-time=7d

  4. lvmm2-monitor.service (Linux Volume Manager)
    sudo systemctl mask lvm2-monitor.service

From what i see, the boot time is quite correct for a 5400rpm HDD as your model is. Disabling and masking services must be done with precaution … Just my 2¢ :wink:

1 Like

This is probably because they are required by another service. Masking them may break things.

Keep in mind that any boot less than 30 seconds is perfectly good for a standard spinning HDD.

If boot time is the most important thing, replace your HDD with an SSD.

1 Like

Noted. If below 30 secs are standards for HDD, then so be it. I will be perfectly content. Perhaps it was just my perfectionistic paranoid that my system is sluggish (while it’s actually not). Linux can only do so much right? It’s still dependent on the machines it’s running on. Besides, it’s consistently faster than my W10.

The proof, I just booted my machine and look at these logs:

$ systemd-analyze
Startup finished in 4.970s (kernel) + 20.020s (userspace) = 24.991s
graphical.target reached after 18.828s in userspace

$ systemd-analyze blame
         12.031s systemd-journal-flush.service
          3.703s mnt-multimediator.mount
          3.616s dev-sda10.device
          3.055s systemd-fsck@dev-disk-by\x2duuid-CC55\x2dA829.service
          2.412s polkit.service
          2.348s ldconfig.service
          1.324s NetworkManager.service
          1.200s tlp.service
          1.131s udisks2.service
          1.103s systemd-rfkill.service
          1.043s upower.service
           902ms systemd-logind.service
           890ms avahi-daemon.service
           814ms user@1000.service
           675ms systemd-journal-catalog-update.service
           642ms systemd-sysusers.service
           467ms dev-mqueue.mount
           467ms systemd-remount-fs.service
           462ms sys-kernel-debug.mount
           453ms systemd-udev-trigger.service
           451ms dev-hugepages.mount
           436ms boot-efi.mount
           415ms wpa_supplicant.service
           410ms systemd-timesyncd.service
           406ms systemd-journald.service
           373ms systemd-udevd.service
           358ms systemd-tmpfiles-setup.service

It seems that no matter what services I squashed, my boot time ranges from 19 to 25 secs. I will be contend with it then. At least I tried and learned a lot!

As for changing HDD to SSD, it’s actually within my list - but I found it economically and ergonomically safer if I change my laptop too. My current machine is already quite old.

Btw, in tweaking my boot time, I found systemd-ui (a package in repo) to be VERY useful. Much easier than using the terminal, at least for me.

Thanks for all the help and tips, folks!

Se also this post regarding haveged (dismiss the name just read the exhausting entropy pool and the fix for it). It might help a bit.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by