Boot time and Running Slow - fresh install

Start sector position of the swap partition should be a multiple of 4096 (your physical sector size). If you don’t get it done with first try - don’t worry you can check it afterwards with

sudo fdisk -l

First sector: 1446689126
Last sector: 1465144064
Total sector: 18454939

edit: so how do I move this to get this aligned correctly?

Start sector 1446689128 would be fine. :wink:

When I am in GParted, and moving the arrows, what exactly am I looking for?
Reducing the linux-swap partition size I am guessing? It then creates an unallocated partition space?

I think GParted won’t allow you to move only by 2 sectors but setting 1 MiB free unallocated space before the partition should be fine. Keep “MiB” in the field “Alignment to”. Then the partition is aligned perfectly after you execute the change in GParted.

Thanks @Wollie.

In GParted, I:
Set free space preceding to 1Mb
New size 9010
Free space following 2Mb
Align to MiB.


Disk /dev/sda: 698.64 GiB, 750156374016 bytes, 1465149168 sectors
Disk model: ST750LM022 HN-M7
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: 07ED1A8A-3900-904A-9379-412EC64306B1

Device          Start        End    Sectors   Size Type
/dev/sda1        4096     618495     614400   300M EFI System
/dev/sda2      618496 1446689125 1446070630 689.5G Linux filesystem
/dev/sda3  1446692864 1465145343   18452480   8.8G Linux swap

I’ll do a reboot now and see if any changes.

I edited the # out of the /etc/fstab file, saved and rebooted.
Not showing signs of increased boot time.

I tried:

And just went for a restart. No changes. Still 1:00 to login, and then at around 2:30 I’m in Firefox again.

I knew this machine was on it’s last legs, but thought I could at least get a good run out of KDE haha.
Any other options? I haven’t tried the live ISO boot you mentioned earlier in step 2.

Edit a few hours later: I’m going to attempt to do a clean instal of XFCE. From what I understand it will run general tasks better which is what I am after (Libreoffice, and most things just run and open too slow for me now). I will update this thread after if there’s any changes.

I assume the speed of your hdd is currently your limiting factor, but trying another DE could give you evidence. I would have checked some other things, first. For example you could post:

cat etc/default/grub

I’m in a live boot now via USB running XFCE iso.


  Kernel: 5.8.16-2-MANJARO x86_64 bits: 64 compiler: N/A 
  parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us 
  tz=Asia/Seoul utc=yes driver=nonfree nouveau.modeset=0 i915.modeset=1 
  radeon.modeset=1 misobasedir=manjaro misolabel=MANJARO_XFCE_2012 quiet 
  systemd.show_status=1 apparmor=1 security=apparmor 
  Desktop: Xfce 4.14.2 tk: Gtk 3.24.20 info: xfce4-panel wm: xfwm4 
  dm: LightDM 1.30.0 Distro: Manjaro Linux 
  Type: Laptop System: ASUSTeK product: N56VZ v: 1.0 serial: <filter> 
  Mobo: ASUSTeK model: N56VZ v: 1.0 serial: <filter> 
  UEFI: American Megatrends v: N56VZ.215 date: 11/02/2012 
  ID-1: BAT0 charge: 21.5 Wh condition: 22.5/57.7 Wh (39%) volts: 11.1/11.1 
  model: ASUSTeK N56--52 type: Li-ion serial: N/A status: Unknown 
  cycles: 577 
  Topology: Quad Core model: Intel Core i7-3630QM bits: 64 type: MT MCP 
  arch: Ivy Bridge family: 6 model-id: 3A (58) stepping: 9 microcode: 21 
  L2 cache: 6144 KiB 
  flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 38328 
  Speed: 1197 MHz min/max: 1200/3400 MHz Core speeds (MHz): 1: 1196 2: 1197 
  3: 1197 4: 1197 5: 1198 6: 1197 7: 1197 8: 1197 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds status: Vulnerable: No microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel 3rd Gen Core processor Graphics vendor: ASUSTeK N56VZ 
  driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:0166 
  Device-2: NVIDIA GK107M [GeForce GT 650M] driver: N/A 
  alternate: nouveau, nvidia_drm, nvidia bus ID: 01:00.0 chip ID: 10de:0fd1 
  Device-3: Sunplus Innovation Asus Webcam type: USB driver: uvcvideo 
  bus ID: 3-1.3:4 chip ID: 1bcf:2883 
  Display: x11 server: X.Org 1.20.9 driver: intel display ID: :0.0 
  screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
  s-diag: 582mm (22.9") 
  Monitor-1: LVDS1 res: 1920x1080 hz: 60 dpi: 143 
  size: 340x190mm (13.4x7.5") diag: 389mm (15.3") 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 4000 (IVB GT2) 
  v: 4.2 Mesa 20.1.8 compat-v: 3.0 direct render: Yes 
  Device-1: Intel 7 Series/C216 Family High Definition Audio 
  vendor: ASUSTeK N56VZ driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  chip ID: 8086:1e20 
  Device-2: NVIDIA GK107 HDMI Audio driver: snd_hda_intel v: kernel 
  bus ID: 01:00.1 chip ID: 10de:0e1b 
  Sound Server: ALSA v: k5.8.16-2-MANJARO 
  Device-1: Intel Centrino Wireless-N 2230 driver: iwlwifi v: kernel 
  port: f040 bus ID: 03:00.0 chip ID: 8086:0887 
  IF: wlp3s0 state: up mac: <filter> 
  Device-2: Qualcomm Atheros AR8161 Gigabit Ethernet vendor: ASUSTeK N56VZ 
  driver: alx v: kernel port: d000 bus ID: 04:00.0 chip ID: 1969:1091 
  IF: enp4s0 state: down mac: <filter> 
  Local Storage: total: 755.92 GiB used: 338.9 MiB (0.0%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda vendor: Seagate model: ST750LM022 HN-M750MBB 
  size: 698.64 GiB block size: physical: 4096 B logical: 512 B 
  speed: 3.0 Gb/s rotation: 5400 rpm serial: <filter> rev: 0001 scheme: GPT 
  ID-2: /dev/sdb type: USB vendor: SanDisk model: Ultra size: 57.28 GiB 
  block size: physical: 512 B logical: 512 B serial: <filter> rev: 1.00 
  scheme: MBR 
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure? 
  ID-1: / raw size: N/A size: 5.75 GiB used: 338.9 MiB (5.8%) fs: overlay 
  source: ERR-102 
  Alert: No Swap data was found. 
  System Temperatures: cpu: 58.0 C mobo: N/A 
  Fan Speeds (RPM): cpu: 2500 
  Processes: 235 Uptime: 5m Memory: 7.66 GiB used: 1.30 GiB (17.0%) 
  Init: systemd v: 246 Compilers: gcc: N/A Packages: pacman: 1141 lib: 313 
  flatpak: 0 Shell: Bash v: 5.0.18 running in: xfce4-terminal inxi: 3.1.05 


Warning: config '/var/lib/mhwd/db/pci/graphic_drivers/hybrid-intel-nvidia-340xx-bumblebee/MHWDCONFIG' is invalid!
Warning: config '/var/lib/mhwd/db/pci/graphic_drivers/hybrid-intel-nvidia-418xx-bumblebee/MHWDCONFIG' is invalid!
Warning: config '/var/lib/mhwd/db/pci/graphic_drivers/hybrid-intel-nvidia-430xx-bumblebee/MHWDCONFIG' is invalid!
Warning: config '/var/lib/mhwd/db/pci/graphic_drivers/hybrid-intel-nvidia-435xx-prime/MHWDCONFIG' is invalid!
Warning: config '/var/lib/mhwd/db/pci/graphic_drivers/hybrid-intel-nvidia-440xx-prime/MHWDCONFIG' is invalid!
Warning: config '/var/lib/mhwd/db/pci/graphic_drivers/nvidia-340xx/MHWDCONFIG' is invalid!
Warning: config '/var/lib/mhwd/db/pci/graphic_drivers/nvidia-418xx/MHWDCONFIG' is invalid!
Warning: config '/var/lib/mhwd/db/pci/graphic_drivers/nvidia-430xx/MHWDCONFIG' is invalid!
Warning: config '/var/lib/mhwd/db/pci/graphic_drivers/nvidia-435xx/MHWDCONFIG' is invalid!
Warning: config '/var/lib/mhwd/db/pci/graphic_drivers/nvidia-440xx/MHWDCONFIG' is invalid!
Warning: config '/var/lib/mhwd/db/pci/graphic_drivers/catalyst/MHWDCONFIG' is invalid!
Warning: config '/var/lib/mhwd/db/pci/network_drivers/r8168/MHWDCONFIG' is invalid!
Warning: config '/var/lib/mhwd/db/pci/network_drivers/rt3562sta/MHWDCONFIG' is invalid!
> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
video-hybrid-intel-nvidia-390xx-bumblebee            2020.10.04               false            PCI

Warning: No installed USB configs!

Today I’ve also tried mint and lubuntu distros. All distros including manjaro seem to run fine off the Usb, until I install them on my laptop and then they have the very slow boot times.

Manjaro xfce shows an improvement in boot time and opening programs. Mint was okay but had wifi problems, and lubuntu had graphic problems in libreoffice. Both mint and lubuntu kept having some error message on startup before login about PCE or something rather. I’m actually going to reinstall Manjaro xfce now because that’s the one I’d like to make work best if possible.

I’m back on Manjaro XFCE installed on my laptop. I’ve run most of the commands from this thread again already.
Boot times slightly better than KDE, with programs like Firefox and Libreoffice starting sightly quicker too.

This returns:

cat: etc/default/grub: No such file or directory

just before installing , check if USB iso manjaro boot is ok with no-free drivers

A) EFI bios boot

recheck all options in EFI bios

  • no Secureboot
  • no fastboot
  • no legacy
  • no CSM
  • all disks on AHCI
  • may be keep USB storage on

boot on USB iso manjaro with no-free drivers

check if all good EFI

inxi  -Mxxa ( check for UEFI or bios , not UEFI[legacy] )
test -d /sys/firmware/efi && echo efi || echo bios
sudo efibootmgr -v
sudo parted -l ( GPT is better case )

then redo installation ,
for EFI: GPT + /boot/efi ( partition /boot/efi type vfat ( FAT32 ) with flag boot & esp )
for Bios + GPT ( create partition 33Mo NOT FORMATTED with flag bios_grub )

B) for trouble on slow boot

Kernel: 5.8.16-2-MANJARO x86_64

UEFI: American Megatrends v: N56VZ.215 date: 11/02/2012 

Topology: Quad Core model: Intel Core i7-3630QM bits: 64 type: MT MCP 
 arch: Ivy Bridge family: 6 model-id: 3A (58) stepping: 9 microcode: 21  L2 cache: 6144 KiB 

 ID-1: /dev/sda vendor: Seagate model: ST750LM022 HN-M750MBB 
 size: 698.64 GiB block size: physical: 4096 B logical: 512 B 

 System Temperatures: cpu: 58.0 C mobo: N/A 
 Fan Speeds (RPM): cpu: 2500 


  1. Ivy bridge and haswell have trouble from microcode ( all distributions ), check cpu idle with htop
  2. if possible update to last good UEFI bios version
  3. in your case , check also
    “sudo cpuppower info-frequency”
    “sudo powertop” ( use tab after )
  4. your heat cpu & fan are heavy , see for any clean dust if possible
  5. if you can , change your HDD for an SSD , it will boot really faster

after install

sudo pacman -S powertop htop  cpupower  lm_sensors haveged
sudo systemctl enable --now haveged
sudo sensors-detect
sudo mhwd-kernel -i linux419 linux54

on next reboot press Esc to see Grub ,
and select older kernel ( 4.19 LTS or 5.4 LTS or 5.8 or 5.9 )
keep always 2 ore more kernels installed in case of trouble

also check

sudo systemd-analyze blame 
sudo systemd-analyze critical-chain
sudo journalctl -b0 -p4

Sorry, misspelling it should have been

cat /etc/default/grub

Looking at your disk it is a superslow notebook hdd, 7 years old, even at release time one of not-so-fast models. So, in the end I fear with all the software tweaks, you won’t gain the time you invest. Replacing the disk with a ssd should give it a real boost.

The faster impression you got from windows might be the result of win using some sort of hibernation instead of full shutdown in most cases.

GRUB_CMDLINE_LINUX_DEFAULT="quiet apparmor=1 security=apparmor resume=UUID=f9620ed0-383b-482f-9df0-473fc0c365f5 udev.log_priority=3"

# If you want to enable the save default function, uncomment the following
# line, and set GRUB_DEFAULT to saved.

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices

# Uncomment to use basic console

# Uncomment to disable graphical terminal

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command 'videoinfo'

# Uncomment to allow the kernel use the same resolution used by grub

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"

# Uncomment to disable generation of recovery mode menu entries

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper
# modes only.  Entries specified as foreground/background.

# Uncomment one of them for the gfx desired, a image background or a gfxtheme

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

Yeah I figured as much. On it’s last legs (or well past it) this HDD. I may begin looking at changing it for an SSD at some point.

To be honest I am quite happy with the performance of Manjara Xfce that I am getting at the moment. After about 2-3mins of getting past the booting in and logging in, it runs quite smooth. So I can only imagine with an SSD it would be flying.

@stephane Wow thanks for the post! Lot’s of details there for a beginner like me to go through. At least for today I’ll wait to go through another re-install after Manjara is feeling ok (excluding the boot time). I’ll see if I can clean some dust out. And yeah I’ll look at the SSD option too.

Would you recommend I run this now with my current install?

yes , it’s better to see now values , change and see after …


I followed this through with all the “YES” commands, this was the result:

Now follows a summary of the probes I have just done.
Just press ENTER to continue: 

Driver `coretemp':
  * Chip `Intel digital thermal sensor' (confidence: 9)

Do you want to generate /etc/conf.d/lm_sensors? (YES/no): YES
Created symlink /etc/systemd/system/ → /usr/lib/systemd/system/lm_sensors.service.
Unloading i2c-dev... OK
Unloading cpuid... OK

I pressed Esc at reboot, and saw these options:
Atheros Boot Agent
Enter Setup

I wasn’t sure, so I just went into setup and rebooted as normal back into Manjaro haha.


htop ( in one terminal see cpu idle , no other apps )
sudo powertop ( in another terminal and tab )
sudo cpupower frequency-info

Not sure what info to post but I’ll do my best here.

960G/7.66G, Tasks 74, 129 thr, 1 running.

C7(pc7) 92%
C7(cc7) 98.9%
Core (HW)
C7 (cc7) 96.9%

The other “C”'s show from zero-1% (not sure what all this means?)

analyzing CPU 0:
  driver: intel_cpufreq
  CPUs which run at the same hardware frequency: 0
  CPUs which need to have their frequency coordinated by software: 0
  maximum transition latency: 20.0 us
  hardware limits: 1.20 GHz - 3.40 GHz
  available cpufreq governors: performance schedutil
  current policy: frequency should be within 1.20 GHz and 3.40 GHz.
                  The governor "schedutil" may decide which speed to use
                  within this range.
  current CPU frequency: Unable to call hardware
  current CPU frequency: 1.99 GHz (asserted by call to kernel)
  boost state support:
    Supported: yes
    Active: yes
    3200 MHz max turbo 4 active cores
    3200 MHz max turbo 3 active cores
    3300 MHz max turbo 2 active cores
    3400 MHz max turbo 1 active cores
Adapter: ISA adapter
Package id 0:  +54.0°C  (high = +87.0°C, crit = +105.0°C)
Core 0:        +54.0°C  (high = +87.0°C, crit = +105.0°C)
Core 1:        +44.0°C  (high = +87.0°C, crit = +105.0°C)
Core 2:        +42.0°C  (high = +87.0°C, crit = +105.0°C)
Core 3:        +47.0°C  (high = +87.0°C, crit = +105.0°C)

Adapter: ACPI interface
in0:          11.10 V  

Adapter: ACPI interface
temp1:        +52.0°C  (crit = +108.0°C)

Adapter: ISA adapter
cpu_fan:     1900 RPM
temp1:        +52.0°C  

Change this into


and you save another 8 sec.


sudo update-grub

to make it effective at next boot.

Is it necessary to change the grub timeout?
I don’t think my grub appears? I Just see theAsus and intel logo for about half a second, and then it turns to black screen for about 45sec before the cursor and log in screen appears.

Try it.