Boot stuck on OEM(hp) logo


I’ve looked it up.

  1. edited the boot option (replaced quit with 3) and booted.

  2. detailed boot started but stuck on missing files which are as follow

[7.545876] Bluetooth : hci0 : BCM : firmware Patch file not found , tried :
[7.545878] Bluetooth : hci0 : BCM : ‘brcm/BCMHK20782A1-0a5c-21e3.hcd’
[7.545879] Bluetooth : hci0 : BCM : ‘brcm/BCM-0a5c-21e3.hcd’


  1. logged in, tried installing BCM drivers and updating the system while at it.

  2. tried booting again and same issue persist.

Please help I don’t want to format the machine. :expressionless:

@megavolt I saw you clicked on question mark button. Is there anything that you need clarification on? I will happy to oblige.

Hello dear community, hope you are doing well.

I have posted my first query here yesterday which i find lacking in describing my issue.


  • I looked it on the forum and came across few posts.
  1. Manjaro is stuck in loading splash screen
  2. Manjaro Stuck at Logo When Booting
  • I sudo nano-ed the /etc/default/grub
    and remove “quiet” from GRUB_CMDLINE_LINUX_DEFAULT="quiet apparmor=1 security=apparmor udev.log_priority=3" , saved it and updated the grub.

  • upon rebooting, I encountered the same line during the boot up.
    [numbers] Bluetooth : hci0 : BCM : firmware Patch file not found , tried :
    [numbers] Bluetooth : hci0 : BCM : ‘brcm/BCMHK20782A1-0a5c-21e3.hcd’
    [numbers] Bluetooth : hci0 : BCM : ‘brcm/BCM-0a5c-21e3.hcd’

other non-important info.

  1. i have it in a dual boot configuration.
  2. Network device, Broadcom BCM4313 802.11bgn Wireless Network Adapter
    vendor: Hewlett-Packard driver: bcma-pci-bridge v: N/A port: 4000
    bus ID: 07:00.0.
  3. i have updated mirror list, upgraded the system

Hello @Mahakaal :wink:

As I made some research, there are problems with bluetooth devices connected via usb (or internally connected as usb) with kernel 5.10 and above.

Which kernel are you using? Did you tried installing and booting linux54? Probably fixed with kernel 5.11…

  1. Start a live session with a install disk.
  2. Open terminal and type manjaro-chroot -a
  3. Then install the kernel:
mhwd-kernel -i linux54
  1. Reboot and choose the kernel at the grub bootloader
1 Like

Now it’s showing anything but boot stops after

Reached target Graphical Interface


If it stops there, then more information are at the xorg log in /var/log/.

 for x in /var/log/Xorg*; do echo -e "\n--- $x ---\n$(cat $x)"; done

With that you can upload it:

 for x in /var/log/Xorg*; do echo -e "\n--- $x ---\n$(cat $x)"; done | curl -F'file=@-'
1 Like
  1. do i just copy paste them?
  2. what does it do?
  1. yes
  2. grabs all xorg logs and print it on the screen, the second one print nothing, but pipe it to curl and it uploads it to, then a link will be displayed.

sorry forgot to mention. You can switch to another tty CTRL+ALT+F3, login and type it there, or start a live session with a install disk, open a terminal, type manjaro-chroot -a and type it there.

1 Like

[    17.059] (II) LoadModule: "vesa"
[    17.059] (II) Loading /usr/lib/xorg/modules/drivers/
[    17.059] (II) Module vesa: vendor="X.Org Foundation"
[    17.059] 	compiled for 1.20.9, module version = 2.5.0
[    17.059] 	Module class: X.Org Video Driver
[    17.059] 	ABI class: X.Org Video Driver, version 24.1
[    17.059] (II) VESA: driver for VESA chipsets: vesa

This is the problem… please keep sure only video-linux is installed:
(if your on a live session, keep sure you are at a chroot)

manjaro-chroot -a


mhwd -li

if not only video-linux is installed, then:

sudo mhwd -r pci video-modesetting
sudo mhwd -r pci video-vesa
sudo mhwd -f -i pci video-linux
1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.