Boot stuck at "[sda] Assuming drive cache: write through"

I’ve tried Manjaro Gnome from a live USB and everything was good so I have installed it from this USB. It said that installation was successful and after that I rebooted my laptop to boot from a freshly installed system. But unfortunately it was stuck on the Lenovo logo so I’ve removed “quiet splash” in the grub menu and now I can see the output: everything looks good but then it stucks, the last line is “[sda] Assuming drive cache: write trough” and two lines before this is “started gnome display manager”. I can’t use a terminal (Ctrl + Alt + F2 doesn’t work).

It is a Lenovo laptop with i7 Tiger Lake and nvidia MX450 (I have chosen “start with proprietary drivers” when booting live USB if that matters).

I’ve tried to search but haven’t found anything which could solve it so I would like to ask you for help. Please tell me what information should I provide to help you with helping me. :slight_smile:

Thank you!

Is it a hybrid card? Then try to add the Intel one to the initramfs:

Replace MODULES=() with:


at /etc/mkinitcpio.conf

Then run sudo mkinitcpio -P to update the initramfs.

Reason of this is that the driver scheduled late and therefore the display-manager does not start at first time when switching from basic video mode to the graphical mode

You can boot into single mode (recovery), by adding GRUB_DISABLE_RECOVERY=false to /etc/default/grub and run sudo update-grub. Then you will have 3rd entry for the same kernel with “(recovery)”. There you should be able to do this.

OR just add temporary only single to the kernel parameter to the bootmenu by typing E.

Wow, that worked, thank you! I’ve used manjaro-chroot -a from the live USB to change the file.

But still, it’s weird for me that there was no problem when running from live USB but the problem occurred in a full installation…

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.