Boot screen stuck on "/dev/sda1 clean, ..."

Hello all,

I’m using Manjaro KDE in an Oracle Virtual box installed on Windows 10. I had no problems with the installation for almost 16 months. Now after an update, my boot screen is stuck on.

/dev/sda1: recovering journal
/dev/sda1: clean, xxxx/yyyy files, xxxxx/yyyyy blocks

Based on some questions posted in this forum.

  1. I have opened a terminal using Ctrl + Alt + F2 and tried to remove the video-nvidia, video-linux, nonfree 0300 [1], cleaned the cache and then force upgraded using pacman command [2].

  2. I have upgraded the virtual box to 6.1 and installed the extension pack. I have upgraded the manjaro kernel from 5.15 to 5.19.

Since I run on virtual box as mentioned before as opposed to a normal boot, the solutions did not work for me. So I do not know what to do further. Please help.

Normally, this just works™.
Review your (virtual) hardware choices in VirtualBox.
The defaults should be fine.
The video driver is for a virtual card, after all - not a real one.
Perhaps your iso you use for booting is corrupted
or perhaps you need to change the (virtual) video driver to something else.
There are a few choices the names of which I can’t remember right now.

… and, come to think of it:

seems wrong
as the (also virtual) disks in VirtualBox
have names like /dev/vda1 - (not sda1)

I have a shared folder between my computer and Manjaro VBox. May be it is that.

Remove it (temporarily, for the time being) and find out. :wink:
But, in my opinion, this is not it.
… the share would simply fail, perhaps - but not prevent the machine to boot

… and it does boot - from what you said
just not to a graphical login or Desktop Environment

Yes you are right. It still shows sda1 even after removing shared folder.

that suggests you are using a real disk, instead of a virtual one
(which the VM can’t easily see unless you do some explicit configuration)

perhaps review your entire procedure - how you set up your VM and why you chose certain things instead of going with defaults

The screen is stuck showing the following text forever.

/dev/sda1: recovering journal
/dev/sda1: clean, xxxx/yyyy files, xxxxx/yyyyy blocks

Why are you (trying to) boot a VM off of a real, physical disk?

Since my shared folders are also removed, I’m sure I only have virtual disk as shown in snapshot below. I did not do any explicit configuration except that I chose to put my virtual disks in D drive to conserve some space in C drive.

This rings some alarm bells:
C Drive and D Drive are Windows terms.

The filesystem (NTFS, likely) is not suitable to be used for that.

The virtual disk would still not be referred to as /dev/sdax - but /dev/vdax instead.

Not sure what you did and how or why.

Well! I used this setup for almost 16 months now and everything broke all of a sudden (I vaguely remember doing a update.)

Well - that info would have been nice to have had from the start. :wink:

the /dev/sda vs. /dev/vda issue I see is still a mystery to me
apparently you use a real disk device, a partition on a real disk - not a virtual one

I have no clue as of now.

You are right. I have updated my question now.

Updates to Manjaro are about once a month.
Did it finish ok?
Are you indeed fully up to date?

You appear to be running from a real hard drive - instead of a virtual one stored somewhere as a .vdi file.

No one knows about your configuration.

Perhaps if you add info on that someone can help.
I can’t