Boot partition while installation

I want to dual boot with windows and every time i install i break window boot partition.(not sure) but i cant boot to it… it just boot linux install instead

I just wanted to know why its not working, why window boot is breaking everytime… If i fix the window boot after linux installation, it only boot window and i have go to boot menu on startup and choose from there …

and my partitioning is correct or not, i am making some mistake here?


sda           8:0    0 931.5G  0 disk  //#HDD Home and /boot/efi partition is here
├─sda1        8:1    0 627.3G  0 part  // Local Disk D
├─sda2        8:2    0 301.8G  0 part /home  // # Linux Home
└─sda4        8:4    0   518M  0 part /boot/efi // boot efi partiiton

nvme0n1     259:0    0 465.8G  0 disk   // # SSD Disk (Root partition is here)
├─nvme0n1p1 259:1    0  97.7G  0 part / // root of linux
├─nvme0n1p2 259:2    0 367.3G  0 part  // # Main windows install  
└─nvme0n1p3 259:3    0   522M  0 part  // # Window boot partition

Did you re-enable os-prober in the Grub config? (It’s disabled by default.)

This will automatically add entries for other OSes (i.e, Windows in your case) when you run update-grub.


Just tried it does not worked for me, is it because of multiple disk i am using, i can put the efi partition in ssd as well if that fixes the issue…

You ran update-grub after making the changes?

What is the real issue? Is it that you never see a graphical Grub menu, and thus it “boots straight into Manjaro”? Or rather, you a presented with the graphical Grub menu, yet the entry for Windows is missing?

You should put the ESP mounted to /boot/efi and used for Windoof on nvme0n1 or is nvme0n1 parted in msdos instead of gpt? For a clean dual boot all OS must be installed on disks with the same boot mode (BIOS or UEFI).

I dont understand what you are asking about… but Windows is installed on nvme0n1p2 and nvme0n1p3 is windows boot partition using gpt.

How to make sure they are being installed on the same boot mode?

Terms are being conflated. What do you mean by “Windows boot partition”? Do you mean it’s a different EFI system partition (esp) separate from the esp created during installation of Manjaro (which is on sda and not nvme0)?

You talk about going back and forth between “only boots into Windows” or “only boots into Manjaro”.

This is why I asked… :point_down:

Yes this is the issue and if i force choose Windows partition to boot using Boot menu it will boot the manjaro instead

What “Boot menu”? From your motherboard’s BIOS?

I must ask clearly: Do you see a graphical theme’d (green’ish theme) menu of boot entries?


Yes i do see it and it only list Manjaro… Sorry for all the confusion

So when you select from the BIOS boot override “Manjaro (WDC)”, it then takes you to a green-themed Grub menu, maybe with a timeout of 10 seconds? But this menu has no such entry for Windows?

Yes and even if i choose window(BIOS boot override) in it, it will show the green-themed Grub menu with a timeout… and it has no entry for windows

Choosing “Windows (WDC)” boot override, actually presents the green-themed Grub menu, and now this menu has no entries, not even for Manjaro?

It shows the same green-themes grub menu and it list only manjaro, similar to if you have choose Manjaro option in “boot override”

According to your disk / partition layout and your BIOS override screen, it appears you’re using an EFI system partition only on your NVMe, not your SATA SSD.

So how come sda4 is mounted as your EFI partition under /boot/efi?

It’s not even being used…

What should be mounted as /boot/efi is nvme0n1p3. But it looks like you hosed your Windows boot files?

The image i uploaded is actually just an old image, i didnt had any latest image so i used it… but in reality Manjaro comes first in the list then windows in Boot override menu

Doesn’t matter which one is listed above the other.

See my previous post. (If it’s true that the only EFI boot files are located on nvme0 and not sda.)

Show content of /dev/sda4 and /dev/nvme0n1p3. And output of blkid. And maybe fdisk -l /dev/sda /dev/nvme0

/dev/sda4: UUID="77DB-1AE4" TYPE="vfat" PARTLABEL="EFI System Partition" PARTUUID="9d160dd3-8433-40cd-8dd9-339eddc03a67" 
/dev/nvme0n1p3: UUID="4A5E974B5E972F27" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="406ba24d-2c1b-4b5b-be83-aa8f47918424" ```

Then nvme0n1p3 isn’t windows boot partition. Show content of sda4, I guess: ls -R /boot/efi

EDIT: actually mount nvme0n1p3 somewhere and show content of that too.