Boot log shows a failed spacenavd.service

At one point I tried out a space mouse.

During that trial, installing it’s drivers apparently set up a daemon to start at boot.

I not longer own the mouse and I uninstalled (I thought) everything to do with it.

But, today I noted during boot that a service for it was failing to start.

Checking the log I see:

systemd[1]: spacenavd.service: Control process exited, code=exited, status=203/EXEC
systemd[1]: spacenavd.service: Failed with result 'exit-code'.

Not sure where this is happening…so don’t know to start looking.

Operating System: Manjaro Linux
KDE Plasma Version: 6.0.5
KDE Frameworks Version: 6.2.0
Qt Version: 6.7.1
Kernel Version: 6.6.32-1-MANJARO (64-bit)
Graphics Platform: X11
Processors: 6 × AMD FX™-6350 Six-Core Processor
Memory: 15.5 GiB of RAM
Graphics Processor: NVIDIA GeForce RTX 3060/PCIe/SSE2

systemctl spacenavd

May provide more information. Add “–user” if it’s a user service rather than a system service.

Thanks for the reply.

I did some more searching and found the systemctl command.

did a status, found the offending spacenav and disabled it.

Seems to have fixed it.

I recommend reading up on systemctl. It’s fundamental to understanding your entire Manjaro system.

…which is why some dislike it, in principle; I too am on-the-fence to an extent.
I suppose, ultimately, resistance is futile… :vulcan_salute:

I really hated it when it first landed, not helped by the fact that it was probably rolled out by distros before it was really ready and while it still had a lot of irritating/nasty bugs. (Though Poettering seemed to think they were features).

Since I’ve got used to it and learned my way around it I’ve come to really like it - it provides much better job control than the old init system (even simple things like if you try to start something that’s already running it’s intelligent enough to not duplicate the process). And although setting up a timer is more involved than using a cron job, again the advantages outweigh the disadvantages (and it’s pretty simple to use an existing timer unit as a template for another).

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.