Boot from USB 3.0 drive

Hey there!

I want to revive an old Laptop and I am really excited about Manjaro XFCE. I succesfully installed it on a quite fast USB3.0 drive (BIOS Legacy Installation), but when I tried to boot from it, I figured out that for some reason my Laptop does not support its USB3.0 port during BIOS/Boot phase. The drive does not show up in BIOS, and there is no options in there regarding USB. I can boot Manjaro when I plug it into an USB 2.0 port though.

What I have tried:

  • Running sudo update-grub on my HDD installation of Ubuntu, so that it recognizes Manjaro on the USB stick. It adds an entry, but Grub is unable to boot if I select the entry, not finding the drive. The “ls” command in grubs command line only shows me the hard drive.

  • Maybe a bit stupid: Plugging the drive from USB2.0 to 3.0 when Manjaro is fully started, hoping that it would just run from RAM enough to recognize its file system was only offline temporarily. Obviously, it did not work.

What do you think? Is there a solution how I can use Manjaro from USB3.0? I wonder if there is a way to feed grub the necessary drivers, or even let it boot a kernel on my hard drive that then continues to boot from my USB3.0 drive. I would also be okay with a quick and dirty solution that allows me to unplug and replug the drive without Manjaro crashing.


Why don’t you just use an internal disk for manjaro to save you all the hassle?
If the BIOS won’t let you boot from USB3 ports, then you could try using 2 drives: one on USB2 with the boot(efi) partition and the USB3 one with the root filesystem (and possibly other partitions you want to use).
Seems quite clunky, but should work just fine.

USB controllers only works with the version they were designed for - and USB devices are - mostly - backwards-compatible in the sense you read an USB3 device using USB2 controller.

If the laptop in question does not have an USB3 controller then it doesn’t matter - the system will never be able to utilize the faster transfer rates of USB3.

And yes - there has been cases where a system cannot boot from USB3 device - I think there was a comment on one of my topics on bootable USB mentioning this rare issue.