Boot from encrypted external SSD

Hi. I installed manjaro with encryption option enabled on my internal ssd (the whole drive is encrypted).
It works ok and system can be loaded with no issues.
Now I need this drive to be used as external through USB 3 to sata adapter.
The drive is detected by bios, I can enter master key on the first screen and then select grub menu with my system.
After that the boot process fails with error, that it cannot find partition with root UUID and enters into rootfs.
UPD: I tried to find the right UUID, ls /dev/disk/by-uuid gives no results in rootfs.
Why it fails at this step and cannot see device? Is it possible to make it work somehow? Thanks

You have the following problem:
the UUID of all partitions contained on the external SSDs are wrong.

How to get the right one?
in rootfs

ls /dev/disk/by-uuid

gives me no results at all

Are you sure your firmware supports booting that way?

Well, I can boot from another live usb flash, then it’s supported, isn’t it?

I mean

USB stick is not SATA through sata to USB adapter.

I tried to install encrypted manjaro on another SSD drive using sata to USB adapter and… it’s working.
Probably some setting is missing in my original SSD install: grub configuration or smt else
If I don’t find a solution, I guess I will have to port my existing system to new drive in order to use it as external. At least I know it can be booted in that way
cc: @Wollie @Keruskerfuerst

1 Like

Ended up with reinstalling system on external SSD

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.