Boot fail after latest update, '/new_root: can't find UUID...'

Similar to these instances:

I suspected this is possibly linked to the bug: but according the the version of the kernel, it should be fixed already, but the problem persists.

I have 3 installation of linux, Manjaro KDE, Manjaro XFCE and Garuda KDE, all of which stopped booting after their respective latest update, and I tried to switch to 5.15LTS kernel, it still fails after reboot.

I tried fresh install of Manjaro XFCE, system boots up fine after install, but no longer works after system update. Tried both 6.x kernel and 5.15 LTS, same problem.

I guess this has something to do with my practice of running linux via USB drives. For now I see no way of resolving this but to keep running the system without updates

it looks like this issue:

downgrading or not udpating (blacklisting from update) mkinitcpio helps

ahh this makes a lot more sense, i think this is what’s going on. I guess i’ll just withhold the updates for a while until it’s fixed. It’ll be a hassle to confirm the issue was fixed tho