Boot error vmlinuz-5.4 not found


I stopped an update yesterday and now my laptop won’t boot, it only shows a black screen with the message:

error: file '/boot/vmlinuz-5.4-x86_64' not found. error: you need to load the kernel first.

I have some very important files in the laptop, is there anyway to recover them?

Welcome at the forum, @Hueich

NEVER stop an ongoing update - you see what’s happening. Try to boot into a Manjaro LIVE ISO, chroot into your system by

sudo manjaro-chroot -a

and re-try to update from there, report any errors.

Sorry to hear that, but its a bit expected.

If you cant boot in any way from the currently installed system you still may be able to access and fix it using a guide like this:

(the long and short of which is in @Wollie’s preceding response :wink:)

Feel free to report back once you are able to interact with it and we may be able to help you recover.

i added

after chroot , check and give return

sudo manjaro-chroot -a
mhwd-kernel -li
mhwd -li
ls /etc/mkinitcpio.d/*.preset

Hi, here are what I got:

[manjaro /]# mhwd-kernel -li
Currently running: 5.9.11-3-MANJARO (linux59)
The following kernels are installed in your system:
error: could not open file /var/lib/pacman/local/libreoffice-still-6.4.7-7/desc: No such file or directory
   * linux54
error: could not open file /var/lib/pacman/local/libreoffice-still-6.4.7-7/desc: No such file or directory
[manjaro /]# mhwd -li
> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2018.05.04                true            PCI

Warning: No installed USB configs!
[manjaro /]# ls etcmkinitcpio.d*.preset
ls: cannot access 'etcmkinitcpio.d*.preset': No such file or directory

I can`t update the system too.

What messages do you get if you execute

sudo pacman-mirrors -f && sudo pacman -Syyu

I just solved it using chroot and updating the system.
Thanks for the help and Happy New Year to y’all :slight_smile:

1 Like

Worked for me after I installed linux 54 and linux 510 packages as well. Either one of them would also have done the job as of June 17th 2021.

sudo pacman-mirrors -f && sudo pacman -Syyu linux54 linux510

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.