Boot error: no filesystem type specified

Can’t boot Manjaro KDE after power outage.
The only message is:

mount: /new_root: no filesystem type specified
You are now being dropped into an emergency shell.
sh: can’t access tty; job control turned off
[rootfs ]#

Possible just a filesystem error. Boot a Manjaro Installation Disk and check your drive.

you mean to check my drive with fsck?
Sorry my knowledge is somewhat limited here

my drive is encrypted with luks, so I run

$ sudo su
$ cryptsetup liksOpen [luks device] crypto

already tried with fsck several times:

$ fsck /dev/mapper/crypto
fsck from util-linux 2.38.1
e2fsck 1.46.5 (30-dec-2021)
/dev/mapper/crypto: clean, 1093259/14581760 files, 37987444/58316649 blocks

Booting from a manjaro live media

Update your system and reinstall kernels. If same happens, try decrypting it in emergency shell.

It seems that updating the kernel fixed my problem

Via chroot, installing latest kernel release

mhwd-kernel -i linux61

this gave me some errors

(4/7) Updating linux initcpios…
install: cannot stat ‘/dev/stdin’: No such file or directory
error: command failed to execute correctly
(5/7) Updating Kernel initcpios for Nvidia-DRM…
(6/7) Refreshing PackageKit…
Error connecting: Could not connect: No such file or directory
error: command failed to execute correctly
(7/7) Updating Grub-Bootmenu
/usr/bin/grub-probe: error: cannot find a device for / (is /dev mounted?).
error: command failed to execute correctly

besides that, listing installed kernels shows that linux61 is installed:

$ mhwd-kernel -li
Currently running: 5.15.60-1-MANJARO (linux515)
The following kernels are installed in your system:
* linux419
* linux515
* linux519
* linux60
* linux61

Now running on 6.1.0rc4-1

thanks for helping me guys :slight_smile:

I would uninstall kernel 5.19 and 4.19.

what about 5.15?

I would keep kernels 5.15, 6.0, 6.1.