Boot entries gone after last update


After last update, all other GRUB entries except Manjaro has gone (Win10, Mint, Zorin). I did update-grub, but that didn’t help and I got this instead:

Why is that so and how can I get back my previous boot entries?


If you need dual-boot you can reactivate os-prober the easiest with the following command combination in a terminal:

echo GRUB_DISABLE_OS_PROBER=false | sudo tee -a /etc/default/grub && sudo update-grub


Thank you, I’ll check the solution, but may question still remains - why it has been deactivated? Who asked to do this?
If I have multiple boot system, why the update has to ruin this?


If you read the announcements thread you’ll see it was the grub developers themselves that did it upstream not manjaro. It was done to fix a vulnerability in grub I believe and will eventually reach all distros as its come from upstream

Do they understand, that this can create a lot frustration to many users? Was that so necessary ?

That worked, thanks.


Their program, their rules.

Glad I found this. WTF grub devs :man_facepalming: this is as bad when win10 nuke and paves EFI entry on update. Well, almost.

Thanks for the fix @chomsky

You probably missed this message during the update process

warning: /etc/default/grub installed as /etc/default/grub.pacnew

Changes to /etc/default/grub would not overwrite your configuration for GRUB because that could cause worse boot problems than the loss of one OS

checking the .pacnew file against the grub.pacnew (pacdiff or meld) would show this change for user to merge with their GRUB

# Uncomment this option to enable os-prober execution in the grub-mkconfig command

Pacman created grub.pacnew, but I haven't edited that file

System Maintenance - Manjaro Wiki

1 Like

Manjaro is one of the most popular distros right now, BECAUSE it doesn’t (or I should say “didn’t”) get in peoples way. But your updates have broken my installations very badly SEVERAL TIMES over the last few months. Most people would have switched distros already, but I am patient and willing (AND ABLE) to go deep into my system to repair it - much more than most people, I suppose. But even I am about to jump ship by now.

I bet you have already lost 10-20% of your users recently and if you keep f***ing up your updates that badly, manjaro will soon be the next distro that fades into oblivion.


And don’t tell me that grub forced this on you. You could have put that in your default cfg. Distros should aim for consistency.
Breaking your users computers on purpose would get you fired (and probably sued) from any software-company. A change like that has to be opt-in, not opt-out!

1 Like

Me to had to do the work around command. Now all is back to normal. Now will I need to repeat this step after each new UPDATE?


No…one time business

1 Like

Great Thanks

Thank you!!!

Now if the Distro Ghods would think about how most people use this, it would not have been a problem. It’s something that needs to be either more explicit, or set to the former default behaviour.

As said before:

Well, upstream decided to change the default from enabled to disabled. I only helped to make it proper. However, by all the emails I and other support members got lately, it simply shows that almost noone is interested in the reasons behind developer decisions and how the whole Linux community addresses security issues regaring grub bootloader:

So please all, stop whining and consider to start reading …