Boot after update fails

After doing an update today, a reboot was prompted. Upon reboot the system did not boot.

I did a power cycle and got to the bios boot menu. it offered Manjaro, and UEFI in the order.

I selected Manjaro and it booted as normal.

After shutdown, it would still not boot without selecting from the bios boot menu.

Entering bios and changing the boot order to UEFI, Manjaro it boots normally.

I guess that’s good. But, Why did the update change this?

1 Like

Same here. Black screen for me.

same here, Manjaro Kde.
Bios boot menu offers Uefi OS and Manjaro, but none works!
Black screen and no console!

Same here, noticed a stop job took very long (45 sec) to complete before rebooting into Grub (which is normally hidden in my config), I think this update messed with grub config file.

Update: Systems hangs after update on Plymouth boot screen removing quiet splash from boot params fixed the issue

I just noticed that it cleaned my task bar of all the things I had pinned…

It works! Thanks

I made a guide based on one of my many old posts walking someone through removing plymouth
(because despite providing virtually nothing of any benefit, let alone quality, it always created random problems)
And it looks like we will need it :sweat_smile:


I will have a look at this in the morning.

I tested boot again on the machine in question and it will only boot from the bios boot menu. (I.e. hitting a function key after power to get to the menu.) If I simply power the machine on I get black screen and eventually the disk activity stops. So, in this case, I don’t even get to grub, so ‘e’ I don’t think I can even get to grub. Maybe this is discussed in the link.

I suspect the other machine I run Manjaro on survived because, there, grub is managed by the Debian install on the same machine.

Its probably just hidden. You are using grub to boot even if you dont see it.

You can also edit the files from the desktop, tty, chroot, etc.

Editing from grub on-the-fly with e would only affect that single boot anyways.

I have had this same issue recently, and I do not believe it is an Archlinux only issue, Debian 12 and Mint also have been dealing with this as well. It seems that reinstalling Grub, seems to fix it for me.

sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi/ --bootloader-id=GRUB

Then update grub
sudo update-grub

And just to be sure,
sudo mkinitcpio -P

Not saying it will, but…

If it is then it would be good to know.

Maybe worth mentioning the install-grub script that should automate this.
Both as in ‘sudo install-grub should figure out the long string you need’ and ‘the package provides a hook that fires when needed like after updates to the grub libraries’.

On my system, the issue was plymouth. It was a versioning issue. Pacman was reporting that the installed version was newer than the extra version in the update, so it wouldn’t install the update version.

The solution was to first remove all plymouth themes, then plymouth, and then to reinstall plymouth and the themes.

There has been a lot of changes in Plymouth from 22.x to 24.x many of them for the better.

That does mean that manual intervention is needed for your existing configuration to work with Plymouth 24.x

The newer Plymouth 24 package was replaced fairly quickly on stable branch with the previous 22 package but some has run into issues nonetheless