Boost.Python error on job "postcfg"

Hi

I’ve been trying to install Manjaro for hours now, to no avail. I keep getting this error. I’m trying to install on a Gigabyte Aero15x v8 with 2 M2 SDDs. One drive has Windows 10, the other has had Ubuntu for the past year now. Now I’m trying to install Manjaro on the drive Ubuntu was on.

System:    Host: manjaro Kernel: 5.6.15-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC driver=free nouveau.modeset=1 
           i915.modeset=1 radeon.modeset=1 misobasedir=manjaro misolabel=MANJARO_KDE_2003 quiet systemd.show_status=1 
           apparmor=1 security=apparmor 
           Desktop: KDE Plasma 5.18.5 Distro: Manjaro Linux 
Machine:   Type: Laptop System: GIGABYTE product: AERO 15XV8 v: N/A serial: <filter> 
           Mobo: GIGABYTE model: AERO 15XV8 serial: <filter> UEFI: American Megatrends v: FB08 date: 09/14/2018 
Battery:   ID-1: BAT1 charge: 94.2 Wh condition: 94.2/94.2 Wh (100%) model: GIGABYTE Aero 15 status: Full 
CPU:       Topology: 6-Core model: Intel Core i7-8750H bits: 64 type: MT MCP arch: Kaby Lake family: 6 model-id: 9E (158) 
           stepping: A (10) microcode: CA L2 cache: 9216 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 52815 
           Speed: 801 MHz min/max: 800/4100 MHz Core speeds (MHz): 1: 800 2: 801 3: 800 4: 800 5: 800 6: 800 7: 800 8: 800 
           9: 800 10: 800 11: 800 12: 802 
           Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel UHD Graphics 630 vendor: Gigabyte driver: i915 v: kernel bus ID: 00:02.0 
           Device-2: NVIDIA GP104M [GeForce GTX 1070 Mobile] vendor: Gigabyte driver: nouveau v: kernel bus ID: 01:00.0 
           Display: x11 server: X.Org 1.20.8 driver: intel,nouveau unloaded: modesetting 
           resolution: 1920x1080~144Hz, 2560x1080~60Hz 
           OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 20.0.7 direct render: Yes 
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: Gigabyte driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           Device-2: NVIDIA GP104 High Definition Audio driver: snd_hda_intel v: kernel bus ID: 01:00.1 
           Sound Server: ALSA v: k5.6.15-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Gigabyte driver: r8169 v: kernel 
           port: 3000 bus ID: 02:00.0 
           IF: enp2s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
           Device-2: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel port: 3000 bus ID: 03:00.0 
           IF: wlp3s0 state: down mac: <filter> 
Drives:    Local Storage: total: 484.30 GiB used: 7.06 GiB (1.5%) 
           ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 EVO 1TB size: 931.51 GiB block size: physical: 512 B 
           logical: 512 B 
           ID-2: /dev/nvme1n1 vendor: Transcend model: TS512GMTE510T size: 476.94 GiB block size: physical: 512 B 
           logical: 512 B 
           ID-3: /dev/sdb type: USB vendor: Transcend model: JetFlash Transcend 8GB size: 7.36 GiB block size: physical: 512 B 
           logical: 512 B 
Partition: ID-1: / raw size: N/A size: 11.63 GiB used: 169.4 MiB (1.4%) fs: overlay source: ERR-102 
Sensors:   System Temperatures: cpu: 44.0 C mobo: N/A gpu: nouveau temp: 47 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 273 Uptime: 13m Memory: 15.50 GiB used: 2.46 GiB (15.9%) Init: systemd Compilers: gcc: 10.1.0 
           Shell: bash v: 5.0.17 inxi: 3.0.37 

So far I’ve tried:

  • Using both free and nonfree driver
  • Using different USB and redownloading ISO
  • Manually partitioning with 512MB and 2GB /boot/efi
  • Not using swap partition
  • Wipe the drive completely with Gparted
  • Wiped something from Ubuntu boot from EUFI partition via diskpart in Windows (was a bit lost at this point, not too sure)

I can still see a boot option for Ubuntu, and there is a boot option for “EUFI OS” now. When installing without using a swap partition, the installation actually succeeded, but booting just give me a list of failed to start errors (forgot to snap a picture). I have not been able to reproduce this. I have googled and found many post with nearly the same error, but not with postcfg. The other few times the installation ‘succeeded’, I got error messages when booting into grub related to the manjaro grub theme and then nothing.

I really don’t know what to do anymore, but I want to run Manjaro. I hope someone knows a solution. Let me know if I haven’t given enough information. Thanks in advance!

how have you create USB iso ?

Using Rufus on my Windows 10 install.

use ventoy to prepare USB
then copy drag iso on USB

I didn’t even think to use another way of flashing the USB. Will try that when I get back home later. Thanks!

I tried with Ventoy (nice tool). According to the installer, it successfully i stalled, but I get the grub with manjaro themes error and then this when I try to boot Manjaro: http://imgur.com/gallery/1zOJztl.

try with another USB stick

I tried with 3 different ones so far, still nothing.

Thank you for the help, but I couldn’t find a feasible solution. I backed everything up from my windows install and wiped both drives. I now have Manjaro and Windows running next to eachother. Cheers!