Boost.Python error in job "networkcfg"

Hi there,

First timer with Manjaro Linux and installing a full KDE stable system from a USB stick. Using the graphical installer and the live system boots fine, I got wifi and typing this from Firefox in the live system. However, when trying to install with Pahvo 21.1.4 I get this weird error before the very end of installation:

Boost.Python error in job "networkcfg"

I’d like to provide a screenshot of the full error message but apparently I can’t embed media items or links in my posts!!?

I found one other post here (#84312) about the same error but no solution. Apart from this error the live system works just fine and I’m loving the Manjaro experience so far. Can anybody help?

Thanks :smiley:

Same problem here

Hello @zbinkz :wink:

Please avoid to post screenshots of text, when pasting terminal output, add three backticks ` OR 3 tilde ~ above and below the text:

text

Thanks


About the error (I hope it is exactly the same):

It must be this line: https://gitlab.manjaro.org/applications/calamares/-/blob/development/src/modules/networkcfg/main.py#L126 and the variable is not defined.

While target_nm and source_nm are defined, the variable network is not, and therefore it troughs this error. I am not a dev of calamares, but it seems to be a bug here…

Can you check this folder:
(run this on the terminal)

LANG=C ls -lah /etc/NetworkManager/system-connections/

on the live session and on the local installation?

Please post the result like described above.

Thanks.

[manjaro@manjaro ~]$ sudo LANG=C ls -lah /etc/NetworkManager/system-connections/
total 4.0K
drwx------ 1 root root  60 Sep 27 11:21 .
drwxr-xr-x 1 root root  60 Sep 25 10:39 ..
-rw------- 1 root root 372 Sep 27 11:21 pavucina_2GHz.nmconnection
[manjaro@manjaro ~]$ 

Hi @megavolt,

Thanks for the clarifications. The error you describe is exactly the same as mine. Here is the output requested (with sudo prepended to the command):

[manjaro@manjaro ~]$ sudo LANG=C ls -lah /etc/NetworkManager/system-connections/
total 4.0K
drwx------ 1 root root  60 Sep 26 23:03 .
drwxr-xr-x 1 root root  60 Sep 25 04:39 ..
-rw------- 1 root root 354 Sep 26 23:03 BELL717.nmconnection
[manjaro@manjaro ~]$ 

It’s the same as @Muskwa, exception made of our respective network SSIDs.

Cheers

The solution for now is to conduct the installation offline ─ i.e. to disable WiFi. The issue will be fixed some time later tonight (Central European Summer Time).

3 Likes

The solution for now is to conduct the installation offline ─ i.e. to disable WiFi. The issue will be fixed some time later tonight (Central European Summer Time).

Thanks @Aragorn, did just that from a fresh reboot (you’ll run into the same calamares bug if you don’t reboot into a fresh installation) and now have a fully functional Manjaro installation :+1:

I’ll wait till the bug fix before picking this turnaround as the solution, which it would be if the problem is confirmed to be exclusively from calamares.

1 Like

This is just asenine though. This installer should’ve been tested multiple times on multiple computers before being shipped out on a public ISO. Now I’m stuck with an unbootable PC cause someone just lazily shipped this broken. Whoever did it should be kicked off the team immediately.

This would be a class action lawsuit if this happened on Windows or Mac. Please Manjaro devs, try harder. Manjaro is a major player in the Linux world, newcomers use your distro as a first impression of Linux, so far this isn’t a good first impression.

Thanks for the detailed post. I was able to use that workaround.

1 Like

I have the same error as reported above, but workaround does not work for me, unfortunately. I tried first just disconnecting from wifi network, than plane mode, than disabled wifi - the Boost.Python... error keeps popping up anyway.

Looking forward to your fix, good people, my wife waits for her new laptop :slight_smile:

EDIT: After typing that, I realized that I should probably restart the live session without enabling the wifi even once - this way it worked.
Thank you all!

1 Like

I have also same problem, but I turn off the wifi from beginning and it’s worked thanks dude :+1::+1: btw I was trying from morning :frowning:

1 Like

Oh please, drama much? I’m sure you never ever make any mistakes, right?

Be sure to ask for your money back at the cash register. :roll_eyes:


Anyway, the issue has by now been remedied. The faulty .iso has been replaced on the server this morning (Central European Summer Time).

I’m closing this thread. If there are any new problems, just start a new thread.

2 Likes