BOINC Manager GUI does not work

I just installed 20.2 Manjaro Gnome. The GUI does not work. boinc.service is missing as well.

/ >>> boincmgr                                                              [1]
06:46:32: Warning: Mismatch between the program and library build versions detected.
The library used 3.0 (wchar_t,compiler with C++ ABI 1013,wx containers,compatible with 2.8),
and your program used 3.0 (wchar_t,compiler with C++ ABI 1014,wx containers,compatible with 2.8).

Well, I would include a screen shot here but someone has stopped us from using things that would actually help.

I run boinc on quite a few machines having used many distros over the years. It appears the packaging still isn’t quite right in the ARCH family of distros.

What do you mean? Does the GUI not appear at all, or is something not functional when using it?

Note: In boinc 7.10.3-1, the unit was renamed from boinc.service to boinc-client.service .

BOINC - ArchWiki

GUI died with said error.

I chucked the Gnome edition and installed KDE.

Life is slightly better. Thank you for pointing out the name change. The vast majority of documentation one finds with searches doesn’t point that out.

The manual tweaks of:
cd /var/lib/boinc
sudo chmod 640 gui_rpc_auth.cfg
sudo chmod o+r gui_rpc_auth.cfg

are still necessary. I’ve not done any pacman packaging, but in Debian and RPM that is a simple postinst step.

Boinc Manager now has this bug.
BOINC manager not listing projects
bbs dot archlinux dot org/viewtopic.php?id=259383
Package version 7.16.11-1 fixed the issue.

According to About we are 7.16.11 sans the -1
I have this same bug.

I have the similar problems and downgrade, configuration and upgrade, resolve it :slight_smile:
sudo DOWNGRADE_FROM_ALA=1 downgrade boinc
and I chose version 7.16.10 after installation:
sudo systemctl start boinc-client.service
sudo systemctl enable boinc-client.service
Restart computer.
Switch on Boinc Manager, cancel adding “.” project, switch Boinc Manager off and switch on again after few seconds to push it to work :slight_smile:
Setup Boinc Manager configuration (connect to BAM) and change some settings.
Upgrade Boinc to newest version, reboot and now it’s working normal :smile:


I have almost everything working the “approved way.” Need to log yet another BOINC issue though.

To start Boinc Manager with system (in the way to remember all settings) I copy desktop file to folder prepared for boinc flies and wrote small script to start Boinc Manager (starting boincmgr from consol or startup programs don’t remember settings).
My desktop file - boinc.desktop :

[Desktop Entry]
Name=BOINC Manager
GenericName=BOINC monitor and control utility
GenericName[pl]=Monitorowanie i ustawianie BOINC
Comment=Configure or monitor a BOINC core client
Comment[pl]=Monitoruj i ustaw klienta BOINC

My starting script (make sure to add x in chmod - run opption) :

cd /home/marcin/boinc
#sleep 60
gtk-launch boinc.desktop

I added to starting programs in Manjaro Setting centre two new entry:

  1. Boinc service with delay 10s and command
    sudo systemctl start boinc-client.service
  2. Boinc Manager Startup with delay 70s and command

After that Boinc Managers should start each time with user login (boot of system if You have autologin) remembering all settings. Hope to help You little bit :slight_smile:

Moderator edit: Formatting

Oh, thanks for the reply.

I thought I posted back here. I have it working now. Manjaro inherited an Arch bug which is why the GUI wouldn’t start. I found the version where Arch fixed it and posted in here on some BOINC message thread. A few days later someone must have pulled in the update. The GUI started working. The half added project appeared in the GUI as “added by URL” where I could finally delete it.

Thanks for trying to help though!

Hi there, new to Manjaro here (familiar with debian and derivatives)
I seem to be having problems with Boinc,

i can get the boincmgr to run but everything is greyed out… with the occasional error about gui_rpc_auth.cfg

when i go to /var/lib/boinc i just find an empty directory.
if i try and start the boinc client with systemctl i get the error Failed to start boinc_client.service: Unit boinc_client.service not found.

not quite sure where to go from here?

[edit] Update, maneged to fix it after some digging and removing config files, re-installing and restarting the service , all working now [/edit]