Blur/Transparency not working on kde plasma

Hello guys, i’m quite new around here, so please, forgive me if I fail to provide all the needed information.

the blur effects are not working on my kde plasma, i’ve searched about it and all the issues get solved by turning on the compositor or changing to opengl3.

But even though my compositor is already on and i am in opengl3 (I think at least), this feature doesn’t work.
I also have tried to manually set blur via systemsettings but no results.

this is my ininxi -Faz output

  Kernel: 5.15.65-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=78bf7dea-97b8-41b6-91bb-e9bbac614e13 rw nouveau.modeset=0
  Desktop: KDE Plasma v: 5.25.5 tk: Qt v: 5.15.5 wm: kwin_x11 vt: 1
    dm: SDDM Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: Dell product: Inspiron 5590 v: N/A
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: Dell model: 0XRXN9 v: A04 serial: <superuser required> UEFI: Dell
    v: 1.20.0 date: 07/08/2022
  ID-1: BAT0 charge: 30.6 Wh (100.0%) condition: 30.6/42.0 Wh (72.9%)
    volts: 12.5 min: 11.4 model: SMP DELL VM73297 type: Li-poly
    serial: <filter> status: full
  Info: model: Intel Core i7-10510U bits: 64 type: MT MCP
    arch: Comet/Whiskey Lake note: check gen: core 10 level: v3 built: 2018
    process: Intel 14nm family: 6 model-id: 0x8E (142) stepping: 0xC (12)
    microcode: 0xF0
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 8 MiB desc: 1x8 MiB
  Speed (MHz): avg: 824 high: 900 min/max: 400/4900 scaling:
    driver: intel_pstate governor: powersave cores: 1: 800 2: 800 3: 800 4: 800
    5: 800 6: 800 7: 893 8: 900 bogomips: 36812
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: retbleed mitigation: Enhanced IBRS
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 status: Vulnerable: eIBRS with unprivileged eBPF
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel CometLake-U GT2 [UHD Graphics] vendor: Dell driver: i915
    v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20 ports:
    active: HDMI-A-1,eDP-1 empty: DP-1,HDMI-A-2 bus-ID: 00:02.0
    chip-ID: 8086:9b41 class-ID: 0300
  Device-2: NVIDIA GP108M [GeForce MX250] vendor: Dell driver: nvidia
    v: 515.65.01 alternate: nouveau,nvidia_drm non-free: 515.xx+ status: current
    (as of 2022-08) arch: Pascal code: GP10x process: TSMC 16nm
    built: 2016-21 pcie: gen: 1 speed: 2.5 GT/s lanes: 4 link-max: gen: 3
    speed: 8 GT/s bus-ID: 01:00.0 chip-ID: 10de:1d13 class-ID: 0302
  Device-3: Realtek Integrated_Webcam_HD type: USB driver: uvcvideo
    bus-ID: 1-6:7 chip-ID: 0bda:565a class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.4 compositor: kwin_x11 driver: X:
    loaded: modesetting,nvidia alternate: fbdev,nouveau,nv,vesa gpu: i915
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3288x1080 s-dpi: 96 s-size: 867x285mm (34.13x11.22")
    s-diag: 913mm (35.93")
  Monitor-1: HDMI-A-1 mapped: HDMI-1 pos: primary,top-left
    model: Samsung F27G3xTF serial: <filter> built: 2021 res: 1920x1080 dpi: 81
    gamma: 1.2 size: 600x330mm (23.62x12.99") diag: 685mm (27") ratio: 16:9
    modes: max: 1920x1080 min: 720x400
  Monitor-2: eDP-1 pos: bottom-r model: LG Display 0x05f2 built: 2018
    res: 1368x768 hz: 60 dpi: 101 gamma: 1.2 size: 344x194mm (13.54x7.64")
    diag: 395mm (15.5") ratio: 16:9 modes: 1920x1080
  OpenGL: renderer: Mesa Intel UHD Graphics (CML GT2) v: 4.6 Mesa 22.1.7
    direct render: Yes
  Device-1: Intel Comet Lake PCH-LP cAVS vendor: Dell
    driver: sof-audio-pci-intel-cnl
    alternate: snd_hda_intel,snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 1-3:3
    bus-ID: 00:1f.3 chip-ID: 1b1c:0a51 chip-ID: 8086:02c8 class-ID: 0300
    class-ID: 0401
  Device-2: Corsair VOID ELITE Wireless Gaming Dongle type: USB
    driver: hid-generic,snd-usb-audio,usbhid
  Sound Server-1: ALSA v: k5.15.65-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 16.1 running: yes
  Sound Server-4: PipeWire v: 0.3.57 running: yes
  Device-1: Intel Comet Lake PCH-LP CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:02f0 class-ID: 0280
  IF: wlp0s20f3 state: up mac: <filter>
  Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB
    driver: btusb v: 0.8 bus-ID: 1-10:8 chip-ID: 8087:0aaa class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends
  Local Storage: total: 238.47 GiB used: 89.94 GiB (37.7%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SSSTC model: CL1-3D256-Q11 NVMe
    SSSTC 256GB size: 238.47 GiB block-size: physical: 512 B logical: 512 B
    speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 22301116
    temp: 30.9 C scheme: GPT
  ID-1: / raw-size: 238.17 GiB size: 233.38 GiB (97.99%) used: 89.94 GiB
    (38.5%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 312 KiB
    (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  Alert: No swap data was found.
  System Temperatures: cpu: 50.0 C pch: 46.0 C mobo: N/A
  Fan Speeds (RPM): cpu: 0
  Processes: 266 Uptime: 24m wakeups: 1 Memory: 15.41 GiB used: 3.37 GiB
  (21.9%) Init: systemd v: 251 default: graphical tool: systemctl
  Compilers: gcc: 12.2.0 clang: 14.0.6 Packages: 1519 pm: pacman pkgs: 1513
  libs: 433 tools: pamac,yay pm: flatpak pkgs: 6 Shell: Zsh v: 5.9
  running-in: konsole inxi: 3.3.21

I would appreciate if you guys could help me, thanks in advance

you mean blur the kwin script blur is not working, or the blur option, in system settings/desktop effects?
the blur kwin doesnt work for everyone …
and the blur desktop effect works only on the panel/sys tray/application launcher

the blur option works, I can change the options on it, but the effects aren’t applied to settings/desktop effects not even on application launcher or panels.

and this is with blur up to the max value

go to system settings/compositor and check if its enabled on startup
in desktop effects disable ‘backround contrast’
right click on panel, enter edit mode and under more options select translucent
blur setting to max disables blur, you need to set it to light for example at the 3 line next to light

the compositor was already on and background constrast was turned off as weel.

I changed the blur settings and also set panel to translucent, but had no effect

Before the translucent option set (it was adaptive)

After the change

and this:


I think i see some progress.

my application launcher now is blurred, but not dolphin, konsole and panel is it normal?

if you want konsole blurred, you can enable it in konsoles settings …
and yes its normal that only the panel(if it supports blur), application launcher, system tray are blurred …
if you want everyhting blured, you need to install kvantum and enable it there, but i dont use it, cant help you with that …
in system settings/plasma style download this panel: winsur-dark thats what im using right now, and it has transparent panel, so test with it

I tried this winsur-dark, but blur didn’t work either, I didn’t know that kvantum, i’ll try that one, thank you very much for your time and your help

so there is something wrong… create a new user, log out, log in with the new user and test if the blur works there correctly

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.