Bluetooth Won't Found a Device After Fresh Installation (Toshiba Satellite C55D-C5271)

Hello, I am new to Manjaro Linux. After I dual boot my Manjaro Linux with my existing Windows (I am using Toshiba Satellite C55D-C5271), my Wi-FI was working properly but not my Bluetooth. I can enable the Bluetooth from the default Bluetooth manager (I am using KDE Manjaro Linux 64bit, not the minimal version). But, the Bluetooth won’t find any devices. It just keep scanning.

I did some research regarding on this issue. One year ago, I dual boot Linux Mint with my existing Windows in this laptop. I face the same problem. So, for this problem, I follow the same instructions.

I install the driver from GitHub - lwfinger/rtl8723au_bt: Bluetooth driver for RTL8723AE and RTL8723AU (my laptop actually using RTL8723BE, but I guess there is some similarity on the driver, because I cannot find the RTL8723BE bluetooth driver). I followed the instructions on the ‘kernel’ branch (it just tells to do ‘make’ and ‘make install’, and also do ‘modprobe’) and also suggestion from Tweaks for Toshiba Satellite L15W-B (Radius) · Issue #40 · lwfinger/rtl8723au_bt · GitHub to add one line for my vendor ID. I followed that, but the Bluetooth still cannot find a nearby device. I did change my kernel version, but still no luck. I also switch off my Bluetooth in my Windows 10, and rebooted again to Manjaro Linux, still no luck.

I also asked the owner of that repo (lwfinger). He answered my questions, but he cannot help with debugging (Does the driver support Linux Kernel 5.4 (LTS) ? · Issue #74 · lwfinger/rtl8723au_bt · GitHub). Hence, I cannot use Bluetooth until now.

Currently, I am using:
Kernel: 5.4.108-1-MANJARO
OS: Manjaro Linux x86_64
Laptop: Toshiba Satellite C55D-C5271
Contains radio device RTL8723BE
Contains FCC ID: TX2-RTL8723BE

Here is my inxi -Fxi result,

System:    Host: manjarosatellite Kernel: 5.4.108-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 Desktop: KDE Plasma 5.21.3 
           Distro: Manjaro Linux base: Arch Linux 
Machine:   Type: Laptop System: TOSHIBA product: Satellite C55D-C v: PSCQEU-01H018B serial: <superuser required> 
           Mobo: FF50 model: 06F7 serial: <superuser required> UEFI: Insyde v: 5.10 date: 07/27/2015 
Battery:   ID-1: BAT1 charge: 25.5 Wh (95.5%) condition: 26.7/31.7 Wh (84.3%) volts: 16.4 min: 14.4 
           model: Panasonic PA5185U-1BRS status: Charging 
CPU:       Info: Quad Core model: AMD A4-7210 APU with AMD Radeon R3 Graphics bits: 64 type: MCP arch: Puma rev: 1 cache: 
           L2: 2 MiB 
           flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 14378 
           Speed: 998 MHz min/max: 1000/1800 MHz boost: enabled Core speeds (MHz): 1: 998 2: 998 3: 998 4: 997 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Mullins [Radeon R3 Graphics] vendor: Toshiba driver: radeon v: kernel 
           bus-ID: 00:01.0 
           Device-2: Chicony TOSHIBA Web Camera - HD type: USB driver: uvcvideo bus-ID: 3-1.1:3 
           Display: x11 server: X.Org 1.20.10 driver: loaded: ati,radeon unloaded: modesetting resolution: 1366x768~60Hz 
           OpenGL: renderer: AMD KABINI (DRM 2.50.0 5.4.108-1-MANJARO LLVM 11.1.0) v: 4.5 Mesa 21.0.1 direct render: Yes 
Audio:     Device-1: Advanced Micro Devices [AMD/ATI] Kabini HDMI/DP Audio vendor: Toshiba driver: snd_hda_intel v: kernel 
           bus-ID: 00:01.1 
           Device-2: Advanced Micro Devices [AMD] FCH Azalia vendor: Toshiba driver: snd_hda_intel v: kernel bus-ID: 00:14.2 
           Sound Server-1: ALSA v: k5.4.108-1-MANJARO running: yes 
           Sound Server-2: JACK v: 0.125.0 running: no 
           Sound Server-3: PulseAudio v: 14.2 running: yes 
           Sound Server-4: PipeWire v: 0.3.24 running: no 
Network:   Device-1: Realtek RTL810xE PCI Express Fast Ethernet vendor: Toshiba driver: r8169 v: kernel port: 3000 
           bus-ID: 01:00.0 
           IF: enp1s0 state: down mac: 2c:60:0c:b4:d6:64 
           Device-2: Realtek RTL8723BE PCIe Wireless Network Adapter driver: rtl8723be v: kernel port: 2000 bus-ID: 02:00.0 
           IF: wlp2s0 state: up mac: b8:86:87:af:25:ea 
           IP v4: type: dynamic noprefixroute scope: global 
           IP v6: fe80::7ac9:e7c:662:fc3d/64 type: noprefixroute scope: link 
           WAN IP: 
Bluetooth: Device-1: Toshiba Bluetooth Radio type: USB driver: btusb v: 0.8 bus-ID: 3-1.2:4 
           Report: This feature requires one of these tools: hciconfig/bt-adapter 
Drives:    Local Storage: total: 465.76 GiB used: 11.6 GiB (2.5%) 
           ID-1: /dev/sda vendor: Toshiba model: MQ01ABF050 size: 465.76 GiB 
Partition: ID-1: / size: 57.37 GiB used: 11.6 GiB (20.2%) fs: ext4 dev: /dev/sda9 
           ID-2: /boot/efi size: 511 MiB used: 440 KiB (0.1%) fs: vfat dev: /dev/sda7 
Swap:      ID-1: swap-1 type: partition size: 2 GiB used: 0 KiB (0.0%) dev: /dev/sda8 
Sensors:   System Temperatures: cpu: 49.4 C mobo: N/A gpu: radeon temp: 48.0 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 174 Uptime: 17m Memory: 6.75 GiB used: 1.58 GiB (23.4%) Init: systemd Compilers: gcc: 10.2.0 
           Packages: 1247 Shell: Bash v: 5.1.0 inxi: 3.3.03 

Here is my lsusb result,

Bus 003 Device 004: ID 0930:0222 Toshiba Corp. Bluetooth Radio 
Bus 003 Device 003: ID 04f2:b446 Chicony Electronics Co., Ltd TOSHIBA Web Camera - HD
Bus 003 Device 002: ID 0438:7900 Advanced Micro Devices, Inc. Root Hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 0438:7900 Advanced Micro Devices, Inc. Root Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 002: ID 046d:c077 Logitech, Inc. M105 Optical Mouse
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Any suggestions?